gnome-extra/gnome-documents: Version bump
authorPacho Ramos <pacho@gentoo.org>
Sun, 3 Apr 2016 10:09:28 +0000 (12:09 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sun, 3 Apr 2016 12:40:12 +0000 (14:40 +0200)
Package-Manager: portage-2.2.28

gnome-extra/gnome-documents/Manifest
gnome-extra/gnome-documents/gnome-documents-3.18.3.ebuild [new file with mode: 0644]

index efe295f197237c71bd8906f2e20e9ef7e7bd19c1..76a3c25c5b860d57019ba370a8a2c11b143bad58 100644 (file)
@@ -1 +1,2 @@
 DIST gnome-documents-3.18.2.tar.xz 2297404 SHA256 850ddaf3366549bbe0696c2ec3a36faf16438b387b8e9cb7812c7d5266a74cd4 SHA512 638ed9020d5204e5587e2241040fff6aa62fc7f1afd50e035f50c5038d1b72038233f2f1a001d89bf45f210344f83790a2c2358a24ee9692a30f3b663dd81dbd WHIRLPOOL 8a08fd0155ec60da7d1276ee4f25be2f7e3ddcfe09e9f0785dd952ab2a58bdcddcaaea8f83c558689613eb914d848209a24f8fd9e7a1e37ead1e208306523272
+DIST gnome-documents-3.18.3.tar.xz 2297720 SHA256 16a50d509d43009d58b44b5f6d4d92e155a55dcb22bd8e0fdfd63b8d2ab48b91 SHA512 69129100858434c99d3a47bfa776637e8d26eda5eb40d089f1c32da6ef1ecc3265c17cbcb657e944559dbca788445a66956c7aabbb24167ec095d8af4f4d29de WHIRLPOOL b5be7ad7ed8bc1ad484a94a1b83dc53389277181a63ccf16519b7bcf798e471082fa4d133173a6dc55628ba3a7ad2e37c8063f987ffd00a38c59efdea7749942
diff --git a/gnome-extra/gnome-documents/gnome-documents-3.18.3.ebuild b/gnome-extra/gnome-documents/gnome-documents-3.18.3.ebuild
new file mode 100644 (file)
index 0000000..9bbbd35
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="A document manager application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Documents"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+# Need gdk-pixbuf-2.25 for gdk_pixbuf_get_pixels_with_length
+COMMON_DEPEND="
+       >=app-misc/tracker-1:=[miner-fs]
+       >=app-text/evince-3.13.3[introspection]
+       dev-libs/gjs
+       >=dev-libs/glib-2.39.3:2
+       >=dev-libs/gobject-introspection-1.31.6:=
+       >=dev-libs/libgdata-0.13.3:=[crypt,gnome-online-accounts,introspection]
+       gnome-base/gnome-desktop:3=
+       >=media-libs/clutter-1.10:1.0
+       >=media-libs/clutter-gtk-1.3.2:1.0[introspection]
+       >=net-libs/gnome-online-accounts-3.2.0
+       >=net-libs/libsoup-2.41.3:2.4
+       >=net-libs/libzapojit-0.0.2
+       >=net-libs/webkit-gtk-2.6:4
+       >=x11-libs/gdk-pixbuf-2.25:2[introspection]
+       >=x11-libs/gtk+-3.15.5:3[introspection]
+       x11-libs/pango[introspection]
+"
+RDEPEND="${COMMON_DEPEND}
+       media-libs/clutter[introspection]
+       net-misc/gnome-online-miners
+       sys-apps/dbus
+       x11-themes/adwaita-icon-theme
+"
+DEPEND="${COMMON_DEPEND}
+       dev-libs/libxslt
+       >=dev-util/intltool-0.50.1
+       dev-util/itstool
+       virtual/pkgconfig
+"
+# eautoreconf requires yelp-tools
+
+src_prepare() {
+       # Prevent sandbox violation, https://bugzilla.gnome.org/show_bug.cgi?id=758097
+       sed -i -e '/-rm -f $(appdir)\/org.gnome.Books.data.gresource/d' data/Makefile.{am,in} || die
+       gnome2_src_prepare
+}