app-emulation/buildah: Bump to version 1.14.5
authorZac Medico <zmedico@gentoo.org>
Thu, 2 Apr 2020 00:20:56 +0000 (17:20 -0700)
committerZac Medico <zmedico@gentoo.org>
Thu, 2 Apr 2020 00:23:46 +0000 (17:23 -0700)
Bug: https://bugs.gentoo.org/715822
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Zac Medico <zmedico@gentoo.org>
app-emulation/buildah/Manifest
app-emulation/buildah/buildah-1.14.5.ebuild [new file with mode: 0644]

index 08a0935ed9cce31a324a6a0cac1c9e7db69b459a..0a16820320aa8bcd660e91d0929125ee40e97636 100644 (file)
@@ -6,4 +6,5 @@ DIST buildah-1.14.0.tar.gz 10895764 BLAKE2B afc99c12737651997785ce96793afbff24e5
 DIST buildah-1.14.2.tar.gz 11022035 BLAKE2B 8927d0d1c0ca75cc7fc739f990dbcb55a16ca34fee77a95fba629db6a5a73003ca320f85e6a9e4c4091e20877a7af00eee361c14b8b1758fe4bf690e179f6799 SHA512 d8f2488321cc52f1e2a390ffe975d83c4a6e9a169d47787715e0e04c29249abf501798bc3588d5d5c1bf70fc1a8451f75b102f629517da636cf9fd093667797c
 DIST buildah-1.14.3.tar.gz 11039144 BLAKE2B 30ee37b083fd59084e19a4a02f3d2e86a6abc73293e1046a271a0d54629eff1aa858f914c21d67e1226ba42c1b19579c764551de45dab30a3d8f6dc173ec851d SHA512 89bc4256b0bea5b74ef71d0918f60d447fc4b0cd069f65995cf7125ed6382574c85db1c6a8101fbcb1c7385b5bc1855ddb1d483f91dce787ebab20ce56fad7e7
 DIST buildah-1.14.4.tar.gz 11020829 BLAKE2B a70e8dd567a5fea56735b18434bf630d278bb1aef7bc8b3ef4dc761c844fd2c1fa5839554586c6d908f67fdd2f755900cc9ac454f975edfcf62669456109d1bf SHA512 74923a552294b5e35361f8446697822850952edcd9b4619e31bad1c3b2fbb0aeb491d598096d2f59cf7bf433a487f056f7229c7fe031cb790cbdc9b8ba12a2cd
+DIST buildah-1.14.5.tar.gz 11023227 BLAKE2B ebd6cecfc6fa4635ae662dddc722a350fd0b9c87c3d4d67f8010d5ea070270da4f4cd5759612b84d55ecd27b90904950b96471d75057bc6b7d45989312ebec8e SHA512 759d2ba26af43d6ff7ee891f88114a0cde6307439f7837343bfa6edba2473805f0f2e584264e8be01b9f0af07b1fd323243af5feeb9535ada4475ce53a980ff6
 DIST containers-storage-1.14.0-vfs-user-xattrs.patch 14835 BLAKE2B 99c35933dcb25385ee83b80cf282c11c738d0e4d91216cc08a50522f6caa9bca5938299412908f16df404f99e80616a10b4c02c0ebc38240a987830ddaf15008 SHA512 62c7ed49728bd12b5706f59b0d4af3b18d90e8cfc2b06e681f84fe3f5d3e0cd5c0317147109c4e3ec4fec26f82c269af3c9813e47339ce102e4e97400b74627d
diff --git a/app-emulation/buildah/buildah-1.14.5.ebuild b/app-emulation/buildah/buildah-1.14.5.ebuild
new file mode 100644 (file)
index 0000000..079c231
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit bash-completion-r1 go-module
+
+KEYWORDS="~amd64"
+DESCRIPTION="A tool that facilitates building OCI images"
+HOMEPAGE="https://github.com/containers/buildah"
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+IUSE="selinux"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT=5247a1f
+SRC_URI="https://github.com/containers/buildah/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+RDEPEND="app-crypt/gpgme:=
+       app-emulation/skopeo
+       dev-libs/libgpg-error:=
+       dev-libs/libassuan:=
+       sys-fs/lvm2:=
+       sys-libs/libseccomp:=
+       selinux? ( sys-libs/libselinux:= )"
+DEPEND="${RDEPEND}"
+RESTRICT="test"
+
+src_prepare() {
+       default
+       [[ -f selinux_tag.sh ]] || die
+       use selinux || { echo -e "#!/bin/sh\ntrue" > \
+               selinux_tag.sh || die; }
+}
+
+src_compile() {
+       emake GIT_COMMIT=${GIT_COMMIT} all
+}
+
+src_install() {
+       dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
+       doman docs/*.1
+       dodoc -r docs/tutorials
+       dobin ${PN} imgtype
+       dobashcomp contrib/completions/bash/buildah
+}
+
+src_test() {
+       emake test-unit
+}