app-portage/mgorny-dev-scripts: Bump to v5
authorMichał Górny <mgorny@gentoo.org>
Thu, 28 May 2020 09:35:06 +0000 (11:35 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 28 May 2020 09:35:26 +0000 (11:35 +0200)
Now with rdep caching.

Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-portage/mgorny-dev-scripts/Manifest
app-portage/mgorny-dev-scripts/mgorny-dev-scripts-5.ebuild [new file with mode: 0644]

index 2762d028ac79de69badd6250fa7a37f8f61bdb86..453015e3da2041c0603bc21ac7ed7ac352c0b24b 100644 (file)
@@ -1 +1,2 @@
 DIST mgorny-dev-scripts-4.tar.gz 6702 BLAKE2B d816e0d15004d21f595e6020d146aa1babfe238b325afb1523bfae60786c067c8591fa5b046f7b18520f5334e0d0506d9d0c919c2ec6a55a85bae09441d1f45c SHA512 0b165f21930ad29de92a715fab27174e2bf2e16e6b52dac2d5bf6ae59c68163f30de955703c2c37a9a799fd4409d1b602d417100a4787787f4b48fd71e6391e3
+DIST mgorny-dev-scripts-5.tar.gz 6834 BLAKE2B 652db4d1be6c5438b9b71fb814cde2424c92fdf1aa88266761beb899a782df34a5f02c39a4f18d1cac471aaee2d0ad8f94a960e86b09144494db0e4438505b1a SHA512 fb1fd66ea8d8757bb0b81285c6d821cf8548001d39c47d028e8367865b67c594187086ed18b21c8f87e0d702d879dcf55c043404f3337b27a1d943cae78b0765
diff --git a/app-portage/mgorny-dev-scripts/mgorny-dev-scripts-5.ebuild b/app-portage/mgorny-dev-scripts/mgorny-dev-scripts-5.ebuild
new file mode 100644 (file)
index 0000000..43affbe
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Handy scripts for ebuild development and more"
+HOMEPAGE="https://github.com/mgorny/mgorny-dev-scripts"
+SRC_URI="https://github.com/mgorny/mgorny-dev-scripts/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       app-portage/gentoolkit
+       dev-perl/URI
+       dev-vcs/git
+       net-misc/wget
+       sys-apps/portage
+       x11-misc/xdg-utils
+       !dev-util/pkgdiff"
+
+src_install() {
+       dodoc README.rst
+       rm -f COPYING README.rst || die
+       dobin *
+}