net-libs/libbtbb: version bump
authorZero_Chaos <zerochaos@gentoo.org>
Sat, 5 Sep 2015 02:31:40 +0000 (22:31 -0400)
committerZero_Chaos <zerochaos@gentoo.org>
Sat, 5 Sep 2015 02:31:48 +0000 (22:31 -0400)
net-libs/libbtbb/Manifest
net-libs/libbtbb/libbtbb-2015.09.1.ebuild [new file with mode: 0644]

index 66ade0f2b863c3ab664bd4137d7375aaa3084ae3..88b6fd391b33d5674c204e6337ede33776e67708 100644 (file)
@@ -1 +1,2 @@
 DIST libbtbb-2014-02-R4.tar.gz 165417 SHA256 6e79a2d8530596e34ad13fcce43dcf8b30b165d4629d5bf9c3eb7f8817980524 SHA512 9ab5ca45f9a88c78f8238c73eabbd04c69723e4ac9171551e3e073eff06acd5ad4197ea4f87036ae066aebb0d15705249899d2b7475e56bd224c83df6f0bd8d5 WHIRLPOOL 30fdc8948f5d1dd057887369f12a5660b1faabe14933ad876c00161fbd43dcebc80f512e370d4b8f56525a8bdcad057a4da8c545814276a65a691bb8e85383fb
+DIST libbtbb-2015-09-R1.tar.gz 222558 SHA256 6f68eae9f8504facce33c42ee790a4ba5dbc79d89564c9a10e9e25b6eb8328b1 SHA512 30b8e376fe4be0e0a5856256cff17f889f154ff7c76ab359cab3eb62bf7f3defc9bae00150a332954f10e60a5cbb84e0ae4595f5298fe3333235b8f6b252990b WHIRLPOOL 1805eb41f7cf4814c3d2f689157b22efd25f8a5dc12f2eb407d61487bd3d270bd630b3b9c54a8e65aa523a8538d61405661267fdffc1975b42ebd4b4b6f4d84c
diff --git a/net-libs/libbtbb/libbtbb-2015.09.1.ebuild b/net-libs/libbtbb/libbtbb-2015.09.1.ebuild
new file mode 100644 (file)
index 0000000..3d12be1
--- /dev/null
@@ -0,0 +1,133 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib cmake-utils
+
+DESCRIPTION="A library to decode Bluetooth baseband packets"
+HOMEPAGE="http://libbtbb.sourceforge.net/"
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/greatscottgadgets/libbtbb.git"
+       inherit git-r3
+       KEYWORDS=""
+else
+       MY_PV=${PV/\./-}
+       MY_PV=${MY_PV/./-R}
+       S=${WORKDIR}/${PN}-${MY_PV}
+       SRC_URI="https://github.com/greatscottgadgets/${PN}/archive/${MY_PV}.tar.gz -> ${PN}-${MY_PV}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE="+pcap +wireshark-plugins"
+
+RDEPEND="
+       pcap? ( net-libs/libpcap )
+       wireshark-plugins? (
+               >=net-analyzer/wireshark-1.8.3-r1:=
+               !>net-analyzer/wireshark-1.98
+       )
+"
+DEPEND="${RDEPEND}
+       wireshark-plugins? ( dev-libs/glib
+                       virtual/pkgconfig )"
+
+get_PV() { local pv=$(best_version $1); pv=${pv#$1-}; pv=${pv%-r*}; pv=${pv//_}; echo ${pv}; }
+
+which_plugins() {
+       if has_version '>=net-analyzer/wireshark-1.12.0'; then
+               plugins="btbb btbredr"
+       elif has_version '<net-analyzer/wireshark-1.12.0'; then
+               plugins="btbb btle btsm"
+       fi
+}
+
+src_prepare(){
+       CMAKE_USE_DIR="${S}"
+       BUILD_DIR="${S}"_build
+       cmake-utils_src_prepare
+
+       if use wireshark-plugins; then
+               which_plugins
+               for i in ${plugins}
+               do
+                       sed -i 's#column_info#packet#' wireshark/plugins/${i}/cmake/FindWireshark.cmake || die
+                       CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
+                       BUILD_DIR="${WORKDIR}"/${i}_build
+                       cmake-utils_src_prepare
+               done
+       fi
+}
+
+src_configure() {
+       CMAKE_USE_DIR="${S}"
+       BUILD_DIR="${S}"_build
+       local mycmakeargs=(
+               -DDISABLE_PYTHON=true
+               -DPACKAGE_MANAGER=true
+               $(cmake-utils_use pcap PCAPDUMP)
+               $(cmake-utils_use pcap USE_PCAP)
+       )
+       cmake-utils_src_configure
+
+       if use wireshark-plugins; then
+               for i in ${plugins}
+               do
+                       CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
+                       BUILD_DIR="${WORKDIR}"/${i}_build
+                       local mycmakeargs=(
+                       -DCMAKE_INSTALL_LIBDIR="/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)"
+                       )
+                       cmake-utils_src_configure
+               done
+       fi
+}
+
+src_compile(){
+       CMAKE_USE_DIR="${S}"
+       BUILD_DIR="${S}"_build
+       cmake-utils_src_compile
+
+       if use wireshark-plugins; then
+               for i in ${plugins}
+               do
+                       CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
+                       BUILD_DIR="${WORKDIR}"/${i}_build
+                       cmake-utils_src_compile
+               done
+       fi
+}
+
+src_test(){
+       CMAKE_USE_DIR="${S}"
+       BUILD_DIR="${S}"_build
+       cmake-utils_src_test
+
+       if use wireshark-plugins; then
+               for i in ${plugins}
+               do
+                       CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
+                       BUILD_DIR="${WORKDIR}"/${i}_build
+                       cmake-utils_src_test
+               done
+       fi
+}
+
+src_install(){
+       CMAKE_USE_DIR="${S}"
+       BUILD_DIR="${S}"_build
+       cmake-utils_src_install
+
+       if use wireshark-plugins; then
+               for i in ${plugins}
+               do
+                       CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
+                       BUILD_DIR="${WORKDIR}"/${i}_build
+                       cmake-utils_src_install
+               done
+       fi
+}