dev-python/python-sipsimple: initial import of version 2.5.1
authorJulian Ospald <hasufell@gentoo.org>
Tue, 8 Sep 2015 10:51:54 +0000 (12:51 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Tue, 8 Sep 2015 17:40:15 +0000 (19:40 +0200)
Gentoo-Bug: 446024

dev-python/python-sipsimple/Manifest [new file with mode: 0644]
dev-python/python-sipsimple/metadata.xml [new file with mode: 0644]
dev-python/python-sipsimple/python-sipsimple-2.5.1.ebuild [new file with mode: 0644]

diff --git a/dev-python/python-sipsimple/Manifest b/dev-python/python-sipsimple/Manifest
new file mode 100644 (file)
index 0000000..afb8b46
--- /dev/null
@@ -0,0 +1 @@
+DIST python-sipsimple-2.5.1.tar.gz 4794640 SHA256 b7706e6a31edbffcac468a8b2df23cb75b34e8f21bcd702760c718a4f516fe6e SHA512 912fe763bfdc440984d08c5a7105db37322f24c3d8ddb1b4ab2bf9c59b21ae510b9b977a819b671369d9eaf0e6118ebc3b78402546a8d7b953ecd9a5b58d26df WHIRLPOOL 8f5c5d76a383a7c52b62fc1c85cf9d07ab2589a3adaf6572565fbaf1bc7fdcad54eab329b40d80696b6092e96ab058b493aca8c3597f9ed958577219c0683394
diff --git a/dev-python/python-sipsimple/metadata.xml b/dev-python/python-sipsimple/metadata.xml
new file mode 100644 (file)
index 0000000..2b568d8
--- /dev/null
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <herd>python</herd>
+       <maintainer>
+               <email>hasufell@gentoo.org</email>
+               <name>Julian Ospald</name>
+       </maintainer>
+       <longdescription lang="en">
+               SIP SIMPLE client SDK is a Software Development Kit for easy
+               development of SIP end-points that support rich media like Audio,
+               Video, Instant Messaging, File Transfers, Desktop Sharing and Presence.
+               Other media types can be easily added by using an extensible high-level
+               API.
+
+               The software has undergone in the past years several interoperability
+               tests at SIPIT (http://www.sipit.net) and today is of industry strength
+               quality.
+       </longdescription>
+</pkgmetadata>
diff --git a/dev-python/python-sipsimple/python-sipsimple-2.5.1.ebuild b/dev-python/python-sipsimple/python-sipsimple-2.5.1.ebuild
new file mode 100644 (file)
index 0000000..10e1c45
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="SIP SIMPLE client SDK is a Software Development Kit"
+HOMEPAGE="http://sipsimpleclient.org"
+SRC_URI="http://download.ag-projects.com/SipClient/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="
+       dev-db/sqlite:3
+       dev-libs/openssl:0
+       dev-python/python-application[${PYTHON_USEDEP}]
+       media-libs/alsa-lib
+       media-libs/libv4l
+       media-libs/libvpx
+       sys-apps/util-linux
+       virtual/ffmpeg
+"
+RDEPEND="${CDEPEND}
+       dev-python/dnspython[${PYTHON_USEDEP}]
+       dev-python/python-cjson[${PYTHON_USEDEP}]
+       dev-python/python-dateutil[${PYTHON_USEDEP}]
+       dev-python/python-eventlib[${PYTHON_USEDEP}]
+       dev-python/greenlet[${PYTHON_USEDEP}]
+       dev-python/python-gnutls[${PYTHON_USEDEP}]
+       dev-python/lxml[${PYTHON_USEDEP}]
+       dev-python/python-msrplib[${PYTHON_USEDEP}]
+       dev-python/python-xcaplib[${PYTHON_USEDEP}]
+       dev-python/twisted-core[${PYTHON_USEDEP}]
+       dev-python/zope-interface[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+       dev-python/cython[${PYTHON_USEDEP}]
+       virtual/pkgconfig
+"