dev-ruby/net-http-pipeline: add ruby26
authorHans de Graaff <graaff@gentoo.org>
Thu, 31 Jan 2019 06:58:38 +0000 (07:58 +0100)
committerHans de Graaff <graaff@gentoo.org>
Thu, 31 Jan 2019 07:35:09 +0000 (08:35 +0100)
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild

index a8ecd68283ff00e45ac3d5b93cfa9ce8387225ec..0f4ded070376a99bb880567b6c967b23ab4db6e2 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
-USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
 
 inherit ruby-fakegem
@@ -18,6 +18,9 @@ IUSE=""
 RUBY_PATCHES=( ${PN}-accept-encoding.patch )
 
 ruby_add_bdepend "
-       dev-ruby/hoe
        test? ( dev-ruby/minitest )
 "
+
+each_ruby_test() {
+       ${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}