dev-python/zope-testing: Revbump to 4.7-r1 add py38
authorPatrick McLean <patrick.mclean@sony.com>
Thu, 21 Nov 2019 03:52:06 +0000 (19:52 -0800)
committerPatrick McLean <chutzpah@gentoo.org>
Thu, 21 Nov 2019 03:52:06 +0000 (19:52 -0800)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/zope-testing/zope-testing-4.7-r1.ebuild [moved from dev-python/zope-testing/zope-testing-4.7.ebuild with 86% similarity]

similarity index 86%
rename from dev-python/zope-testing/zope-testing-4.7.ebuild
rename to dev-python/zope-testing/zope-testing-4.7-r1.ebuild
index acd8b7e0fa29be1f1670bfc6bae65f1b8a1aae95..91f48c8f12c7a5db15d332a78469918eb789b72c 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
 inherit distutils-r1
 
 MY_PN=${PN/-/.}
@@ -22,11 +22,9 @@ RDEPEND="dev-python/namespace-zope[${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
        dev-python/setuptools[${PYTHON_USEDEP}]"
 
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
 
-python_test() {
-       esetup.py test
-}
+distutils_enable_tests setup.py
 
 python_install_all() {
        distutils-r1_python_install_all