Added dev-util/boost-build for the upcoming boost-1.34 release
authorTiziano Müller <dev-zero@gentoo.org>
Mon, 18 Dec 2006 23:06:50 +0000 (23:06 +0000)
committerTiziano Müller <dev-zero@gentoo.org>
Mon, 18 Dec 2006 23:06:50 +0000 (23:06 +0000)
Package-Manager: portage-2.1.2_rc3

dev-util/boost-build/ChangeLog [new file with mode: 0644]
dev-util/boost-build/Manifest [new file with mode: 0644]
dev-util/boost-build/boost-build-1.34_pre20061214.ebuild [new file with mode: 0644]
dev-util/boost-build/files/digest-boost-build-1.34_pre20061214 [new file with mode: 0644]
dev-util/boost-build/metadata.xml [new file with mode: 0644]

diff --git a/dev-util/boost-build/ChangeLog b/dev-util/boost-build/ChangeLog
new file mode 100644 (file)
index 0000000..1113d3e
--- /dev/null
@@ -0,0 +1,10 @@
+# ChangeLog for dev-util/boost-build
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/ChangeLog,v 1.1 2006/12/18 23:06:50 dev-zero Exp $
+
+*boost-build-1.34_pre20061214 (18 Dec 2006)
+
+  18 Dec 2006; Tiziano Müller <dev-zero@gentoo.org> +metadata.xml,
+  +boost-build-1.34_pre20061214.ebuild:
+  Initial commit.
+
diff --git a/dev-util/boost-build/Manifest b/dev-util/boost-build/Manifest
new file mode 100644 (file)
index 0000000..2a7be43
--- /dev/null
@@ -0,0 +1,16 @@
+DIST boost_1_34_pre20061214.tar.bz2 12357020 RMD160 51a96ef3dc28b4bd1d5fc3c295a4a3f874fe59fa SHA1 62e6fc5ea23aec68e26282068e950c0ca035f846 SHA256 4c88805afe6b47366d960d878eec8a6e0e7f40a7f9122a7d877020e9102d0e49
+EBUILD boost-build-1.34_pre20061214.ebuild 1865 RMD160 3070cde599520cb014a194a00a56d6d34022989c SHA1 21a19896a0539359eb08660d1c5db32dcc68c4ad SHA256 6bf9d1b3b0fadb305d1d6c0f2f6dbfd08b9cdc257289de2379d9799742d1bd7d
+MD5 9f520606712337da813a3c585cbf2907 boost-build-1.34_pre20061214.ebuild 1865
+RMD160 3070cde599520cb014a194a00a56d6d34022989c boost-build-1.34_pre20061214.ebuild 1865
+SHA256 6bf9d1b3b0fadb305d1d6c0f2f6dbfd08b9cdc257289de2379d9799742d1bd7d boost-build-1.34_pre20061214.ebuild 1865
+MISC ChangeLog 387 RMD160 a5386ad2b6dc63fe7c5ac3447998fa3bfdd642a5 SHA1 3da37357cdcd5e0494645d4f2269796a65185732 SHA256 4df1ec5dba1a90341e36522800f90dcb9e65f73cf85908fbde9d750a8489ec65
+MD5 b494214418272382115eecfe73912648 ChangeLog 387
+RMD160 a5386ad2b6dc63fe7c5ac3447998fa3bfdd642a5 ChangeLog 387
+SHA256 4df1ec5dba1a90341e36522800f90dcb9e65f73cf85908fbde9d750a8489ec65 ChangeLog 387
+MISC metadata.xml 261 RMD160 5334f981ef24f0e2d90bbf1fc1acfa0861684476 SHA1 9c795ec41d3c4c6c284fc88f292ae04c23083f56 SHA256 3207c8a2b1789cb857ab68170ddb6d4e9e4f970e4a110119e62e7fac0b9f6ddb
+MD5 27ff5413a93c29035d82d94e5d7d6d9a metadata.xml 261
+RMD160 5334f981ef24f0e2d90bbf1fc1acfa0861684476 metadata.xml 261
+SHA256 3207c8a2b1789cb857ab68170ddb6d4e9e4f970e4a110119e62e7fac0b9f6ddb metadata.xml 261
+MD5 4d2c7622840a8822a22de0b6b476a878 files/digest-boost-build-1.34_pre20061214 277
+RMD160 9a9df1d0836e4228bb0555168feaec083d916c49 files/digest-boost-build-1.34_pre20061214 277
+SHA256 06642f8f05261ead16839bb8350548064c469dba0f16992c748e9a3c2b0b0f46 files/digest-boost-build-1.34_pre20061214 277
diff --git a/dev-util/boost-build/boost-build-1.34_pre20061214.ebuild b/dev-util/boost-build/boost-build-1.34_pre20061214.ebuild
new file mode 100644 (file)
index 0000000..ee11ec2
--- /dev/null
@@ -0,0 +1,70 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.34_pre20061214.ebuild,v 1.1 2006/12/18 23:06:50 dev-zero Exp $
+
+inherit toolchain-funcs versionator
+
+KEYWORDS="~amd64 ~x86"
+
+MY_PV=$(replace_all_version_separators _)
+
+DESCRIPTION="A system for large project software construction, which is simple to use and powerfull."
+HOMEPAGE="http://www.boost.org/tools/build/v2/index.html"
+SRC_URI="http://dev.gentoo.org/~dev-zero/distfiles/boost_${MY_PV}.tar.bz2"
+LICENSE="Boost-1.0"
+SLOT="0"
+IUSE="icc"
+
+DEPEND="!<dev-libs/boost-1.34_pre20060930"
+RDEPEND=""
+
+S=${WORKDIR}/boost_${MY_PV}/tools
+
+src_unpack() {
+       unpack ${A}
+
+       # Remove stripping option
+       cd "${S}/jam/src"
+       sed -i \
+               -e 's/-s\b//' \
+               build.jam || die "sed failed"
+
+       # This patch allows us to fully control optimization
+       # and stripping flags when bjam is used as build-system
+       # We simply extend the optimization and debug-symbols feature
+       # with empty dummies called 'none'
+       cd "${S}/build/v2"
+       sed -i \
+               -e 's/\(feature optimization : off speed space\)/\1 none/' \
+               -e 's/\(feature debug-symbols : on off\)/\1 none/' \
+               tools/builtin.jam || die "sed failed"
+}
+
+src_compile() {
+
+       cd jam/src
+       local toolset
+
+       if use icc ; then
+               toolset=intel-linux
+               sed -i \
+                       -e "s#/opt/intel/cc/9.0#${IA32ROOT}#" \
+                       build.sh || die "sed failed"
+       elif [ "${ARCH}" == "ppc-macos" ] ; then
+               toolset=darwin
+       else
+               # Using boost's generic toolset here, which respects CC and CFLAGS
+               toolset=cc
+       fi
+
+       CC=$(tc-getCC) ./build.sh ${toolset} || die "building bjam failed"
+}
+
+src_install() {
+       dobin jam/src/bin.*/bjam
+
+       cd "${S}/build/v2"
+       insinto /usr/share/boost-build
+       doins -r boost-build.jam bootstrap.jam build-system.jam site-config.jam user-config.jam \
+               build kernel options tools util
+}
diff --git a/dev-util/boost-build/files/digest-boost-build-1.34_pre20061214 b/dev-util/boost-build/files/digest-boost-build-1.34_pre20061214
new file mode 100644 (file)
index 0000000..ed25c5f
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 c2ecc5f9f12198eb7fe116a14edd65a5 boost_1_34_pre20061214.tar.bz2 12357020
+RMD160 51a96ef3dc28b4bd1d5fc3c295a4a3f874fe59fa boost_1_34_pre20061214.tar.bz2 12357020
+SHA256 4c88805afe6b47366d960d878eec8a6e0e7f40a7f9122a7d877020e9102d0e49 boost_1_34_pre20061214.tar.bz2 12357020
diff --git a/dev-util/boost-build/metadata.xml b/dev-util/boost-build/metadata.xml
new file mode 100644 (file)
index 0000000..64e111f
--- /dev/null
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <herd>cpp</herd>
+  <maintainer>
+    <email>dev-zero@gentoo.org</email>
+    <name>Tiziano Müller</name>
+  </maintainer>
+</pkgmetadata>