dev-python/sphinx: Clean old up
authorMichał Górny <mgorny@gentoo.org>
Sat, 6 Jan 2018 11:12:28 +0000 (12:12 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 6 Jan 2018 13:39:28 +0000 (14:39 +0100)
dev-python/sphinx/Manifest
dev-python/sphinx/sphinx-1.5.2.ebuild [deleted file]
dev-python/sphinx/sphinx-1.6.3-r1.ebuild [deleted file]

index ac77ecb60059008a14ba91925bff6cf001cf2412..768256e43fd674a3a783643ca11c78b6017fa9fc 100644 (file)
@@ -2,5 +2,4 @@ DIST Sphinx-1.2.2.tar.gz 3143671 BLAKE2B a21b2a060363ac86832a6a28a623ed410ff0bb3
 DIST Sphinx-1.2.3.tar.gz 3200548 BLAKE2B 42033c59e6e38247af12c78cb4f69c73b1dfa883aa8a9e6c180bb74de666b45faef24a55c0bfd3aa1f22bf3e632e0e95016eb1bea54e8b5ebc7df78756763b5c SHA512 00346516e826a65145a3a7fd25ef7cee569ae7fdcc0c1bec3a7301fc08d5d8730d02eee792c3efedfcac17e712ea7e2ad70ea1fcdedc11720ad54f6bcb51ad05
 DIST Sphinx-1.3.1.tar.gz 3469782 BLAKE2B ae2fa602a7873e6ef735decc2dcdd5a2632b848bb8394ee80b4215e21bfe625645fbf905a6661c333ad062e17f15b6f2c39027b44ad827f66c6467a78e8c4490 SHA512 8b92b69c4ced242c5e608ea03a7a061b0d2908f34f3150048ff4ce08b5d56be4a642a6aec13fa249ff8208fa8dd2d38d8a10d37ebbcc68385ee51f527ede0b94
 DIST Sphinx-1.3.5.tar.gz 3679978 BLAKE2B 2a88859bfd4a3de75a7b56fce65086e1239c3c58730280df078b3f76d368028a124aa6d4ca65c40773efa4c1a83dd047ea0d647582057c63bf82dadb5f2549e9 SHA512 90eda9cdbd24575d9f763e5c35e176d9970d1c83dd06dd41e9137f5c6035738fd21c4c57ff98810fc8adf91fa625192e6534bf0bbf70e78cc98f73df59eaabbc
-DIST Sphinx-1.5.2.tar.gz 4418646 BLAKE2B 4622a9df53d72f05f24e8060b348904dc3d2cce043c2f06c471cad96f4831b38ba2095cb8fe1f42dfd50531126ceaf5ed8d5bb611c18c536e9585a15d578b6ae SHA512 32c8fb98d72e998fcce8c46ceddcbb0a0776d0e9ce75dc96cef48139b8b47ebe9636243fb48b9e04c8e1d5c56e09fc4c60248fbbef810fba9813b83a3e6cbe88
 DIST Sphinx-1.6.3.tar.gz 4674251 BLAKE2B ba13de3d72fbc5cbc3632a1062001ed287798efe5f04064d241b645d6e4c52c9d9c115aaae4ae7b94213bbddf595a93480788d66b3a54eac3c9fb415d007d4ca SHA512 d5aec58e19239db4e61fcd6b103fcc838d97aad5a7aaf9279ff1097791d9cd1ba245989307a2d1049c123058b84ca4e91db192a1672c040d80fafed3907736ae
diff --git a/dev-python/sphinx/sphinx-1.5.2.ebuild b/dev-python/sphinx/sphinx-1.5.2.ebuild
deleted file mode 100644 (file)
index 3c0a844..0000000
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 eutils versionator
-
-DESCRIPTION="Python documentation generator"
-HOMEPAGE="http://sphinx.pocoo.org/ https://pypi.python.org/pypi/Sphinx"
-SRC_URI="mirror://pypi/S/${PN^}/${P^}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ia64 ~ppc ~ppc64 ~x86"
-IUSE="doc latex net test"
-
-RDEPEND="
-       >=dev-python/alabaster-0.7.9[${PYTHON_USEDEP}]
-       <dev-python/alabaster-0.8[${PYTHON_USEDEP}]
-       >=dev-python/docutils-0.11[${PYTHON_USEDEP}]
-       >=dev-python/jinja-2.3[${PYTHON_USEDEP}]
-       >=dev-python/pygments-2.0.1-r1[${PYTHON_USEDEP}]
-       >=dev-python/six-1.5[${PYTHON_USEDEP}]
-       >=dev-python/Babel-2.1.1[${PYTHON_USEDEP}]
-       dev-python/requests[${PYTHON_USEDEP}]
-       >=dev-python/snowballstemmer-1.1[${PYTHON_USEDEP}]
-       >=dev-python/sphinx_rtd_theme-0.1[${PYTHON_USEDEP}]
-       <dev-python/sphinx_rtd_theme-2.0[${PYTHON_USEDEP}]
-       dev-python/imagesize[${PYTHON_USEDEP}]
-       latex? (
-               dev-texlive/texlive-latexextra
-               app-text/dvipng
-       )
-       net? (
-               >=dev-python/sqlalchemy-0.9[${PYTHON_USEDEP}]
-               >=dev-python/whoosh-2.0[${PYTHON_USEDEP}]
-       )"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/mock[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/simplejson[${PYTHON_USEDEP}]' pypy)
-               dev-python/html5lib[${PYTHON_USEDEP}]
-               >=dev-python/sqlalchemy-0.9[${PYTHON_USEDEP}]
-               >=dev-python/whoosh-2.0[${PYTHON_USEDEP}]
-               dev-python/flake8[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-cov[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'pypy*' 'python2*')
-               $(python_gen_cond_dep 'dev-python/typing[${PYTHON_USEDEP}]' 'pypy*' 'python2*' python3_4 )
-       )"
-
-S="${WORKDIR}/${P^}"
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-1.5.1-fix-pycode-grammar.patch
-)
-
-python_prepare_all() {
-       # remove tests that fail due to network-sandbox
-       rm tests/test_websupport.py || die "Failed to remove web tests"
-       rm tests/test_searchadapters.py || die "Failed to remove web tests"
-       rm tests/test_build_linkcheck.py || die "Failed to remove web tests"
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile() {
-       distutils-r1_python_compile
-
-       # Generate the grammar. It will be caught by install somehow.
-       # Note that the tests usually do it for us. However, I don't want
-       # to trust USE=test really running all the tests, especially
-       # with FEATURES=test-fail-continue.
-       pushd "${BUILD_DIR}"/lib >/dev/null || die
-       "${EPYTHON}" -m sphinx.pycode.__init__ || die "Grammar generation failed."
-       popd >/dev/null || die
-}
-
-python_compile_all() {
-       if use doc; then
-               emake -C doc SPHINXBUILD='"${EPYTHON}" "${S}/sphinx-build.py"' html
-               HTML_DOCS=( doc/_build/html/. )
-       fi
-}
-
-python_test() {
-       mkdir -p "${BUILD_DIR}/sphinx_tempdir" || die
-       local -x SPHINX_TEST_TEMPDIR="${BUILD_DIR}/sphinx_tempdir"
-       cp -r -l tests "${BUILD_DIR}"/ || die "Failed to copy tests"
-       cp Makefile "${BUILD_DIR}"/ || die "Failed to copy Makefile"
-       emake test
-}
-
-pkg_postinst() {
-       replacing_python_eclass() {
-               local pv
-               for pv in ${REPLACING_VERSIONS}; do
-                       if ! version_is_at_least 1.1.3-r4 ${pv}; then
-                               return 0
-                       fi
-               done
-
-               return 1
-       }
-
-       if replacing_python_eclass; then
-               ewarn "Replaced a very old sphinx version. If you are"
-               ewarn "experiencing problems, please re-emerge sphinx."
-       fi
-}
diff --git a/dev-python/sphinx/sphinx-1.6.3-r1.ebuild b/dev-python/sphinx/sphinx-1.6.3-r1.ebuild
deleted file mode 100644 (file)
index 4633c97..0000000
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 eutils versionator
-
-DESCRIPTION="Python documentation generator"
-HOMEPAGE="http://www.sphinx-doc.org/"
-SRC_URI="mirror://pypi/S/${PN^}/${P^}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc latex net test"
-
-RDEPEND="
-       >=dev-python/alabaster-0.7.9[${PYTHON_USEDEP}]
-       <dev-python/alabaster-0.8[${PYTHON_USEDEP}]
-       >=dev-python/Babel-2.1.1[${PYTHON_USEDEP}]
-       >=dev-python/docutils-0.11[${PYTHON_USEDEP}]
-       dev-python/imagesize[${PYTHON_USEDEP}]
-       >=dev-python/jinja-2.3[${PYTHON_USEDEP}]
-       >=dev-python/pygments-2.0.1-r1[${PYTHON_USEDEP}]
-       dev-python/requests[${PYTHON_USEDEP}]
-       >=dev-python/six-1.5[${PYTHON_USEDEP}]
-       >=dev-python/snowballstemmer-1.1[${PYTHON_USEDEP}]
-       >=dev-python/sphinx_rtd_theme-0.1[${PYTHON_USEDEP}]
-       <dev-python/sphinx_rtd_theme-2.0[${PYTHON_USEDEP}]
-       dev-python/typing[${PYTHON_USEDEP}]
-       latex? (
-               dev-texlive/texlive-latexextra
-               dev-texlive/texlive-luatex
-               app-text/dvipng
-       )
-       net? (
-               >=dev-python/sqlalchemy-0.9[${PYTHON_USEDEP}]
-               >=dev-python/whoosh-2.0[${PYTHON_USEDEP}]
-       )"
-PDEPEND="dev-python/sphinxcontrib-websupport[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/sphinxcontrib-websupport[${PYTHON_USEDEP}]
-               dev-python/flake8[${PYTHON_USEDEP}]
-               dev-python/html5lib[${PYTHON_USEDEP}]
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-cov[${PYTHON_USEDEP}]
-               dev-python/simplejson[${PYTHON_USEDEP}]
-               >=dev-python/sqlalchemy-0.9[${PYTHON_USEDEP}]
-               >=dev-python/whoosh-2.0[${PYTHON_USEDEP}]
-               virtual/imagemagick-tools[jpeg,png,svg]
-               virtual/python-enum34[${PYTHON_USEDEP}]
-       )"
-
-S="${WORKDIR}/${P^}"
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-1.5.1-fix-pycode-grammar.patch
-)
-
-python_prepare_all() {
-       # remove tests that fail due to network-sandbox
-       rm tests/test_websupport.py || die "Failed to remove web tests"
-       rm tests/test_build_linkcheck.py || die "Failed to remove web tests"
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile() {
-       distutils-r1_python_compile
-
-       # Generate the grammar. It will be caught by install somehow.
-       # Note that the tests usually do it for us. However, I don't want
-       # to trust USE=test really running all the tests, especially
-       # with FEATURES=test-fail-continue.
-       pushd "${BUILD_DIR}"/lib >/dev/null || die
-       "${EPYTHON}" -m sphinx.pycode.__init__ || die "Grammar generation failed."
-       popd >/dev/null || die
-}
-
-python_compile_all() {
-       if use doc; then
-               emake -C doc SPHINXBUILD='"${EPYTHON}" "${S}/sphinx-build.py"' html
-               HTML_DOCS=( doc/_build/html/. )
-       fi
-}
-
-python_test() {
-       mkdir -p "${BUILD_DIR}/sphinx_tempdir" || die
-       local -x SPHINX_TEST_TEMPDIR="${BUILD_DIR}/sphinx_tempdir"
-       cp -r -l tests "${BUILD_DIR}"/ || die "Failed to copy tests"
-       cp Makefile "${BUILD_DIR}"/ || die "Failed to copy Makefile"
-       emake test
-}
-
-pkg_postinst() {
-       replacing_python_eclass() {
-               local pv
-               for pv in ${REPLACING_VERSIONS}; do
-                       if ! version_is_at_least 1.1.3-r4 ${pv}; then
-                               return 0
-                       fi
-               done
-
-               return 1
-       }
-
-       if replacing_python_eclass; then
-               ewarn "Replaced a very old sphinx version. If you are"
-               ewarn "experiencing problems, please re-emerge sphinx."
-       fi
-}