sci-electronics/kicad: Add sub-slot operator on boost
authorSven Wegener <swegener@gentoo.org>
Fri, 15 Nov 2019 14:45:04 +0000 (15:45 +0100)
committerSven Wegener <swegener@gentoo.org>
Fri, 15 Nov 2019 14:45:34 +0000 (15:45 +0100)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Sven Wegener <swegener@gentoo.org>
sci-electronics/kicad/kicad-4.0.7.ebuild
sci-electronics/kicad/kicad-5.0.1.ebuild
sci-electronics/kicad/kicad-5.1.0-r1.ebuild
sci-electronics/kicad/kicad-5.1.2-r1.ebuild
sci-electronics/kicad/kicad-5.1.4.ebuild

index 2ed5780e7a1f0cce8137a6092aa6ce24bfc94069..624172e8994a3d7583dcaf2d3f19e6c10df73320 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -37,7 +37,7 @@ COMMON_DEPEND=">=x11-libs/wxGTK-3.0.2:${WX_GTK_VER}[X,opengl]
                dev-python/wxpython:${WX_GTK_VER}[opengl,${PYTHON_USEDEP}]
                ${PYTHON_DEPS}
        )
-       >=dev-libs/boost-1.61[context,nls,threads,python?,${PYTHON_USEDEP}]
+       >=dev-libs/boost-1.61:=[context,nls,threads,python?,${PYTHON_USEDEP}]
        github? (
                libressl? ( dev-libs/libressl:0= )
                !libressl? ( dev-libs/openssl:0= )
index e04b292fa1eeedc5ac982dea2878eab194c89797..a9f2e30229b26cacf822f66226e41a34ce11b8bc 100644 (file)
@@ -27,7 +27,7 @@ COMMON_DEPEND=">=x11-libs/wxGTK-3.0.2:${WX_GTK_VER}[X,opengl]
                dev-python/wxpython:${WX_GTK_VER}[opengl,${PYTHON_USEDEP}]
                ${PYTHON_DEPS}
        )
-       >=dev-libs/boost-1.61[context,nls,threads,python?,${PYTHON_USEDEP}]
+       >=dev-libs/boost-1.61:=[context,nls,threads,python?,${PYTHON_USEDEP}]
        github? ( net-misc/curl:=[ssl] )
        media-libs/glew:0=
        media-libs/glm
index 6780bf0336dc91e95dde99f972d0d3dffeba11ab..6646e63fac8cf98ea783cfe7477aa391c66b6cf7 100644 (file)
@@ -28,7 +28,7 @@ COMMON_DEPEND=">=x11-libs/wxGTK-3.0.2:${WX_GTK_VER}[X,opengl]
                dev-python/wxpython:${WX_GTK_VER}[opengl,${PYTHON_USEDEP}]
                ${PYTHON_DEPS}
        )
-       >=dev-libs/boost-1.61[context,nls,threads,python?,${PYTHON_USEDEP}]
+       >=dev-libs/boost-1.61:=[context,nls,threads,python?,${PYTHON_USEDEP}]
        github? ( net-misc/curl:=[ssl] )
        media-libs/glew:0=
        media-libs/glm
index a35800d88ee91e488f908a604d0735c525e5e59c..440ad979830f7a406f6972038183e7fb03ab6975 100644 (file)
@@ -28,7 +28,7 @@ COMMON_DEPEND="x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
                dev-python/wxpython:4.0[${PYTHON_USEDEP}]
                ${PYTHON_DEPS}
        )
-       >=dev-libs/boost-1.61[context,nls,threads,python?,${PYTHON_USEDEP}]
+       >=dev-libs/boost-1.61:=[context,nls,threads,python?,${PYTHON_USEDEP}]
        github? ( net-misc/curl:=[ssl] )
        media-libs/glew:0=
        media-libs/glm
index 6cf2d51c218c8bdb54053b5fe5212ad097b3a62d..7922baa2fd5932ae43195fc678b9814550463524 100644 (file)
@@ -28,7 +28,7 @@ COMMON_DEPEND="x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
                dev-python/wxpython:4.0[${PYTHON_USEDEP}]
                ${PYTHON_DEPS}
        )
-       >=dev-libs/boost-1.61[context,nls,threads,python?,${PYTHON_USEDEP}]
+       >=dev-libs/boost-1.61:=[context,nls,threads,python?,${PYTHON_USEDEP}]
        github? ( net-misc/curl:=[ssl] )
        media-libs/glew:0=
        media-libs/glm