restore mistakenly removed stable ebuild (bug #565442)
authorMichael Sterrett <mr_bones_@gentoo.org>
Thu, 12 Nov 2015 04:06:55 +0000 (23:06 -0500)
committerMichael Sterrett <mr_bones_@gentoo.org>
Thu, 12 Nov 2015 04:06:55 +0000 (23:06 -0500)
Package-Manager: portage-2.2.20.1

app-emulation/vice/Manifest
app-emulation/vice/files/vice-2.4.20-autotools.patch [new file with mode: 0644]
app-emulation/vice/files/vice-2.4.20-format.patch [new file with mode: 0644]
app-emulation/vice/files/vice-2.4.20-xf86extensions.patch [new file with mode: 0644]
app-emulation/vice/metadata.xml
app-emulation/vice/vice-2.4.20.ebuild [new file with mode: 0644]

index 7c68c7487007dc8ad0b6f189af73e4dc2b501939..2180a638c13775f18425ef47057be8179849b198 100644 (file)
@@ -1,2 +1,3 @@
+DIST vice-2.4.20.tar.gz 25156408 SHA256 e5d3d125940f0fafe409aabeec9de4e3ae8d9c19a731aa7ec6a57f6d2b897c5f SHA512 a27b1672ca356d0e8f2890c91e449b78ef76512f6d81bdf25350b90c1f472d57ae6d23646d0176c5544c47d81023aa3deb172e3a02eeb0022ea32a13311b5a76 WHIRLPOOL 5f25bfa72ade54dbe09699b5932df2c37017c3993daba048eb09f723a4351300b6722cf06ceb264202459051780a775f45b787b6ea60db78560d5c65da684541
 DIST vice-2.4.22.tar.gz 25180343 SHA256 767e00eb9dbd1a9bcc6db8b4cd1697b8bc744b1d507bbac930975ee130378d9d SHA512 b43e609ae2f43717d10e079d3b8ac284e5c4920ed222c7502e9a7b75dfe32784628031ae6cf8672c8d9d50576fb714cecdd1a9292bf53477f4bbd52c10403975 WHIRLPOOL 580de25d739585c0316c91aba44bb17b2cd4cc19f162e3c5e53b8a7a9e3f694e8c5d8d549b232259d5c9ed077549410b220169a3c026ebad55bc7c537922be81
 DIST vice-2.4.tar.gz 13656511 SHA256 ff8b8d5f0f497d1f8e75b95bbc4204993a789284a08a8a59ba727ad81dcace10 SHA512 ad197fc35eb80c9738b7f4f551d350dbb4440c7c8103e5d472b7f7ea5106c1356e9d6e3f481552a028a313129ef233833d3147e03f6f00b9890229d5708e3ebb WHIRLPOOL 80f89f7c144fe1ef2305e109049b49e47dfa4af9b69d0d848bf7b06bd0f2d210669acece363b550abad1c50f53dd45a30397eb1bfacfaa443c9e865c686d0823
diff --git a/app-emulation/vice/files/vice-2.4.20-autotools.patch b/app-emulation/vice/files/vice-2.4.20-autotools.patch
new file mode 100644 (file)
index 0000000..7bebd28
--- /dev/null
@@ -0,0 +1,11 @@
+--- vice-2.4.7.orig/configure.ac
++++ vice-2.4.7/configure.ac
+@@ -124,7 +118,7 @@
+ AC_SUBST(VICE_VERSION)
+ AM_INIT_AUTOMAKE(vice, $VICE_VERSION)
+-AM_CONFIG_HEADER(src/config.h)
++AC_CONFIG_HEADERS(src/config.h)
+ if test x"$VICE_VERSION_BUILD" = "x" -o x"$VICE_VERSION_BUILD" = "x0" ; then
+   VERSION_RC=$VICE_VERSION_MAJOR","$VICE_VERSION_MINOR",0,0"
diff --git a/app-emulation/vice/files/vice-2.4.20-format.patch b/app-emulation/vice/files/vice-2.4.20-format.patch
new file mode 100644 (file)
index 0000000..1c782fd
--- /dev/null
@@ -0,0 +1,20 @@
+--- src/main.c.old     2015-10-19 17:25:07.549164652 +0200
++++ src/main.c 2015-10-19 17:25:33.106694706 +0200
+@@ -227,7 +227,7 @@
+     for (i = 0; core_team[i].name; i++) {\r
+         n += strlen(core_team[i].name);\r
+         if (n > 74) {\r
+-            log_message(LOG_DEFAULT, tmp);\r
++            log_message(LOG_DEFAULT, "%s", tmp);\r
+             n = 0; *tmp = 0;\r
+         }\r
+         strcat(tmp, core_team[i].name);\r
+@@ -235,7 +235,7 @@
+             strcat(tmp, ", ");\r
+         } else {\r
+             strcat(tmp, ".");\r
+-            log_message(LOG_DEFAULT, tmp);\r
++            log_message(LOG_DEFAULT, "%s", tmp);\r
+         }\r
+     }\r
+     lib_free(tmp);\r
diff --git a/app-emulation/vice/files/vice-2.4.20-xf86extensions.patch b/app-emulation/vice/files/vice-2.4.20-xf86extensions.patch
new file mode 100644 (file)
index 0000000..357d686
--- /dev/null
@@ -0,0 +1,15 @@
+--- a/trunk/vice/src/arch/unix/x11/gnome/x11ui.c
++++ b/trunk/vice/src/arch/unix/x11/gnome/x11ui.c
+@@ -102,9 +102,10 @@
+ #include "ui-threads.h"
+ #endif
+-#ifdef USE_XF86_EXTENSIONS
++#if defined(USE_XF86_EXTENSIONS) || !defined(HAVE_VTE)
+ #include <gdk/gdkx.h>
+ #endif
++
+ #include "x11ui.h"
+ #ifdef DEBUG_X11UI
+
index 242aab2676deb8a4d4d2c78015c64f571dd4788f..9364cf9ad61eb887c698110da295d94c28b09a4c 100644 (file)
@@ -5,6 +5,7 @@
        <use>
                <flag name="ethernet">Enable ethernet emulation</flag>
                <flag name="fullscreen">Enable the ability to run fullscreen</flag>
+               <flag name="gtk2">Use GTK+2 for GUI instead of GTK+3</flag>
                <flag name="memmap">Enable extra monitor features</flag>
                <flag name="sdlsound">Use <pkg>media-libs/libsdl</pkg> for sound support</flag>
                <flag name="vte">Enable support for <pkg>x11-libs/vte</pkg> in the GTK+ interface</flag>
diff --git a/app-emulation/vice/vice-2.4.20.ebuild b/app-emulation/vice/vice-2.4.20.ebuild
new file mode 100644 (file)
index 0000000..1ee7dc6
--- /dev/null
@@ -0,0 +1,173 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils toolchain-funcs flag-o-matic games
+
+DESCRIPTION="The Versatile Commodore 8-bit Emulator"
+HOMEPAGE="http://vice-emu.sourceforge.net/"
+SRC_URI="mirror://sourceforge/vice-emu/releases/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE="Xaw3d alsa ethernet ffmpeg fullscreen +gtk2 ipv6 lame nls oss png pulseaudio sdl +sdlsound threads vte zlib"
+
+# upstream says gtk3 and sdl2 shouldn't be exposed yet.
+#REQUIRED_USE="?? ( gtk2 gtk3 sdl )"
+REQUIRED_USE="?? ( gtk2 sdl )"
+
+GTK_COMMON="
+       x11-libs/pango
+       x11-libs/cairo"
+#      gtk3? (
+#              x11-libs/gtk+:3
+#              vte? ( x11-libs/vte:2.90 )
+#              ${GTK_COMMON}
+#      )
+RDEPEND="
+       virtual/jpeg:0
+       virtual/opengl
+       media-libs/giflib
+       alsa? ( media-libs/alsa-lib )
+       pulseaudio? ( media-sound/pulseaudio )
+       sdlsound? ( media-libs/libsdl[sound] )
+       ethernet? (
+           >=net-libs/libpcap-0.9.8
+           >=net-libs/libnet-1.1.2.1:1.1
+       )
+       ffmpeg? ( virtual/ffmpeg )
+       lame? ( media-sound/lame )
+       nls? ( virtual/libintl )
+       png? ( media-libs/libpng:0 )
+       zlib? ( sys-libs/zlib )
+       sdl? (
+               media-libs/libsdl[joystick,video]
+       )
+       !sdl? (
+               fullscreen? (
+                       x11-libs/libXrandr
+                       x11-libs/libXxf86vm )
+               x11-libs/libX11
+               x11-libs/libXext
+               sys-libs/readline
+       )
+       gtk2? (
+               x11-libs/gtk+:2
+               vte? ( x11-libs/vte:0 )
+               x11-libs/gtkglext
+               ${GTK_COMMON}
+       )
+       !sdl? ( !gtk2? (
+               x11-libs/libXmu
+               x11-libs/libXpm
+               x11-libs/libXt
+               x11-libs/libXv
+               Xaw3d? ( x11-libs/libXaw3d )
+               !Xaw3d? ( x11-libs/libXaw )
+       ) )
+       "
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       !sdl? (
+               fullscreen? ( x11-proto/xf86vidmodeproto )
+               !gtk2? (
+                       x11-libs/libICE
+                       x11-libs/libSM
+               )
+       )
+       x11-apps/bdftopcf
+       x11-apps/mkfontdir
+       x11-proto/xproto
+       x11-proto/xextproto
+       media-libs/fontconfig
+       x11-proto/videoproto
+       nls? ( sys-devel/gettext )"
+
+src_prepare() {
+       epatch \
+               "${FILESDIR}"/${P}-autotools.patch \
+               "${FILESDIR}"/${P}-format.patch \
+               "${FILESDIR}"/${P}-xf86extensions.patch
+       sed -i \
+               -e 's/building//' \
+               doc/Makefile.am || die
+       sed -i \
+               -e "/^docdir =/s:=.*:=/usr/share/doc/${PF}:" \
+               doc/Makefile.am \
+               doc/readmes/Makefile.am || die
+       sed -i \
+               -e "/^docdir =/s:=.*:=/usr/share/doc/${PF}/html:" \
+               doc/html/Makefile.am || die
+       sed -i \
+               -e "s:/usr/local/lib/VICE:$(games_get_libdir)/${PN}:" \
+               man/vice.1 \
+               $(grep -rl --exclude="*texi" /usr/local/lib doc) || die
+       sed -i \
+               -e "/VICEDIR=/s:=.*:=\"$(games_get_libdir)/${PN}\";:" \
+               configure.ac || die
+       sed -i \
+               -e "s:\(#define LIBDIR \).*:\1\"$(games_get_libdir)/${PN}\":" \
+               -e "s:\(#define DOCDIR \).*:\1\"/usr/share/doc/${PF}\":" \
+               src/arch/unix/archdep.h \
+               src/arch/sdl/archdep_unix.h || die
+       rm -rf src/lib/{libffmpeg,liblame} || die
+       sed -i \
+               -e '/SUBDIRS/s/libffmpeg//;' \
+               -e '/SUBDIRS/s/liblame//;' \
+               src/lib/Makefile.am || die
+       AT_NO_RECURSIVE=1 eautoreconf
+}
+
+src_configure() {
+       local gui_arg snd_arg
+
+       snd_arg+=" $(use_with alsa)"
+       snd_arg+=" $(use_with oss)"
+       snd_arg+=" $(use_with pulseaudio pulse)"
+       snd_arg+=" $(use_with sdlsound)"
+
+       gui_arg+=" $(use_enable sdl sdlui)"
+       # The gtk UI code has raw calls to XOpenDisplay and
+       # is missing -lX11 if vte doesn't pull it in.
+       #if use gtk2 || use gtk3 ; then
+       if use gtk2 ; then
+               use vte || append-libs -lX11
+       fi
+       gui_arg+=" $(use_enable gtk2 gnomeui)"
+       #gui_arg+=" $(use_enable gtk3 gnomeui3)"
+       gui_arg+=" $(use_enable Xaw3d xaw3d)"
+
+       # --with-readline is forced to avoid using the embedded copy
+       # don't try to actually run fc-cache (bug #280976)
+       FCCACHE=/bin/true \
+       PKG_CONFIG=$(tc-getPKG_CONFIG) \
+       egamesconf \
+               --enable-parsid \
+               --with-resid \
+               --with-readline \
+               --without-arts \
+               --without-midas \
+               $(use_enable ethernet) \
+               $(use_enable ffmpeg) \
+               $(use_enable ffmpeg external-ffmpeg) \
+               $(use_enable fullscreen) \
+               $(use_enable ipv6) \
+               $(use_enable lame) \
+               $(use_enable nls) \
+               $(use_enable vte) \
+               $(use_with png) \
+               $(use_with threads uithreads) \
+               $(use_with zlib) \
+               ${gui_arg} \
+               ${snd_arg} \
+               --disable-option-checking
+               # --disable-option-checking has to be last
+}
+
+src_install() {
+       DOCS="AUTHORS ChangeLog FEEDBACK README" \
+               default
+       prepgamesdirs
+}