media-gfx/inkscape: synced 9999 from 1.0
authorMiroslav Šulc <fordfrog@gentoo.org>
Fri, 8 May 2020 07:41:31 +0000 (09:41 +0200)
committerMiroslav Šulc <fordfrog@gentoo.org>
Fri, 8 May 2020 07:42:04 +0000 (09:42 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
media-gfx/inkscape/files/inkscape-1.0_beta1-detect-imagemagick.patch [deleted file]
media-gfx/inkscape/files/inkscape-1.0_beta1-do-not-compress-man.patch [deleted file]
media-gfx/inkscape/inkscape-9999.ebuild

diff --git a/media-gfx/inkscape/files/inkscape-1.0_beta1-detect-imagemagick.patch b/media-gfx/inkscape/files/inkscape-1.0_beta1-detect-imagemagick.patch
deleted file mode 100644 (file)
index ee4becf..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/CMakeScripts/DefineDependsandFlags.cmake b/CMakeScripts/DefineDependsandFlags.cmake
-index 91f93e7..95b2af2 100644
---- a/CMakeScripts/DefineDependsandFlags.cmake
-+++ b/CMakeScripts/DefineDependsandFlags.cmake
-@@ -330,7 +330,7 @@ list(APPEND INKSCAPE_LIBS ${ZLIB_LIBRARIES})
- if(WITH_IMAGE_MAGICK)
-     # we want "<" but pkg_check_modules only offers "<=" for some reason; let's hope nobody actually has 7.0.0
--    pkg_check_modules(MAGICK ImageMagick++<=7)
-+    pkg_check_modules(MAGICK Magick++<=7)
-     if(MAGICK_FOUND)
-         set(WITH_GRAPHICS_MAGICK OFF)  # prefer ImageMagick for now and disable GraphicsMagick if found
-     else()
diff --git a/media-gfx/inkscape/files/inkscape-1.0_beta1-do-not-compress-man.patch b/media-gfx/inkscape/files/inkscape-1.0_beta1-do-not-compress-man.patch
deleted file mode 100644 (file)
index c9d395e..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/CMakeScripts/Pod2man.cmake b/CMakeScripts/Pod2man.cmake
-index eda6292..b94d5af 100644
---- a/CMakeScripts/Pod2man.cmake
-+++ b/CMakeScripts/Pod2man.cmake
-@@ -14,6 +14,8 @@ if(NOT GZIP)
-     message(STATUS "Could not find gzip - man pages uncompressed")
- endif()
-+set(GZIP "")
-+
- macro(pod2man PODFILE_FULL RELEASE SECTION CENTER)
-     get_filename_component(PODFILE ${PODFILE_FULL} NAME)
-     string(REPLACE "." ";" PODFILE_LIST ${PODFILE})
index 158a19eeca9b77183dbf3b4b9351e7e9507ebe4a..b87ca681947fa35bd12003793226c1e35830ec6d 100644 (file)
@@ -61,7 +61,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
        dbus? ( dev-libs/dbus-glib )
        exif? ( media-libs/libexif )
        imagemagick? (
-               !graphicsmagick? ( <media-gfx/imagemagick-7:=[cxx] )
+               !graphicsmagick? ( media-gfx/imagemagick:=[cxx] )
                graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
        )
        jemalloc? ( dev-libs/jemalloc )
@@ -96,14 +96,9 @@ DEPEND="${COMMON_DEPEND}
        >=dev-libs/boost-1.65
 "
 
-S="${WORKDIR}/${MY_P}"
-
 RESTRICT="test"
 
-PATCHES=(
-       "${FILESDIR}"/${PN}-1.0_beta1-detect-imagemagick.patch
-       "${FILESDIR}"/${PN}-1.0_beta1-do-not-compress-man.patch
-)
+S="${WORKDIR}/${MY_P}"
 
 pkg_pretend() {
        if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
@@ -154,6 +149,10 @@ src_install() {
 
        find "${ED}" -type f -name "*.la" -delete || die
 
+       find "${ED}"/usr/share/man -type f -maxdepth 3 -name '*.bz2' -exec bzip2 -d {} \; || die
+
+       find "${ED}"/usr/share/man -type f -maxdepth 3 -name '*.gz' -exec gzip -d {} \; || die
+
        # No extensions are present in beta1
        local extdir="${ED}"/usr/share/${PN}/extensions