app-crypt/certbot-nginx: 1.4.0 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Wed, 6 May 2020 20:27:12 +0000 (15:27 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Wed, 6 May 2020 20:27:32 +0000 (15:27 -0500)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-crypt/certbot-nginx/Manifest
app-crypt/certbot-nginx/certbot-nginx-1.4.0.ebuild [new file with mode: 0644]
app-crypt/certbot-nginx/certbot-nginx-9999.ebuild

index c6644fcb5db8c7ca12540b49f72283f327e4dddd..24824d6ddbee7678828c1e76bd2026efb76c1b7f 100644 (file)
@@ -1 +1,2 @@
 DIST certbot-1.3.0.tar.gz 1362945 BLAKE2B bb36a7737275332f018d7f2283286e07e041892cc366f79e68df9eee7e57ca2186d36895d1923b032068a365878d09e49e17c1399a7418dbd8607c9a7efc1c26 SHA512 4205cdd1f3ddf500b9b952744db234636c086a856df80acd2d776305f4501eed07995e453e5c9b2c711fb0d1f1987d2bb8baaa13fccce8e000a38f486cfdc5d3
+DIST certbot-1.4.0.tar.gz 1381435 BLAKE2B 57d70a12ee38e1ba96f4c8c594c1940403e33d4cdf5111472a9c0c7d41061b2201792c38d9bb4ec516358f5592d2f689eeab31e1e686a534418b20eba2df4b4b SHA512 8926f724c47c0249e2e420cd8944f0b106682efaa2d9b211491ea4524fe4e64bb3ff4f21fd756996049d781a68294ab8307bd077b6d96fa00e09cbbdf4e59261
diff --git a/app-crypt/certbot-nginx/certbot-nginx-1.4.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-1.4.0.ebuild
new file mode 100644 (file)
index 0000000..b6f70f8
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_6,3_7})
+
+if [[ ${PV} == 9999* ]]; then
+       EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+       inherit git-r3
+       S=${WORKDIR}/${P}/${PN}
+else
+       SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-nginx}-${PV}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+       S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Nginx plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+       >=app-crypt/acme-1.4.0[${PYTHON_USEDEP}]
+       >=app-crypt/certbot-1.4.0[${PYTHON_USEDEP}]
+       dev-python/pyopenssl[${PYTHON_USEDEP}]
+       >=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
+       dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
index b87bdbf7b7dd026a1eff95f52821ccb031b3728a..b6f70f8607be977605af8bb4066698fd6f6cf73a 100644 (file)
@@ -25,9 +25,8 @@ IUSE=""
 
 CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
 RDEPEND="${CDEPEND}
-       >=app-crypt/acme-1.0.0[${PYTHON_USEDEP}]
-       >=app-crypt/certbot-1.1.0[${PYTHON_USEDEP}]
-       dev-python/mock[${PYTHON_USEDEP}]
+       >=app-crypt/acme-1.4.0[${PYTHON_USEDEP}]
+       >=app-crypt/certbot-1.4.0[${PYTHON_USEDEP}]
        dev-python/pyopenssl[${PYTHON_USEDEP}]
        >=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
        dev-python/zope-interface[${PYTHON_USEDEP}]"