* bump
authorKonstantin V. Arkhipov <voxus@gentoo.org>
Mon, 11 Dec 2006 21:46:37 +0000 (21:46 +0000)
committerKonstantin V. Arkhipov <voxus@gentoo.org>
Mon, 11 Dec 2006 21:46:37 +0000 (21:46 +0000)
Package-Manager: portage-2.1.2_rc3-r2

www-servers/nginx/ChangeLog
www-servers/nginx/files/digest-nginx-0.5.2 [new file with mode: 0644]
www-servers/nginx/nginx-0.5.2.ebuild [new file with mode: 0644]

index d2e14267e1e8cd5af447aad28ad24d8729c68358..9bbe4bd662bef4a7d44f29869392e83c1159f8ec 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for www-servers/nginx
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.122 2006/12/11 10:14:00 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.123 2006/12/11 21:46:37 voxus Exp $
+
+*nginx-0.5.2 (11 Dec 2006)
+
+  11 Dec 2006; Konstantin V. Arkhipov <voxus@gentoo.org>
+  -nginx-0.5.1.ebuild, +nginx-0.5.2.ebuild:
+  One more bump.
 
 *nginx-0.5.1 (11 Dec 2006)
 
diff --git a/www-servers/nginx/files/digest-nginx-0.5.2 b/www-servers/nginx/files/digest-nginx-0.5.2
new file mode 100644 (file)
index 0000000..fc54680
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 017194243873dcc5ca60d975b8586fc1 nginx-0.5.2.tar.gz 442157
+RMD160 f4b0243beedde7b08a4b2602ea46a2dbfaa5e617 nginx-0.5.2.tar.gz 442157
+SHA256 e0927ec0696223148d563939f738f725488a60a0ed416c1308b4af06db3eabda nginx-0.5.2.tar.gz 442157
diff --git a/www-servers/nginx/nginx-0.5.2.ebuild b/www-servers/nginx/nginx-0.5.2.ebuild
new file mode 100644 (file)
index 0000000..ca2d559
--- /dev/null
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.5.2.ebuild,v 1.1 2006/12/11 21:46:37 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl zlib"
+
+DEPEND="dev-lang/perl
+       pcre? ( >=dev-libs/libpcre-4.2 )
+       ssl? ( dev-libs/openssl )
+       zlib? ( sys-libs/zlib )
+       perl? ( >=dev-lang/perl-5.8 )"
+
+src_compile() {
+       local myconf
+
+       if use threads; then
+               einfo
+               ewarn "threads support is experimental at the moment"
+               ewarn "do not use it on production systems - you've been warned"
+               einfo
+               myconf="${myconf} --with-threads"
+       fi
+
+       use fastcgi     || myconf="${myconf} --without-http_fastcgi_module"
+       use fastcgi     && myconf="${myconf} --with-http_realip_module"
+       use zlib        || myconf="${myconf} --without-http_gzip_module"
+       use pcre        || {
+               myconf="${myconf} --without-pcre --without-http_rewrite_module"
+       }
+       use debug       && myconf="${myconf} --with-debug"
+       use ssl         && myconf="${myconf} --with-http_ssl_module"
+       use imap        && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+       use perl        && myconf="${myconf} --with-http_perl_module"
+
+       ./configure \
+               --prefix=/usr \
+               --conf-path=/etc/${PN}/${PN}.conf \
+               --http-log-path=/var/log/${PN}/access_log \
+               --error-log-path=/var/log/${PN}/error_log \
+               --pid-path=/var/run/${PN}.pid \
+               --http-client-body-temp-path=/var/tmp/${PN}/client \
+               --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+               --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+               --with-md5-asm --with-md5=/usr/include \
+               ${myconf} || die "configure failed"
+
+       emake || die "failed to compile"
+}
+
+src_install() {
+       keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+       dosbin objs/nginx
+       cp ${FILESDIR}/nginx-r1 ${T}/nginx
+       doinitd ${T}/nginx
+
+       rm conf/nginx.conf
+       cp ${FILESDIR}/nginx.conf-r2 ${T}/nginx.conf
+
+       dodir /etc/${PN}
+       insinto /etc/${PN}
+       doins conf/* ${T}/nginx.conf
+
+       dodoc CHANGES{,.ru} LICENSE README
+
+       use perl && {
+               cd ${S}/objs/src/http/modules/perl/
+               make DESTDIR=${D} install || die "failed to install perl stuff"
+       }
+}