sys-fs/lvm2: Minor ebuild improvements.
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 12 Dec 2018 10:03:50 +0000 (11:03 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 12 Dec 2018 11:57:30 +0000 (12:57 +0100)
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-fs/lvm2/lvm2-2.02.183.ebuild

index ea67d28a6d8c0ea33677a4099d37afc5bdb84a98..6ea92b0ac768579f5d05e15a8b5c6a139c3ae8f6 100644 (file)
@@ -197,12 +197,12 @@ src_compile() {
 }
 
 src_install() {
-       local inst
-       INSTALL_TARGETS="install install_tmpfiles_configuration"
+       local inst INSTALL_TARGETS
+       INSTALL_TARGETS=( install install_tmpfiles_configuration )
        # install systemd related files only when requested, bug #522430
-       use systemd && INSTALL_TARGETS="${INSTALL_TARGETS} install_systemd_units install_systemd_generators"
-       use device-mapper-only && INSTALL_TARGETS="install_device-mapper"
-       for inst in ${INSTALL_TARGETS}; do
+       use systemd && INSTALL_TARGETS+=( install_systemd_units install_systemd_generators )
+       use device-mapper-only && INSTALL_TARGETS=( install_device-mapper )
+       for inst in ${INSTALL_TARGETS[@]}; do
                emake DESTDIR="${D}" ${inst}
        done