dev-ml/ocaml-compiler-libs: update to opam.eclass
authorAlexis Ballier <aballier@gentoo.org>
Fri, 22 Sep 2017 08:28:37 +0000 (10:28 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 22 Sep 2017 08:31:46 +0000 (10:31 +0200)
Package-Manager: Portage-2.3.10, Repoman-2.3.3

dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.9.0.ebuild

index 1c94b1a1bdf0356d156e86fff2531f9305c8604a..82cd4f1c3a949725aa3f5ddda56b4b4666e29ba1 100644 (file)
@@ -3,6 +3,8 @@
 
 EAPI=6
 
+inherit opam
+
 DESCRIPTION="Repackage the OCaml compiler libs so they do not expose everything at toplevel"
 HOMEPAGE="https://github.com/janestreet/ocaml-compiler-libs"
 SRC_URI="https://github.com/janestreet/ocaml-compiler-libs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -12,17 +14,6 @@ SLOT="0/${PV}"
 KEYWORDS="~amd64 ~ppc"
 IUSE=""
 
-DEPEND="dev-lang/ocaml:="
-RDEPEND="${DEPEND}"
+RDEPEND=""
 DEPEND="${RDEPEND}
-       dev-ml/opam
        dev-ml/jbuilder"
-
-src_install() {
-       opam-installer -i \
-               --prefix="${ED}/usr" \
-               --libdir="${D}/$(ocamlc -where)" \
-               --docdir="${ED}/usr/share/doc/${PF}" \
-               --mandir="${ED}/usr/share/man" \
-               ${PN}.install || die
-}