media-fonts/cantarell: 0.0.25 → 0.101, complete redesign
authorGilles Dartiguelongue <eva@gentoo.org>
Sun, 27 May 2018 16:30:47 +0000 (18:30 +0200)
committerGilles Dartiguelongue <eva@gentoo.org>
Sun, 27 May 2018 16:31:14 +0000 (18:31 +0200)
Redesigned from scratch to interpolate cleanly from thin to extra bold.

Package-Manager: Portage-2.3.40, Repoman-2.3.9

media-fonts/cantarell/Manifest
media-fonts/cantarell/cantarell-0.101.ebuild [new file with mode: 0644]

index b41e1cb911331b56f2b03c6415d6e3410dda4cd2..7720fc73e0d849c71b9cc9e12eba406b2ebd5401 100644 (file)
@@ -1 +1,2 @@
 DIST cantarell-fonts-0.0.25.tar.xz 351768 BLAKE2B cfdd7570c99db9e75658369df9eb243ddb6290dfe8017bcff12edf876134ba185083e70676369962a2a9f35365e92268625b47da286aca640927fb7a47073295 SHA512 c09c3ecb3d4c50f613234398fabd327ca92b8abbc27082e8e98f2944f3dd9f0c2ff4c022ff5e5503a86e724bb8e2fbf6cd081f8a29e91b4209f5bf0e32168c3e
+DIST cantarell-fonts-0.101.tar.xz 263480 BLAKE2B 79652cf87088a8fe505895cad1f2474e0cb52e4be8a977ae06442a0e8ca6ba6a7f93c811b14e56fd5e61a17c97175b2374d180e435cbac00af8c10b272461802 SHA512 52dbd8358de7e20146e627ab0b1298efb97ee335e45d8e63bab7c3a7d05314d0bb94ac448e34af4c6f7212623185a9e03a30eb24acee4915142e40af0086bbfb
diff --git a/media-fonts/cantarell/cantarell-0.101.ebuild b/media-fonts/cantarell/cantarell-0.101.ebuild
new file mode 100644 (file)
index 0000000..b63dba2
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME_ORG_MODULE="${PN}-fonts"
+
+inherit font gnome.org meson
+
+DESCRIPTION="Default fontset for GNOME Shell"
+HOMEPAGE="https://wiki.gnome.org/Projects/CantarellFonts"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="media-libs/fontconfig"
+DEPEND="
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+"
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+# Font eclass settings
+FONT_CONF=("${S}/fontconfig/31-cantarell.conf")
+FONT_S="${S}/prebuilt"
+FONT_SUFFIX="otf"
+
+src_prepare() {
+       # Leave prebuilt font installation to font.eclass
+       sed -e "/subdir('prebuilt')/d" -i meson.build || die
+
+       default
+}
+
+src_configure() {
+       local emesonargs=(
+               -Dfontsdir=${FONTDIR}
+               -Duseprebuilt=true
+       )
+       meson_src_configure
+}
+
+src_install() {
+       local DOCS=( NEWS README.md )
+       meson_src_install
+       font_src_install
+}