net-analyzer/flow-tools: Fix CFLAGS=-fno-common
authorJeroen Roovers <jer@gentoo.org>
Mon, 3 Feb 2020 19:28:04 +0000 (20:28 +0100)
committerJeroen Roovers <jer@gentoo.org>
Mon, 3 Feb 2020 19:28:33 +0000 (20:28 +0100)
Package-Manager: Portage-2.3.87, Repoman-2.3.20
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Closes: https://bugs.gentoo.org/show_bug.cgi?id=708038
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-analyzer/flow-tools/files/flow-tools-0.68.5.1-fno-common.patch [new file with mode: 0644]
net-analyzer/flow-tools/flow-tools-0.68.5.1-r10.ebuild

diff --git a/net-analyzer/flow-tools/files/flow-tools-0.68.5.1-fno-common.patch b/net-analyzer/flow-tools/files/flow-tools-0.68.5.1-fno-common.patch
new file mode 100644 (file)
index 0000000..14623fa
--- /dev/null
@@ -0,0 +1,42 @@
+--- ./src/acl2.h
++++ ./src/acl2.h
+@@ -48,7 +48,7 @@
+ #define ACL_TYPE_STD  1
+ #define ACL_TYPE_EXT  2
+-struct acl_list {
++typedef struct acl_list {
+   int num;                          /* number of entries */
+   int num_std;                      /* number of standard acl entries */
+   int num_ext;                      /* number of extended acl entries */
+@@ -59,6 +59,8 @@
+                                     /* num_ext of these */
+ };
++extern struct acl_list acl_list;
++
+ struct acl_names {
+   int num;       /* index into standard or extended list */
+   char *name;    /* name of this acl */
+--- a/src/aclyacc.y
++++ b/src/aclyacc.y
+@@ -7,8 +7,6 @@
+ unsigned char fmt_buf[32];
+ unsigned char fmt_buf2[32];
+-extern struct acl_list acl_list;
+-
+ int x;
+ %}
+--- a/src/flow-filter.c
++++ b/src/flow-filter.c
+@@ -56,8 +56,6 @@
+ int debug;
+ int ip_net_only;
+-struct acl_list acl_list;
+-
+ int yyparse (void);
+ void usage(void);
+ void yyerror(const char *msg);
index 4a048f0d81c0ac79484f2a25c9cde410d37294f6..8656ded0568880a62f65cc8998ba68e6f47e30ca 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -32,6 +32,7 @@ PATCHES=(
        "${FILESDIR}"/${P}-run.patch
        "${FILESDIR}"/${P}-syslog.patch
        "${FILESDIR}"/${P}-openssl11.patch
+       "${FILESDIR}"/${P}-fno-common.patch
 )
 
 pkg_setup() {