dev-python/pytest-catchlog: New package, ebuild written by me
authorJustin Lecher <jlec@gentoo.org>
Wed, 30 Sep 2015 14:32:53 +0000 (16:32 +0200)
committerJustin Lecher <jlec@gentoo.org>
Wed, 30 Sep 2015 17:43:18 +0000 (19:43 +0200)
Package-Manager: portage-2.2.22
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/pytest-catchlog/Manifest [new file with mode: 0644]
dev-python/pytest-catchlog/metadata.xml [new file with mode: 0644]
dev-python/pytest-catchlog/pytest-catchlog-1.1.ebuild [new file with mode: 0644]

diff --git a/dev-python/pytest-catchlog/Manifest b/dev-python/pytest-catchlog/Manifest
new file mode 100644 (file)
index 0000000..77ac4ef
--- /dev/null
@@ -0,0 +1 @@
+DIST pytest-catchlog-1.1.tar.gz 6540 SHA256 7ad18d77b93d70c4ea30ed4593b164be104efc50a9112a5733304a71f2cb1119 SHA512 7a272874f9fb4231a7b3a42742b752f0f9750fb861abfed0411bf8edae5ab3e67a0a33fe166e485d530a1ecf1834d131d3affcfc43a735fc5d28018ba155129a WHIRLPOOL cf04096c01176fc077c45ca26b5002e10cdc145e3d3ea83cc7594eb2cbaa3a7636ba661253b1a8e47e316407e672c5ee424df10d8026bc6adb2c04499d386d3f
diff --git a/dev-python/pytest-catchlog/metadata.xml b/dev-python/pytest-catchlog/metadata.xml
new file mode 100644 (file)
index 0000000..812a53f
--- /dev/null
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <herd>python</herd>
+       <upstream>
+               <remote-id type="pypi">pytest-catchlog</remote-id>
+               <remote-id type="github">eisensheng/pytest-catchlog</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-catchlog/pytest-catchlog-1.1.ebuild b/dev-python/pytest-catchlog/pytest-catchlog-1.1.ebuild
new file mode 100644 (file)
index 0000000..c539e0c
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin to catch log messages, fork of pytest-capturelog"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-catchlog https://github.com/eisensheng/pytest-catchlog"
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/eisensheng/pytest-catchlog/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=">=dev-python/py-1.1.1[${PYTHON_USEDEP}]"
+DEPEND="
+       test? (
+               ${RDEPEND}
+               >=dev-python/pytest-2.7.1[${PYTHON_USEDEP}]
+       )"
+
+# Cannot figure out how to run them
+RESTRICT=test
+
+python_test() {
+       PYTHONPATH="${S}:${PYTONPATH}" \
+               py.test -v -v -x || die
+}