dev-libs/jsoncpp: Switch to meson
authorMichał Górny <mgorny@gentoo.org>
Fri, 20 Dec 2019 21:51:58 +0000 (22:51 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 20 Dec 2019 21:53:07 +0000 (22:53 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-libs/jsoncpp/jsoncpp-1.9.2-r2.ebuild [new file with mode: 0644]

diff --git a/dev-libs/jsoncpp/jsoncpp-1.9.2-r2.ebuild b/dev-libs/jsoncpp/jsoncpp-1.9.2-r2.ebuild
new file mode 100644 (file)
index 0000000..311eab1
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} )
+
+inherit meson python-any-r1
+
+DESCRIPTION="C++ JSON reader and writer"
+HOMEPAGE="https://github.com/open-source-parsers/jsoncpp"
+SRC_URI="https://github.com/open-source-parsers/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( public-domain MIT )"
+SLOT="0/22"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+       ${PYTHON_DEPS}
+       doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_configure() {
+       local emesonargs=(
+               # Follow Debian, Ubuntu, Arch convention for headers location
+               # bug #452234
+               --includedir include/jsoncpp
+       )
+       meson_src_configure
+}
+
+src_compile() {
+       meson_src_compile
+
+       if use doc; then
+               cp "${BUILD_DIR}"/version . || die
+               "${EPYTHON}" doxybuild.py --doxygen="${EPREFIX}"/usr/bin/doxygen || die
+               HTML_DOCS=( dist/doxygen/jsoncpp*/. )
+       fi
+}