x11-wm/mutter: be explicit about pipewire disabling
authorMart Raudsepp <leio@gentoo.org>
Sat, 17 Aug 2019 18:29:38 +0000 (21:29 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sat, 17 Aug 2019 18:29:49 +0000 (21:29 +0300)
The autotools AC_ARG_ENABLE usage bug was fixed long ago upstream,
so we can be explicit about the disabling now to avoid confusion.
Though autotools never got automagic behaviour for it - it got
ported to meson for 3.32 first - so it makes no practical
difference.

Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
x11-wm/mutter/mutter-3.30.2-r1.ebuild
x11-wm/mutter/mutter-3.30.2-r3.ebuild

index c0fa10f52b9188de4d31374b193461ba749cba67..bd9ea4cb462f92963952774ec3d848af3d6762c6 100644 (file)
@@ -111,7 +111,7 @@ src_prepare() {
 }
 
 src_configure() {
-       # TODO: pipewire remote desktop support; --disable-remote-desktop actually enables it due to upstream autotools bug in 3.26.2 (omitted means disabled)
+       # TODO: pipewire remote desktop support
        # TODO: nvidia EGLDevice support
        # TODO: elogind vs systemd is automagic in 3.28.3 - if elogind is found, it's used instead of systemd; but not a huge problem as elogind package blocks systemd package
        # TODO: lack of --with-xwayland-grab-default-access-rules relies on default settings, but in Gentoo we might have some more packages we want to give Xgrab access (mostly virtual managers and remote desktops)
@@ -130,6 +130,7 @@ src_configure() {
                --enable-xlib-egl-platform \
                --with-default-driver=gl \
                --with-libcanberra \
+               --disable-remote-desktop \
                $(usex debug --enable-debug=yes "") \
                $(use_enable gles2)        \
                $(use_enable gles2 cogl-gles2) \
index 5b88d60c9a8487172a2062a6f3f0c070a0206efa..a6b546ea6ad2836a05b4df517ead85cd02b3d32f 100644 (file)
@@ -111,7 +111,7 @@ src_prepare() {
 }
 
 src_configure() {
-       # TODO: pipewire remote desktop support; --disable-remote-desktop actually enables it due to upstream autotools bug in 3.26.2 (omitted means disabled)
+       # TODO: pipewire remote desktop support
        # TODO: nvidia EGLDevice support
        # TODO: elogind vs systemd is automagic in 3.28.3 - if elogind is found, it's used instead of systemd; but not a huge problem as elogind package blocks systemd package
        # TODO: lack of --with-xwayland-grab-default-access-rules relies on default settings, but in Gentoo we might have some more packages we want to give Xgrab access (mostly virtual managers and remote desktops)
@@ -130,6 +130,7 @@ src_configure() {
                --enable-xlib-egl-platform \
                --with-default-driver=gl \
                --with-libcanberra \
+               --disable-remote-desktop \
                $(usex debug --enable-debug=yes "") \
                $(use_enable gles2)        \
                $(use_enable gles2 cogl-gles2) \