dev-python/colorspacious: bump to 1.1.2
authorAndrey Grozin <grozin@gentoo.org>
Sun, 1 Mar 2020 03:45:04 +0000 (10:45 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Sun, 1 Mar 2020 03:45:04 +0000 (10:45 +0700)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
dev-python/colorspacious/Manifest
dev-python/colorspacious/colorspacious-1.1.2.ebuild [new file with mode: 0644]

index 9a4bd03c168f5889c361a645649afb004fbca6d5..b6f82b68a0b8f702502858c1f57e837e009caf92 100644 (file)
@@ -1 +1,2 @@
 DIST colorspacious-1.1.0.zip 698745 BLAKE2B 3d6ebf9b76b727a982829fb0e3012507e30524662110628d8bc164bad4581baf147cdf4d6c8d54a52420d3e72497ac547f98f1d162b178ac20e8e9c926d41bd3 SHA512 b4267cab679d581f2072f5a315aeccd78cc68e325e16f14675cb17133cd411a28f376f150aee7822e1568b84571d5d149adff10e9c5a7fd9f41927153967e2ef
+DIST colorspacious-1.1.2.tar.gz 688573 BLAKE2B 85b4c24a0d0ce42817060be9dfeaa00f1775f656590cc76fd5c0ce0f929b165cd1239b33a54d7d5a4969ecf7240c3b9c3fdf067ab8282052768f4f8ad6f04a02 SHA512 a5c212c82f4a8eb1561f3ff86effeb0c1edb80fca3657dc62336c56de3c8810c44288022223a6089f9eb2cad8d3bcd9c8222014c106b8915c0c6d8b7df0c353a
diff --git a/dev-python/colorspacious/colorspacious-1.1.2.ebuild b/dev-python/colorspacious/colorspacious-1.1.2.ebuild
new file mode 100644 (file)
index 0000000..efd99b8
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Powerful, accurate, and easy-to-use Python library for colorspace conversions"
+HOMEPAGE="https://colorspacious.readthedocs.org/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       app-arch/unzip
+       test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+       nosetests --all-modules || die "Tests fail with ${EPYTHON}"
+}