sys-freebsd/boot0: Remove last-rited pkg
authorMichał Górny <mgorny@gentoo.org>
Fri, 11 Oct 2019 15:15:58 +0000 (17:15 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 11 Oct 2019 15:16:44 +0000 (17:16 +0200)
Closes: https://bugs.gentoo.org/683284
Signed-off-by: Michał Górny <mgorny@gentoo.org>
profiles/package.mask
sys-freebsd/boot0/Manifest [deleted file]
sys-freebsd/boot0/boot0-11.1.ebuild [deleted file]
sys-freebsd/boot0/files/boot0-11.0-gcc46.patch [deleted file]
sys-freebsd/boot0/files/boot0-add-nossp-cflags.patch [deleted file]
sys-freebsd/boot0/metadata.xml [deleted file]

index 086f537028d94e337383745abf79e0935f5e1966..568436850f20e972a683412d27c62067f819abb4 100644 (file)
@@ -733,23 +733,6 @@ dev-libs/cgicc
 # Removal in 30 days.  Bug #691264.
 dev-libs/actor-framework
 
-# Michał Górny <mgorny@gentoo.org> (2019-09-11)
-# Gentoo/FreeBSD project is effectively dead.  The core packages are
-# outdated and vulnerable.  We do not have a fully working install,
-# and I have not been able to find anyone knowing how to create one.
-# Leaf packages are failing to build more and more frequently, some
-# simply because of our outdated base system.  The profiles were marked
-# exp two months ago not to stall other developers, core packages are
-# masked for at least two months, and nowadays they have unsatisfied
-# dependencies already.
-#
-# If anyone wishes to take the effort over, please consider it urgent.
-# If not, I will slowly start removing remaining parts of FreeBSD
-# after this batch, and checking which packages can be salvaged.
-#
-# Removal in 30 days.  Bug #683284.
-sys-freebsd/boot0
-
 # Lars Wendler <polynomial-c@gentoo.org> (2019-09-04)
 # Unofficial build. Superseded by official 2.49.5 release.
 # Masked for removal.
diff --git a/sys-freebsd/boot0/Manifest b/sys-freebsd/boot0/Manifest
deleted file mode 100644 (file)
index f3dcd89..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST freebsd-src-11.1.tar.xz 147661560 BLAKE2B a9e6ba9d0e12c8b56ac58575d5f02931edbb6a3545d9dccae78810d2d0470a29b29dd7f724b03b8afafbca23717a71346e4cfbd3530e0f40118a23609c3f414e SHA512 b97707ec7a601ca6bcb682c45f6d94a38484301ac24630d7285eff6f88b027ce6900c93fc62f8ce36e0cf32c91f73a9d1c999db397b7f8782fd74a8551a03aca
diff --git a/sys-freebsd/boot0/boot0-11.1.ebuild b/sys-freebsd/boot0/boot0-11.1.ebuild
deleted file mode 100644 (file)
index 6b33a68..0000000
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit bsdmk freebsd flag-o-matic toolchain-funcs
-
-DESCRIPTION="FreeBSD's bootloader"
-SLOT="0"
-
-IUSE="bzip2 ieee1394 tftp zfs"
-
-# Security Advisory and Errata patches.
-# UPSTREAM_PATCHES=()
-
-if [[ ${PV} != *9999* ]]; then
-       KEYWORDS="~amd64-fbsd ~x86-fbsd"
-       SRC_URI="${SRC_URI}
-               $(freebsd_upstream_patches)"
-fi
-
-EXTRACTONLY="
-       sys/
-       lib/
-       contrib/bzip2/
-       contrib/zlib/
-"
-
-RDEPEND=""
-DEPEND="=sys-freebsd/freebsd-mk-defs-${RV}*
-       =sys-freebsd/freebsd-lib-${RV}*"
-
-S="${WORKDIR}/sys/boot"
-
-PATCHES=( "${FILESDIR}/${PN}-11.0-gcc46.patch"
-       "${FILESDIR}/${PN}-add-nossp-cflags.patch" )
-
-boot0_use_enable() {
-       use ${1} && mymakeopts="${mymakeopts} LOADER_${2}_SUPPORT=\"yes\""
-       use ${1} || mymakeopts="${mymakeopts} WITHOUT_${2}= "
-}
-
-pkg_setup() {
-       boot0_use_enable ieee1394 FIREWIRE
-       boot0_use_enable zfs ZFS
-       boot0_use_enable tftp TFTP
-       boot0_use_enable bzip2 BZIP2
-}
-
-src_prepare() {
-       sed -e '/-mno-align-long-strings/d' \
-               -i "${S}"/i386/boot2/Makefile \
-               -i "${S}"/i386/gptboot/Makefile \
-               -i "${S}"/i386/gptzfsboot/Makefile \
-               -i "${S}"/i386/zfsboot/Makefile || die
-
-       mymakeopts="${mymakeopts} LOADER_NO_GELI_SUPPORT=yes"
-       export MAKEOBJDIRPREFIX="${WORKDIR}/build"
-}
-
-src_compile() {
-       strip-flags
-       append-flags "-fno-strict-aliasing"
-
-       cd "${WORKDIR}/lib/libstand" || die
-       freebsd_src_compile
-
-       CFLAGS="${CFLAGS} -I${WORKDIR}/lib/libstand"
-       LDFLAGS="${LDFLAGS} -L${MAKEOBJDIRPREFIX}/${WORKDIR}/lib/libstand"
-       export LIBSTAND="${MAKEOBJDIRPREFIX}/${WORKDIR}/lib/libstand/libstand.a"
-
-       cd "${S}" || die
-       NOFLAGSTRIP="yes" freebsd_src_compile
-}
-
-src_install() {
-       dodir /boot/defaults
-       freebsd_src_install FILESDIR=/boot
-
-       cd "${WORKDIR}/sys/$(tc-arch-kernel)/conf" || die
-       insinto /boot
-       newins GENERIC.hints device.hints
-
-       echo 'CONFIG_PROTECT="/boot/device.hints"' > "${T}"/50boot0
-       doenvd "${T}"/50boot0
-}
diff --git a/sys-freebsd/boot0/files/boot0-11.0-gcc46.patch b/sys-freebsd/boot0/files/boot0-11.0-gcc46.patch
deleted file mode 100644 (file)
index ec17d92..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/sys/boot/i386/boot2/Makefile b/sys/boot/i386/boot2/Makefile
-index ead9ad1..af5e021 100644
---- a/sys/boot/i386/boot2/Makefile
-+++ b/sys/boot/i386/boot2/Makefile
-@@ -45,6 +45,9 @@ CFLAGS.gcc+= -Os \
- .if ${COMPILER_TYPE} == "gcc" && ${COMPILER_VERSION} <= 40201
- CFLAGS.gcc+=   -mno-align-long-strings
- .endif
-+.if ${COMPILER_TYPE} == "gcc" && ${COMPILER_VERSION} >= 40600
-+CFLAGS.gcc+=  -fno-asynchronous-unwind-tables
-+.endif
- CFLAGS.clang+=        -Oz ${CLANG_OPT_SMALL}
diff --git a/sys-freebsd/boot0/files/boot0-add-nossp-cflags.patch b/sys-freebsd/boot0/files/boot0-add-nossp-cflags.patch
deleted file mode 100644 (file)
index abc6a57..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=511698
-
-diff --git a/sys/boot/Makefile.inc b/sys/boot/Makefile.inc
-index e0039b9..533dea0 100644
---- a/sys/boot/Makefile.inc
-+++ b/sys/boot/Makefile.inc
-@@ -1,3 +1,3 @@
- # $FreeBSD: release/10.0.0/sys/boot/Makefile.inc 188895 2009-02-21 15:04:31Z ru $
--SSP_CFLAGS=
-+SSP_CFLAGS= -fno-stack-protector
diff --git a/sys-freebsd/boot0/metadata.xml b/sys-freebsd/boot0/metadata.xml
deleted file mode 100644 (file)
index d9f0c83..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
-    <email>bsd@gentoo.org</email>
-    <name>BSD Project</name>
-  </maintainer>
-  <use>
-    <flag name="tftp">Enable PXE/TFTP boot support.</flag>
-    <flag name="zfs">Enable booting on ZFS filesystems.</flag>
-  </use>
-</pkgmetadata>