sci-physics/lammps: Fix broken python3 patch.
authorNicolas Bock <nicolasbock@gentoo.org>
Tue, 8 Sep 2015 12:04:24 +0000 (06:04 -0600)
committerNicolas Bock <nicolasbock@gentoo.org>
Tue, 8 Sep 2015 12:04:24 +0000 (06:04 -0600)
Package-Manager: portage-2.2.20.1

sci-physics/lammps/files/lammps-python3-r1.patch [new file with mode: 0644]
sci-physics/lammps/lammps-20150904.ebuild

diff --git a/sci-physics/lammps/files/lammps-python3-r1.patch b/sci-physics/lammps/files/lammps-python3-r1.patch
new file mode 100644 (file)
index 0000000..2dc2bd7
--- /dev/null
@@ -0,0 +1,11 @@
+--- lammps-4Sep15-orig/python/lammps.py        2015-09-02 14:41:38.000000000 -0600
++++ lammps-4Sep15/python/lammps.py     2015-09-08 05:59:16.000000000 -0600
+@@ -33,7 +33,7 @@
+     except:
+       type,value,tb = sys.exc_info()
+       traceback.print_exception(type,value,tb)
+-      raise OSError,"Could not load LAMMPS dynamic library from %s" % modpath
++      raise OSError("Could not load LAMMPS dynamic library from %s" % modpath)
+     # if no ptr provided, create an instance of LAMMPS
+     #   don't know how to pass an MPI communicator from PyPar
index 1a244c83975e133e6e1fe5f5310e35fe3b79f0a3..5400e87baefb467831a9aaf6407110062005b981 100644 (file)
@@ -167,7 +167,7 @@ src_prepare() {
                tools/Makefile || die
 
        # Patch python.
-       epatch "${FILESDIR}/lammps-python3.patch"
+       epatch "${FILESDIR}/lammps-python3-r1.patch"
        epatch "${FILESDIR}/python-shebang.patch"
 }