gui-libs/gtk-layer-shell: Add new package
authorAdam Feldman <NP-Hardass@gentoo.org>
Sat, 21 Mar 2020 18:50:04 +0000 (14:50 -0400)
committerAdam Feldman <NP-Hardass@gentoo.org>
Mon, 6 Apr 2020 17:48:14 +0000 (13:48 -0400)
Added as a dep for mate-base/mate-panel-1.24.0[wayland]

Package-Manager: Portage-2.3.82, Repoman-2.3.18
Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
gui-libs/gtk-layer-shell/Manifest [new file with mode: 0644]
gui-libs/gtk-layer-shell/gtk-layer-shell-0.1.0.ebuild [new file with mode: 0644]
gui-libs/gtk-layer-shell/metadata.xml [new file with mode: 0644]

diff --git a/gui-libs/gtk-layer-shell/Manifest b/gui-libs/gtk-layer-shell/Manifest
new file mode 100644 (file)
index 0000000..31d2fb0
--- /dev/null
@@ -0,0 +1 @@
+DIST gtk-layer-shell-0.1.0.tar.xz 34580 BLAKE2B db815d711e53485e00de2e0b7d238f6c66ddac9ca790d5f31c44eed965ad01ee07392d27552ae21bb1eab4905cc1d5f7dad9c10fd059afb43ba85c7ea1af2aa5 SHA512 3788559405a495d43279b20b9d64e1fb0fb9be4125eb3011a623565938246310c2e81cb6d52db111e42a9cd0739bb273ccf7fcb7c52db8b74a1e44108e061c6d
diff --git a/gui-libs/gtk-layer-shell/gtk-layer-shell-0.1.0.ebuild b/gui-libs/gtk-layer-shell/gtk-layer-shell-0.1.0.ebuild
new file mode 100644 (file)
index 0000000..3cff2fd
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+if [[ ${PV} == 9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/wmww/${PN}"
+else
+       SRC_URI="https://github.com/wmww/${PN}/releases/download/v${PV}/${P}.tar.xz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Library to create desktop components for Wayland using the Layer Shell protocol"
+HOMEPAGE="https://github.com/wmww/gtk-layer-shell"
+
+LICENSE="MIT-with-advertising"
+SLOT="0"
+IUSE="examples gtk-doc"
+
+DEPEND="
+       >=x11-libs/gtk+-3.22.0:3[introspection,wayland]
+       >=dev-libs/wayland-1.10.0
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+       local emesonargs=(
+               $(meson_use examples)
+               $(meson_use gtk-doc docs)
+       )
+       meson_src_configure
+}
diff --git a/gui-libs/gtk-layer-shell/metadata.xml b/gui-libs/gtk-layer-shell/metadata.xml
new file mode 100644 (file)
index 0000000..7b754d1
--- /dev/null
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>NP-Hardass@gentoo.org</email>
+               <name>NP-Hardass</name>
+       </maintainer>
+       <longdescription lang="en">
+               A library to create panels and other desktop components for Wayland using the Layer Shell protocol
+       </longdescription>
+       <upstream>
+               <remote-id type="github">wmww/gtk-layer-shell</remote-id>
+       </upstream>
+</pkgmetadata>