net-misc/openssh: add test ebuild for new LDAP implementation
authorThomas Deutschmann <whissi@gentoo.org>
Wed, 13 Jun 2018 15:23:27 +0000 (17:23 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Wed, 13 Jun 2018 15:25:44 +0000 (17:25 +0200)
We switched from dead openssh-lpk patch to Red Hat's rewritten
LDAP patch which makes use of "AuthorizedKeysCommand".

Warning:
Default LDAP scheme isn't compatible. Migration is needed.

Bug: https://bugs.gentoo.org/658044
Package-Manager: Portage-2.3.40, Repoman-2.3.9

net-misc/openssh/Manifest
net-misc/openssh/openssh-7.7_p1-r100.ebuild [new file with mode: 0644]

index b0fcdb7976a61d527c028c84b93fce3677d022a2..c673bcf6687dfdc3ac636e875eae6d366ba2a445 100644 (file)
@@ -7,6 +7,7 @@ DIST openssh-7.6p1+x509-11.2.diff.gz 466657 BLAKE2B 3f4f108e2d97eb292c215bc3a6e2
 DIST openssh-7.6p1-hpnssh14v12-r1.tar.xz 15440 BLAKE2B e140852a3ce63e4f744ed4b18b474cf88d09ca55509e5a16d26eef5cf8574466b472073eef56e19467932959d9ba7e941ab561d9ea0704dfee3fd08a6ba7ba8c SHA512 9d0450ec99fe550d790e471cb7815d0863788cf9c41dfef653d102f02be3d38a09e5103e537658279216a5815c1a075ded9f011e05ce216beee2c7daeea8c75a
 DIST openssh-7.6p1.tar.gz 1489788 BLAKE2B 938bfeeff0a0aaa2fc7e4c345f04561c6c071c526e354a7d344a08742cb70ab1f4a41d325b31720f2fba5c4afa4db11f3fc87055c8c9c8bea37b29cc11dc8f39 SHA512 de17fdcb8239401f76740c8d689a8761802f6df94e68d953f3c70b9f4f8bdb403617c48c1d01cc8c368d88e9d50aee540bf03d5a36687dfb39dfd28d73029d72
 DIST openssh-7.7p1-hpnssh14v15-gentoo1.patch.xz 22060 BLAKE2B 81a7f3d1346718c154b39920c126eb0b00ae43f1369d882b8a1bd0b885668805639d869581fb49a8e7c67b61d72a904fde45841e4396af426b136d6d2f0a0dc3 SHA512 7b437bc061677aeabe561ad74bb19bc6f85369119ad8a92fb430fb5c1394c2bb3afd472ee66b285362b2041f871c56633dc94fec33cb062c6b1817d63c1d4a78
+DIST openssh-7.7p1-ldap-20180327.patch.xz 19760 BLAKE2B f316ea65de3415b9ee19a621f36c5ce7e4bda7e1fe06e9edbc1e96e9d7296facf1a59dc79822939035c333a07b04a21d33c116fb74f36f1a93ac6849a4182166 SHA512 6439057839341169f9a198b25fdcbbddd50b0db0834aa762c16fb9b9b2e6b95b4ee9b4c6ad1cf2723750aacded4e6cba7f6036cdd91cf8d5e88eb21ea83790dd
 DIST openssh-7.7p1-patches-1.1.tar.xz 16476 BLAKE2B fca2885a9e29faec40700ece37a995ba83e40bd2a6875129a5327770d8ee43663a7c063de33b4653994ed7332adb03730f613c047550d874190b95c66e2e9efa SHA512 aa5e33ce4bb4be16abf27ac1bade1dc85c51d82002be546402e0b8b0685de3ec7029f0f56bf1295ec346eb3960a6bed7cfc882722e57957a19a732f3174b3039
 DIST openssh-7.7p1-sctp-1.0.patch.xz 7380 BLAKE2B 6ad40972ece131ff148ede6ba94d63bffc606e0bcabb959d4c9056196cb6f4fddc285f97d7b49b73fde7ee84e3c981c07bddb058ad88eb7c7c2fe716e657c630 SHA512 bc5f50805ba25415f93f61b6654e5bcbaef673b0af48d339116ca9c94b6152afae294c5a9144adeb40190da97c2fc73b43e3ac7ac34feb4a647628327a7cac0a
 DIST openssh-7.7p1-x509-11.3.1.patch.xz 362672 BLAKE2B 55b8b0ef00dc4d962a0db1115406b7b1e84110870c74198e9e4cb081b2ffde8daca67cb281c69d73b4c5cbffde361429d62634be194b57e888a0b434a0f42a37 SHA512 f84744f6d2e5a15017bce37bfa65ebb47dbafeac07ea9aab46bdc780b4062ff70687512d9d512cab81e3b9c701adb6ce17c5474f35cb4b49f57db2e2d45ac9ac
diff --git a/net-misc/openssh/openssh-7.7_p1-r100.ebuild b/net-misc/openssh/openssh-7.7_p1-r100.ebuild
new file mode 100644 (file)
index 0000000..8aa36a5
--- /dev/null
@@ -0,0 +1,440 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit user flag-o-matic multilib autotools pam systemd versionator
+
+# Make it more portable between straight releases
+# and _p? releases.
+PARCH=${P/_}
+
+HPN_VER="14v15-gentoo1" HPN_PATCH="${PARCH}-hpnssh${HPN_VER}.patch.xz"
+SCTP_VER="1.0" SCTP_PATCH="${PARCH}-sctp-${SCTP_VER}.patch.xz"
+X509_VER="11.3.1" X509_PATCH="${PARCH}-x509-${X509_VER}.patch.xz"
+LDAP_VER="20180327" LDAP_PATCH="${PARCH}-ldap-${LDAP_VER}.patch.xz"
+
+PATCH_SET="openssh-7.7p1-patches-1.1"
+
+DESCRIPTION="Port of OpenBSD's free SSH release"
+HOMEPAGE="https://www.openssh.com/"
+SRC_URI="mirror://openbsd/OpenSSH/portable/${PARCH}.tar.gz
+       https://dev.gentoo.org/~whissi/dist/${PN}/${PATCH_SET}.tar.xz
+       ${SCTP_PATCH:+sctp? ( https://dev.gentoo.org/~whissi/dist/openssh/${SCTP_PATCH} )}
+       ${HPN_PATCH:+hpn? ( https://dev.gentoo.org/~whissi/dist/openssh/${HPN_PATCH} )}
+       ${LDAP_PATCH:+ldap? ( https://dev.gentoo.org/~whissi/dist/openssh/${LDAP_PATCH} )}
+       ${X509_PATCH:+X509? ( https://dev.gentoo.org/~whissi/dist/openssh/${X509_PATCH} )}
+       "
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+# Probably want to drop ssl defaulting to on in a future version.
+IUSE="abi_mips_n32 audit bindist debug hpn kerberos kernel_linux ldap ldns libedit libressl livecd pam +pie sctp selinux skey +ssl static test X X509"
+REQUIRED_USE="ldns? ( ssl )
+       pie? ( !static )
+       static? ( !kerberos !pam )
+       X509? ( !ldap !sctp ssl )
+       test? ( ssl )"
+
+LIB_DEPEND="
+       audit? ( sys-process/audit[static-libs(+)] )
+       ldns? (
+               net-libs/ldns[static-libs(+)]
+               !bindist? ( net-libs/ldns[ecdsa,ssl(+)] )
+               bindist? ( net-libs/ldns[-ecdsa,ssl(+)] )
+       )
+       libedit? ( dev-libs/libedit:=[static-libs(+)] )
+       sctp? ( net-misc/lksctp-tools[static-libs(+)] )
+       selinux? ( >=sys-libs/libselinux-1.28[static-libs(+)] )
+       skey? ( >=sys-auth/skey-1.1.5-r1[static-libs(+)] )
+       ssl? (
+               !libressl? (
+                       >=dev-libs/openssl-1.0.1:0=[bindist=]
+                       dev-libs/openssl:0=[static-libs(+)]
+               )
+               libressl? ( dev-libs/libressl:0=[static-libs(+)] )
+       )
+       >=sys-libs/zlib-1.2.3:=[static-libs(+)]"
+RDEPEND="
+       !static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+       pam? ( virtual/pam )
+       kerberos? ( virtual/krb5 )
+       ldap? ( net-nds/openldap )"
+DEPEND="${RDEPEND}
+       static? ( ${LIB_DEPEND} )
+       virtual/pkgconfig
+       virtual/os-headers
+       sys-devel/autoconf"
+RDEPEND="${RDEPEND}
+       pam? ( >=sys-auth/pambase-20081028 )
+       userland_GNU? ( virtual/shadow )
+       X? ( x11-apps/xauth )"
+
+S="${WORKDIR}/${PARCH}"
+
+pkg_pretend() {
+       # this sucks, but i'd rather have people unable to `emerge -u openssh`
+       # than not be able to log in to their server any more
+       maybe_fail() { [[ -z ${!2} ]] && echo "$1" ; }
+       local fail="
+               $(use hpn && maybe_fail hpn HPN_PATCH)
+               $(use ldap && maybe_fail ldap LDAP_PATCH)
+               $(use sctp && maybe_fail sctp SCTP_PATCH)
+               $(use X509 && maybe_fail X509 X509_PATCH)
+       "
+       fail=$(echo ${fail})
+       if [[ -n ${fail} ]] ; then
+               eerror "Sorry, but this version does not yet support features"
+               eerror "that you requested:      ${fail}"
+               eerror "Please mask ${PF} for now and check back later:"
+               eerror " # echo '=${CATEGORY}/${PF}' >> /etc/portage/package.mask"
+               die "booooo"
+       fi
+
+       # Make sure people who are using tcp wrappers are notified of its removal. #531156
+       if grep -qs '^ *sshd *:' "${EROOT%/}"/etc/hosts.{allow,deny} ; then
+               ewarn "Sorry, but openssh no longer supports tcp-wrappers, and it seems like"
+               ewarn "you're trying to use it.  Update your ${EROOT}etc/hosts.{allow,deny} please."
+       fi
+}
+
+src_prepare() {
+       sed -i \
+               -e "/_PATH_XAUTH/s:/usr/X11R6/bin/xauth:${EPREFIX%/}/usr/bin/xauth:" \
+               pathnames.h || die
+
+       # don't break .ssh/authorized_keys2 for fun
+       sed -i '/^AuthorizedKeysFile/s:^:#:' sshd_config || die
+
+       eapply "${FILESDIR}"/${PN}-7.7_p1-GSSAPI-dns.patch #165444 integrated into gsskex
+       eapply "${FILESDIR}"/${PN}-6.7_p1-openssl-ignore-status.patch
+       eapply "${FILESDIR}"/${PN}-7.5_p1-disable-conch-interop-tests.patch
+
+       local PATCHSET_VERSION_MACROS=()
+
+       if use X509 ; then
+               eapply "${WORKDIR}"/${X509_PATCH%.*}
+
+               # We need to patch package version or any X.509 sshd will reject our ssh client
+               # with "userauth_pubkey: could not parse key: string is too large [preauth]"
+               # error
+               einfo "Patching package version for X.509 patch set ..."
+               sed -i \
+                       -e "s/^AC_INIT(\[OpenSSH\], \[Portable\]/AC_INIT([OpenSSH], [${X509_VER}]/" \
+                       "${S}"/configure.ac || die "Failed to patch package version for X.509 patch"
+
+               einfo "Patching version.h to expose X.509 patch set ..."
+               sed -i \
+                       -e "/^#define SSH_PORTABLE.*/a #define SSH_X509               \"-PKIXSSH-${X509_VER}\"" \
+                       "${S}"/version.h || die "Failed to sed-in X.509 patch version"
+               PATCHSET_VERSION_MACROS+=( 'SSH_X509' )
+
+               einfo "Disabling broken X.509 agent test ..."
+               sed -i \
+                       -e "/^ agent$/d" \
+                       "${S}"/tests/CA/config || die "Failed to disable broken X.509 agent test"
+
+               # The following patches don't apply on top of X509 patch
+               rm "${WORKDIR}"/patch/2002_all_openssh-7.7p1_upstream_bug2840.patch || die
+               rm "${WORKDIR}"/patch/2009_all_openssh-7.7p1_make-shell-tests-portable.patch || die
+               rm "${WORKDIR}"/patch/2016_all_openssh-7.7p1_implement-EMFILE-mitigation-for-ssh-agent.patch || die
+               rm "${WORKDIR}"/patch/2025_all_openssh-7.7p1_prefer-argv0-to-ssh-when-re-executing-ssh-for-proxyjump.patch || die
+       else
+               rm "${WORKDIR}"/patch/2016_all_openssh-7.7p1-X509_implement-EMFILE-mitigation-for-ssh-agent.patch || die
+               rm "${WORKDIR}"/patch/2025_all_openssh-7.7p1-X509_prefer-argv0-to-ssh-when-re-executing-ssh-for-proxyjump.patch || die
+       fi
+
+       if use ldap ; then
+               sed -i \
+                       -e "s/ -lfipscheck//" \
+                       "${WORKDIR}"/${LDAP_PATCH%.*} || die "Failed to remove fipscheck from LDAP patch"
+               eapply "${WORKDIR}"/${LDAP_PATCH%.*}
+
+               einfo "Patching version.h to expose LDAP patch set ..."
+               sed -i \
+                       -e "/^#define SSH_PORTABLE.*/a #define SSH_LDAP               \"-ldap-${LDAP_VER}\"" \
+                       "${S}"/version.h || die "Failed to sed-in LDAP patch version"
+               PATCHSET_VERSION_MACROS+=( 'SSH_LDAP' )
+       fi
+
+       if use sctp ; then
+               eapply "${WORKDIR}"/${SCTP_PATCH%.*}
+
+               einfo "Patching version.h to expose SCTP patch set ..."
+               sed -i \
+                       -e "/^#define SSH_PORTABLE/a #define SSH_SCTP        \"-sctp-${SCTP_VER}\"" \
+                       "${S}"/version.h || die "Failed to sed-in SCTP patch version"
+               PATCHSET_VERSION_MACROS+=( 'SSH_SCTP' )
+
+               einfo "Disabling know failing test (cfgparse) caused by SCTP patch ..."
+               sed -i \
+                       -e "/\t\tcfgparse \\\/d" \
+                       "${S}"/regress/Makefile || die "Failed to disable known failing test (cfgparse) caused by SCTP patch"
+       fi
+
+       if use hpn ; then
+               eapply "${WORKDIR}"/${HPN_PATCH%.*}
+
+               einfo "Patching Makefile.in for HPN patch set ..."
+               sed -i \
+                       -e "/^LIBS=/ s/\$/ -lpthread/" \
+                       "${S}"/Makefile.in || die "Failed to patch Makefile.in"
+
+               einfo "Patching version.h to expose HPN patch set ..."
+               sed -i \
+                       -e "/^#define SSH_PORTABLE/a #define SSH_HPN         \"-hpn${HPN_VER}\"" \
+                       "${S}"/version.h || die "Failed to sed-in HPN patch version"
+               PATCHSET_VERSION_MACROS+=( 'SSH_HPN' )
+
+               if [[ -n "${HPN_DISABLE_MTAES}" ]] ; then
+                       einfo "Disabling known non-working MT AES cipher per default ..."
+
+                       cat > "${T}"/disable_mtaes.conf <<- EOF
+                       
+                       # HPN's Multi-Threaded AES CTR cipher is currently known to be broken
+                       # and therefore disabled per default.
+                       DisableMTAES yes
+                       EOF
+                       sed -i \
+                               -e "/^#HPNDisabled.*/r ${T}/disable_mtaes.conf" \
+                               "${S}"/sshd_config || die "Failed to disabled MT AES ciphers in sshd_config"
+
+                       sed -i \
+                               -e "/AcceptEnv.*_XXX_TEST$/a \\\tDisableMTAES\t\tyes" \
+                               "${S}"/regress/test-exec.sh || die "Failed to disable MT AES ciphers in test config"
+               fi
+       fi
+
+       if use X509 || use hpn ; then
+               einfo "Patching packet.c for X509 and/or HPN patch set ..."
+               sed -i \
+                       -e "s/const struct sshcipher/struct sshcipher/" \
+                       "${S}"/packet.c || die "Failed to patch ssh_packet_set_connection() (packet.c)"
+       fi
+
+       if use X509 || use sctp || use ldap || use hpn ; then
+               einfo "Patching sshconnect.c to use SSH_RELEASE in send_client_banner() ..."
+               sed -i \
+                       -e "s/PROTOCOL_MAJOR_2, PROTOCOL_MINOR_2, SSH_VERSION/PROTOCOL_MAJOR_2, PROTOCOL_MINOR_2, SSH_RELEASE/" \
+                       "${S}"/sshconnect.c || die "Failed to patch send_client_banner() to use SSH_RELEASE (sshconnect.c)"
+
+               einfo "Patching sshd.c to use SSH_RELEASE in sshd_exchange_identification() ..."
+               sed -i \
+                       -e "s/PROTOCOL_MAJOR_2, PROTOCOL_MINOR_2, SSH_VERSION/PROTOCOL_MAJOR_2, PROTOCOL_MINOR_2, SSH_RELEASE/" \
+                       "${S}"/sshd.c || die "Failed to patch sshd_exchange_identification() to use SSH_RELEASE (sshd.c)"
+
+               einfo "Patching version.h to add our patch sets to SSH_RELEASE ..."
+               sed -i \
+                       -e "s/^#define SSH_RELEASE.*/#define SSH_RELEASE     SSH_VERSION SSH_PORTABLE ${PATCHSET_VERSION_MACROS[*]}/" \
+                       "${S}"/version.h || die "Failed to patch SSH_RELEASE (version.h)"
+       fi
+
+       sed -i \
+               -e "/#UseLogin no/d" \
+               "${S}"/sshd_config || die "Failed to remove removed UseLogin option (sshd_config)"
+
+       eapply "${WORKDIR}"/patch/*.patch
+
+       eapply_user #473004
+
+       tc-export PKG_CONFIG
+       local sed_args=(
+               -e "s:-lcrypto:$(${PKG_CONFIG} --libs openssl):"
+               # Disable PATH reset, trust what portage gives us #254615
+               -e 's:^PATH=/:#PATH=/:'
+               # Disable fortify flags ... our gcc does this for us
+               -e 's:-D_FORTIFY_SOURCE=2::'
+       )
+
+       # The -ftrapv flag ICEs on hppa #505182
+       use hppa && sed_args+=(
+               -e '/CFLAGS/s:-ftrapv:-fdisable-this-test:'
+               -e '/OSSH_CHECK_CFLAG_LINK.*-ftrapv/d'
+       )
+       # _XOPEN_SOURCE causes header conflicts on Solaris
+       [[ ${CHOST} == *-solaris* ]] && sed_args+=(
+               -e 's/-D_XOPEN_SOURCE//'
+       )
+       sed -i "${sed_args[@]}" configure{.ac,} || die
+
+       eautoreconf
+}
+
+src_configure() {
+       addwrite /dev/ptmx
+
+       use debug && append-cppflags -DSANDBOX_SECCOMP_FILTER_DEBUG
+       use static && append-ldflags -static
+
+       local myconf=(
+               --with-ldflags="${LDFLAGS}"
+               --disable-strip
+               --with-pid-dir="${EPREFIX}"$(usex kernel_linux '' '/var')/run
+               --sysconfdir="${EPREFIX%/}"/etc/ssh
+               --libexecdir="${EPREFIX%/}"/usr/$(get_libdir)/misc
+               --datadir="${EPREFIX%/}"/usr/share/openssh
+               --with-privsep-path="${EPREFIX%/}"/var/empty
+               --with-privsep-user=sshd
+               $(use_with audit audit linux)
+               $(use_with kerberos kerberos5 "${EPREFIX%/}"/usr)
+               # We apply the ldap and sctp patch conditionally, so can't pass --without-{ldap,sctp}
+               # unconditionally else we get unknown flag warnings.
+               $(use ldap && use_with ldap)
+               $(use sctp && use_with sctp)
+               $(use_with ldns)
+               $(use_with libedit)
+               $(use_with pam)
+               $(use_with pie)
+               $(use_with selinux)
+               $(use_with skey)
+               $(use_with ssl openssl)
+               $(use_with ssl md5-passwords)
+               $(use_with ssl ssl-engine)
+       )
+
+       # The seccomp sandbox is broken on x32, so use the older method for now. #553748
+       use amd64 && [[ ${ABI} == "x32" ]] && myconf+=( --with-sandbox=rlimit )
+
+       econf "${myconf[@]}"
+}
+
+src_test() {
+       local t skipped=() failed=() passed=()
+       local tests=( interop-tests compat-tests )
+
+       local shell=$(egetshell "${UID}")
+       if [[ ${shell} == */nologin ]] || [[ ${shell} == */false ]] ; then
+               elog "Running the full OpenSSH testsuite requires a usable shell for the 'portage'"
+               elog "user, so we will run a subset only."
+               skipped+=( tests )
+       else
+               tests+=( tests )
+       fi
+
+       # It will also attempt to write to the homedir .ssh.
+       local sshhome=${T}/homedir
+       mkdir -p "${sshhome}"/.ssh
+       for t in "${tests[@]}" ; do
+               # Some tests read from stdin ...
+               HOMEDIR="${sshhome}" HOME="${sshhome}" \
+               emake -k -j1 ${t} </dev/null \
+                       && passed+=( "${t}" ) \
+                       || failed+=( "${t}" )
+       done
+
+       einfo "Passed tests: ${passed[*]}"
+       [[ ${#skipped[@]} -gt 0 ]] && ewarn "Skipped tests: ${skipped[*]}"
+       [[ ${#failed[@]}  -gt 0 ]] && die "Some tests failed: ${failed[*]}"
+}
+
+src_install() {
+       emake install-nokeys DESTDIR="${D}"
+       fperms 600 /etc/ssh/sshd_config
+       dobin contrib/ssh-copy-id
+       newinitd "${FILESDIR}"/sshd.rc6.5 sshd
+       newconfd "${FILESDIR}"/sshd-r1.confd sshd
+
+       newpamd "${FILESDIR}"/sshd.pam_include.2 sshd
+       if use pam ; then
+               sed -i \
+                       -e "/^#UsePAM /s:.*:UsePAM yes:" \
+                       -e "/^#PasswordAuthentication /s:.*:PasswordAuthentication no:" \
+                       -e "/^#PrintMotd /s:.*:PrintMotd no:" \
+                       -e "/^#PrintLastLog /s:.*:PrintLastLog no:" \
+                       "${ED%/}"/etc/ssh/sshd_config || die
+       fi
+
+       # Gentoo tweaks to default config files
+       cat <<-EOF >> "${ED%/}"/etc/ssh/sshd_config
+
+       # Allow client to pass locale environment variables #367017
+       AcceptEnv LANG LC_*
+       EOF
+       cat <<-EOF >> "${ED%/}"/etc/ssh/ssh_config
+
+       # Send locale environment variables #367017
+       SendEnv LANG LC_*
+       EOF
+
+       if use livecd ; then
+               sed -i \
+                       -e '/^#PermitRootLogin/c# Allow root login with password on livecds.\nPermitRootLogin Yes' \
+                       "${ED%/}"/etc/ssh/sshd_config || die
+       fi
+
+       if use ldap && [[ -n ${LDAP_PATCH} ]] ; then
+               insinto /etc/openldap/schema/
+               doins openssh-lpk-{sun,openldap}.schema
+       fi
+
+       doman contrib/ssh-copy-id.1
+       dodoc CREDITS OVERVIEW README* TODO sshd_config
+       use hpn && dodoc HPN-README
+       use X509 || dodoc ChangeLog
+
+       diropts -m 0700
+       dodir /etc/skel/.ssh
+
+       keepdir /var/empty
+
+       systemd_dounit "${FILESDIR}"/sshd.{service,socket}
+       systemd_newunit "${FILESDIR}"/sshd_at.service 'sshd@.service'
+}
+
+pkg_preinst() {
+       enewgroup sshd 22
+       enewuser sshd 22 -1 /var/empty sshd
+}
+
+pkg_postinst() {
+       if has_version "<${CATEGORY}/${PN}-5.8_p1" ; then
+               elog "Starting with openssh-5.8p1, the server will default to a newer key"
+               elog "algorithm (ECDSA).  You are encouraged to manually update your stored"
+               elog "keys list as servers update theirs.  See ssh-keyscan(1) for more info."
+       fi
+       if has_version "<${CATEGORY}/${PN}-7.0_p1" ; then
+               elog "Starting with openssh-6.7, support for USE=tcpd has been dropped by upstream."
+               elog "Make sure to update any configs that you might have.  Note that xinetd might"
+               elog "be an alternative for you as it supports USE=tcpd."
+       fi
+       if has_version "<${CATEGORY}/${PN}-7.1_p1" ; then #557388 #555518
+               elog "Starting with openssh-7.0, support for ssh-dss keys were disabled due to their"
+               elog "weak sizes.  If you rely on these key types, you can re-enable the key types by"
+               elog "adding to your sshd_config or ~/.ssh/config files:"
+               elog "  PubkeyAcceptedKeyTypes=+ssh-dss"
+               elog "You should however generate new keys using rsa or ed25519."
+
+               elog "Starting with openssh-7.0, the default for PermitRootLogin changed from 'yes'"
+               elog "to 'prohibit-password'.  That means password auth for root users no longer works"
+               elog "out of the box.  If you need this, please update your sshd_config explicitly."
+       fi
+       if has_version "<${CATEGORY}/${PN}-7.6_p1" ; then
+               elog "Starting with openssh-7.6p1, openssh upstream has removed ssh1 support entirely."
+               elog "Furthermore, rsa keys with less than 1024 bits will be refused."
+       fi
+       if ! use ssl && has_version "${CATEGORY}/${PN}[ssl]" ; then
+               elog "Be aware that by disabling openssl support in openssh, the server and clients"
+               elog "no longer support dss/rsa/ecdsa keys.  You will need to generate ed25519 keys"
+               elog "and update all clients/servers that utilize them."
+       fi
+
+       if use hpn && [[ -n "${HPN_DISABLE_MTAES}" ]] ; then
+               elog ""
+               elog "HPN's multi-threaded AES CTR cipher is currently known to be broken"
+               elog "and therefore disabled at runtime per default."
+               elog "Make sure your sshd_config is up to date and contains"
+               elog ""
+               elog "  DisableMTAES yes"
+               elog ""
+               elog "Otherwise you maybe unable to connect to this sshd using any AES CTR cipher."
+               elog ""
+       fi
+
+       if use ldap && [[ -n ${LDAP_PATCH} ]] && has_version "<${CATEGORY}/${PN}-7.7_p1" ; then
+               elog "Starting with openssh-7.7_p1, the LDAP implementation was changed."
+               elog "You must revise your configuration or your previous LDAP setup will stop working."
+               elog ""
+               elog "See https://wiki.gentoo.org/wiki/SSH/LDAP_migration for migration details."
+       fi
+}