sci-libs/tensorflow-estimator: bump 2.2.0
authorJason Zaman <perfinion@gentoo.org>
Mon, 11 May 2020 06:09:18 +0000 (14:09 +0800)
committerJason Zaman <perfinion@gentoo.org>
Sat, 16 May 2020 00:52:16 +0000 (08:52 +0800)
Package-Manager: Portage-2.3.99, Repoman-2.3.20
Signed-off-by: Jason Zaman <perfinion@gentoo.org>
sci-libs/tensorflow-estimator/Manifest
sci-libs/tensorflow-estimator/tensorflow-estimator-2.2.0.ebuild [new file with mode: 0644]

index 06d4719feee44ea37af576bdedef4b0707050ea8..e67cc45af4063e8bfaa52bfec0173f636a8736ed 100644 (file)
@@ -4,3 +4,4 @@ DIST bazelbuild-rules_java-7cf3cefd652008d0a64a419c34c13bdca6c8f178.zip 9422 BLA
 DIST tensorflow-estimator-1.15.1.tar.gz 696316 BLAKE2B 7797ae13fa5f56920df912f7d0eaef214a381acb25632dc2d21c6bbf5744bcc36b32f21e30b18be16d37f7a1deb30b2139d58c2c0f97a1de7a5f767a8a5462d8 SHA512 ae42057870cfb0e19d45ee59bd99c110ecfb3ae43cd5a5536711c7d2528b429c433b0f594e462eae9c40b34dd7813f3b14b1282cbf2edc725e13c45e93da818d
 DIST tensorflow-estimator-2.0.1.tar.gz 618583 BLAKE2B d4ae6225cb8a56febc9ffa64d5f811fc41db462534361a183095f724ce6deb17fa22edbd13bacd2d556adcc023dff1daeb7bf7338360b3cb49b19dc3bc3e97d0 SHA512 d7aa35784aa2726c49039be50b73cc957e7f883414bb43101527918bacfa55632df89e6f54cfc58a096512fc49a6ea7524aea87af0579c2a52db2ca7f5ee4bc2
 DIST tensorflow-estimator-2.1.tar.gz 622792 BLAKE2B d1c8abb22d90c789ebfadaf78ca932f87428274afe6e1ac20670bf6d2b4c1c6ea8f367b1eb7ee64ff9f6e9b8ecdc2f64113924e7e2286e3f4e3d2c36cb101794 SHA512 4aaa21969299b02443e9396c238ef4c03af3bde1d0142a81c04d9706f18b02bfd125f3aaf8ffb47e0a3ffad949c3d3bca3909375f12a1c1e4c55ca1cc7930d51
+DIST tensorflow-estimator-2.2.0.tar.gz 627362 BLAKE2B 125792fc2167b8af837a99b08a9a26943bc5c1fda8ab3690b01c0d49a6dd39142ff4a063867dfe1bee3b99fb018981d0e4ee45d194caac2cd96a829ad22db0ad SHA512 aaf743835e2c606439fcccb56742997e930ba0e72c01d51633ce86824bbfaacd64607dc1fd7fb9604cc444feb65ebae60c2266be084e1b49ef2a1a9ca5a3d60d
diff --git a/sci-libs/tensorflow-estimator/tensorflow-estimator-2.2.0.ebuild b/sci-libs/tensorflow-estimator/tensorflow-estimator-2.2.0.ebuild
new file mode 100644 (file)
index 0000000..32a54df
--- /dev/null
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+MY_PN="estimator"
+MY_PV=${PV/_rc/-rc}
+MY_P=${MY_PN}-${MY_PV}
+
+inherit bazel distutils-r1 flag-o-matic toolchain-funcs
+
+DESCRIPTION="A high-level TensorFlow API that greatly simplifies machine learning programming"
+HOMEPAGE="https://www.tensorflow.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+bazel_external_uris="
+       https://github.com/bazelbuild/rules_cc/archive/0d5f3f2768c6ca2faca0079a997a97ce22997a0c.zip -> bazelbuild-rules_cc-0d5f3f2768c6ca2faca0079a997a97ce22997a0c.zip
+       https://github.com/bazelbuild/rules_cc/archive/8bd6cd75d03c01bb82561a96d9c1f9f7157b13d0.zip -> bazelbuild-rules_cc-8bd6cd75d03c01bb82561a96d9c1f9f7157b13d0.zip
+       https://github.com/bazelbuild/rules_java/archive/7cf3cefd652008d0a64a419c34c13bdca6c8f178.zip -> bazelbuild-rules_java-7cf3cefd652008d0a64a419c34c13bdca6c8f178.zip"
+
+SRC_URI="https://github.com/tensorflow/${MY_PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz
+       ${bazel_external_uris}"
+
+RDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       dev-java/java-config"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+src_unpack() {
+       unpack "${P}.tar.gz"
+       bazel_load_distfiles "${bazel_external_uris}"
+}
+
+src_prepare() {
+       bazel_setup_bazelrc
+       default
+}
+
+src_compile() {
+       export JAVA_HOME=$(java-config --jre-home)
+
+       ebazel build //tensorflow_estimator/tools/pip_package:build_pip_package
+       ebazel shutdown
+
+       local srcdir="${T}/src"
+       mkdir -p "${srcdir}" || die
+       bazel-bin/tensorflow_estimator/tools/pip_package/build_pip_package --src "${srcdir}" || die
+}
+
+src_install() {
+       do_install() {
+               cd "${T}/src" || die
+               esetup.py install
+               python_optimize
+       }
+       python_foreach_impl do_install
+
+       cd "${S}" || die
+       einstalldocs
+}