sys-boot/syslinux: Drop old (EAPI 0)
authorMichał Górny <mgorny@gentoo.org>
Thu, 7 Nov 2019 07:18:59 +0000 (08:18 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 7 Nov 2019 07:18:59 +0000 (08:18 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-boot/syslinux/Manifest
sys-boot/syslinux/syslinux-4.07.ebuild [deleted file]

index f247daa774875c95970265a481434d640999f222..b9ab5dc8f2493baf8339f28641e2734fa6cba744 100644 (file)
@@ -1,4 +1,3 @@
-DIST syslinux-4.07.tar.bz2 5761877 BLAKE2B 2fe28f268f896601a045564b1e3dde618d57ebf4098d007f7e45119ad019fa88221658608f88e55d4d09cd297140427cdeaf03a40a2341d732064a0630fe92b5 SHA512 8efbd14803ec74c5ee699a754b4727e4b975c08afd4dbb39f4b7ccdb90743e4459cd4609c6f1065c7b7efaa26c9d465806254891795d363758f35a2fe5704ae5
 DIST syslinux-5.10.tar.xz 5315660 BLAKE2B 19d6861bb6220fe57e12d8d6118d37b197c3c771e4d2e7a51ce7db39219e3c837e6d1543d7a3927820f3a34da34ce849f9badbaf9cd83cb5ee24fd5ed7b705f2 SHA512 56422e14b4aa53ca1a5811da0582dbbb349aa52b9e78868bbedc24c67ef2420c4d0ac63fd68c7f0adc2c22606196276265d503b5b6f9d3d796d9ce42845bbdb5
 DIST syslinux-6.03.tar.xz 6855224 BLAKE2B 9caccf8bed4e3c3e87393c9dc8f3b3d267c14469bbf8135a648ea41d8a43a4aedbf2b007c6b9a6853de8866152f5bc33e5ea85fca1db86c5f2fac88d97189b0f SHA512 dd2b2916962b9e93bc1e714182e3ca2a727a229b8afabe913050bcfdd43ee2af51ee3acf79121d8c20caf434583efaa7f3196871e0e07c04d82191323a50fe31
 DIST syslinux-6.04-pre1.tar.xz 5283272 BLAKE2B 800e5977ed13b26a1756c33d8625e850631b642e26a86e3328196ddd998596693c3a26db0ada4c0ba78a4ba692a1cc01886b6eb693d877ddafcfb325ecdeb639 SHA512 7927dd39be8e2dcf4138a6fea33def67d19d938379d694f15b48fdd2f5924c028b7a9e7bd71d0c7c6630c203e9e2a54296628e530632ad5e6f55b1ebefe8fc98
diff --git a/sys-boot/syslinux/syslinux-4.07.ebuild b/sys-boot/syslinux/syslinux-4.07.ebuild
deleted file mode 100644 (file)
index 021f559..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="SYSLINUX, PXELINUX, ISOLINUX, EXTLINUX and MEMDISK bootloaders"
-HOMEPAGE="https://syslinux.zytor.com/"
-SRC_URI="https://www.kernel.org/pub/linux/utils/boot/syslinux/${PV:0:1}.xx/${P/_/-}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* amd64 x86"
-IUSE="custom-cflags"
-
-RDEPEND="sys-fs/mtools
-               dev-perl/Crypt-PasswdMD5
-               dev-perl/Digest-SHA1"
-DEPEND="${RDEPEND}
-       dev-lang/nasm
-       virtual/os-headers"
-
-S=${WORKDIR}/${P/_/-}
-
-# This ebuild is a departure from the old way of rebuilding everything in syslinux
-# This departure is necessary since hpa doesn't support the rebuilding of anything other
-# than the installers.
-
-# removed all the unpack/patching stuff since we aren't rebuilding the core stuff anymore
-
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-       # Fix building on hardened
-       epatch "${FILESDIR}"/${PN}-4.05-nopie.patch
-
-       rm -f gethostip #bug 137081
-
-       # Don't prestrip or override user LDFLAGS, bug #305783
-       local SYSLINUX_MAKEFILES="extlinux/Makefile linux/Makefile mtools/Makefile \
-               sample/Makefile utils/Makefile"
-       sed -i ${SYSLINUX_MAKEFILES} -e '/^LDFLAGS/d' || die "sed failed"
-
-       if use custom-cflags; then
-               sed -i ${SYSLINUX_MAKEFILES} \
-                       -e 's|-g -Os||g' \
-                       -e 's|-Os||g' \
-                       -e 's|CFLAGS[[:space:]]\+=|CFLAGS +=|g' \
-                       || die "sed custom-cflags failed"
-       else
-               QA_FLAGS_IGNORED="
-                       /sbin/extlinux
-                       /usr/bin/memdiskfind
-                       /usr/bin/gethostip
-                       /usr/bin/isohybrid
-                       /usr/bin/syslinux
-                       "
-       fi
-
-}
-
-src_compile() {
-       emake CC="$(tc-getCC)" installer || die
-}
-
-src_install() {
-       emake INSTALLSUBDIRS=utils INSTALLROOT="${D}" MANDIR=/usr/share/man install || die
-       dodoc README NEWS doc/*.txt || die
-}