dev-python/pycurl: Disable tests broken by bottle upgrade
authorMichał Górny <mgorny@gentoo.org>
Sat, 16 May 2020 16:11:07 +0000 (18:11 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 16 May 2020 16:12:47 +0000 (18:12 +0200)
Upstream is silly and requires old dev-python/bottle version
for testing.  Instead of harming users and preventing downgrade, let's
disable the few tests that require that.

Closes: https://bugs.gentoo.org/721270
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pycurl/pycurl-7.43.0.5.ebuild

index 0bdbcb60e90161bff019c626b038c72b81f9f210..a299572dfd1102b5ee26f79993de2ceff193f23d 100644 (file)
@@ -54,6 +54,8 @@ PATCHES=(
 
 python_prepare_all() {
        sed -e "/setup_args\['data_files'\] = /d" -i setup.py || die
+       # these tests are broken with newer versions of bottle
+       sed -e 's:test.*_invalid_utf8:_&:' -i tests/getinfo_test.py || die
        distutils-r1_python_prepare_all
 }