media-libs/ganv: update
authorMiroslav Šulc <fordfrog@gentoo.org>
Fri, 20 Dec 2019 11:19:57 +0000 (12:19 +0100)
committerMiroslav Šulc <fordfrog@gentoo.org>
Fri, 20 Dec 2019 11:19:57 +0000 (12:19 +0100)
1) rebased patch
2) eapi6
3) added missing dep (bug #668592)

Closes: https://bugs.gentoo.org/668592
Package-Manager: Portage-2.3.82, Repoman-2.3.20
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
media-libs/ganv/files/ganv-1.4.2-no-fdgl.patch
media-libs/ganv/ganv-1.4.2-r1.ebuild [moved from media-libs/ganv/ganv-1.4.2.ebuild with 86% similarity]

index 17cc2432d0ec96e8a026887af5c8bab5864e903c..3fb29a7f0b5435ca50e2fb68c23fe41cee5e47d3 100644 (file)
@@ -1,8 +1,8 @@
-Index: src/Canvas.cpp
-===================================================================
---- src/Canvas.cpp     (revision 5479)
-+++ src/Canvas.cpp     (revision 5480)
-@@ -760,6 +760,18 @@
+diff --git a/src/Canvas.cpp b/src/Canvas.cpp
+index c01021c..1c66a6c 100644
+--- a/src/Canvas.cpp
++++ b/src/Canvas.cpp
+@@ -760,6 +760,18 @@ GanvCanvasImpl::layout_dot(const std::string& filename)
  }
  #endif
  
@@ -21,7 +21,7 @@ Index: src/Canvas.cpp
  #ifdef GANV_FDGL
  
  inline Region
-@@ -788,18 +800,6 @@
+@@ -788,18 +800,6 @@ apply_force(GanvNode* a, GanvNode* b, const Vector& f)
        b->impl->force = vec_sub(b->impl->force, f);
  }
  
similarity index 86%
rename from media-libs/ganv/ganv-1.4.2.ebuild
rename to media-libs/ganv/ganv-1.4.2-r1.ebuild
index dafedc72ffdad6e0ca0ae31729777ddbf2df547d..3d19184be690cb6a46d28f47a79f7fc82bac6892 100644 (file)
@@ -1,7 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=6
+# oes not work with python3
 PYTHON_COMPAT=( python2_7 )
 PYTHON_REQ_USE='threads(+)'
 inherit eutils flag-o-matic waf-utils python-any-r1
@@ -26,12 +27,13 @@ RDEPEND="
 "
 DEPEND="${RDEPEND}
        ${PYTHON_DEPS}
+       dev-util/glib-utils
        nls? ( virtual/libintl )
 "
 
-src_prepare() {
-       epatch "${FILESDIR}"/${P}-no-fdgl.patch
-}
+PATCHES=(
+       "${FILESDIR}"/${P}-no-fdgl.patch
+)
 
 src_configure() {
        append-cxxflags -std=c++11