Relocate attributes from AbstractEbuildProcess to subclasses that use
authorZac Medico <zmedico@gentoo.org>
Tue, 10 Aug 2010 06:38:38 +0000 (23:38 -0700)
committerZac Medico <zmedico@gentoo.org>
Tue, 10 Aug 2010 06:38:38 +0000 (23:38 -0700)
them, since EbuildSpawnProcess doesn't use the attributes.

pym/_emerge/AbstractEbuildProcess.py
pym/_emerge/EbuildProcess.py
pym/_emerge/MiscFunctionsProcess.py

index 293251323a7bfd680982a22792e1b356692fc6e7..302d3440303d45d821f16a8c11ecd4f563a1251c 100644 (file)
@@ -8,7 +8,7 @@ from portage.util._pty import _create_pty_or_pipe
 
 class AbstractEbuildProcess(SpawnProcess):
 
-       __slots__ = ('phase', 'pkg', 'settings',)
+       __slots__ = ('settings',)
 
        def _pipe(self, fd_pipes):
                stdout_pipe = fd_pipes.get(1)
index bf7af4b9d31fad828a449e9edb7deea9fe231e04..a0ef2357a8c94e1329e3f6a7c695c5af810e9f55 100644 (file)
@@ -8,7 +8,7 @@ from portage.package.ebuild.doebuild import doebuild, \
 
 class EbuildProcess(AbstractEbuildProcess):
 
-       __slots__ = ('tree',)
+       __slots__ = ('phase', 'pkg', 'tree',)
 
        def _start(self):
                # Don't open the log file during the clean phase since the
index c0d40a197619fbab32258a44fa1d6e2d9d79251c..c66beb2c2ad6230d6f760bd9e35076b32427f878 100644 (file)
@@ -12,7 +12,7 @@ class MiscFunctionsProcess(AbstractEbuildProcess):
        Spawns misc-functions.sh with an existing ebuild environment.
        """
 
-       __slots__ = ('commands',)
+       __slots__ = ('commands', 'phase', 'pkg',)
 
        def _start(self):
                settings = self.settings