dev-lang/ghc: Prefixify STAGE0_AR.
authorBenda Xu <heroxbd@gentoo.org>
Tue, 26 Jul 2016 08:59:51 +0000 (17:59 +0900)
committerBenda Xu <heroxbd@gentoo.org>
Tue, 26 Jul 2016 09:05:45 +0000 (18:05 +0900)
Bug: 540168

Package-Manager: portage-2.3.0

dev-lang/ghc/ghc-7.10.3.ebuild

index 9721ed4fb10ffb44fb8ac11b0b54b65d89451ded..78ebfbf12d46725aedf24dc97ea61e06c063a31f 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -16,7 +16,7 @@ if [[ ${CTARGET} = ${CHOST} ]] ; then
 fi
 
 inherit autotools bash-completion-r1 eutils flag-o-matic ghc-package
-inherit multilib pax-utils toolchain-funcs versionator
+inherit multilib pax-utils toolchain-funcs versionator prefix
 
 DESCRIPTION="The Glasgow Haskell Compiler"
 HOMEPAGE="http://www.haskell.org/ghc/"
@@ -322,6 +322,7 @@ relocate_ghc() {
                        "${WORKDIR}/usr/bin/$(cross)runghc-${GHC_PV}" \
                        "$gp_back" \
                        || die "Adding LD_LIBRARY_PATH for wrappers failed"
+               hprefixify "${bin_libpath}"/${PN}*/settings
        fi
 
        # regenerate the binary package cache