app-misc/calendar: EAPI 6 bump.
authorPatrice Clement <monsieurp@gentoo.org>
Thu, 19 Jan 2017 21:38:08 +0000 (22:38 +0100)
committerPatrice Clement <monsieurp@gentoo.org>
Fri, 20 Jan 2017 21:19:11 +0000 (22:19 +0100)
Package-Manager: portage-2.3.0

app-misc/calendar/calendar-0.9.1-r1.ebuild [new file with mode: 0644]

diff --git a/app-misc/calendar/calendar-0.9.1-r1.ebuild b/app-misc/calendar/calendar-0.9.1-r1.ebuild
new file mode 100644 (file)
index 0000000..f320572
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Standard unix calendar program for Linux, ported from OpenBSD"
+HOMEPAGE="http://bsdcalendar.sourceforge.net/"
+SRC_URI="http://bsdcalendar.sourceforge.net/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DOCS=( README )
+
+src_compile() {
+       tc-export CC
+       emake
+}
+
+src_install() {
+       cp -R "${S}/calendars" "${D}/usr/share/calendar" || die "cp failed"
+       dobin "${PN}"
+       doman "${PN}.1"
+       einstalldocs
+}