sci-misc/cdfplayer: bump to 11.3.0
authorAndrey Grozin <grozin@gentoo.org>
Wed, 21 Mar 2018 12:22:41 +0000 (19:22 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Wed, 21 Mar 2018 12:22:41 +0000 (19:22 +0700)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

sci-misc/cdfplayer/Manifest
sci-misc/cdfplayer/cdfplayer-11.3.0.ebuild [new file with mode: 0644]

index f9700eccf686d02813d612acc05ae2aeb70afddc..2a68544f07c0118833c70c701aaed4a57ebda93e 100644 (file)
@@ -1 +1,2 @@
 DIST CDFPlayer_11.2.0_LINUX.sh 1821479711 BLAKE2B 7d12a94b43fdd60dc6af3d78fe45f85a2aa68752c690de023d4cd0cc5d24f8b091db7846d3732d7618d7df659b982fbcf19543d7d0c0116ddcae7f7b1aa11d88 SHA512 8a9a98ed5dceb18db41e52269dedf2a00ee89015a76eb650b852f8e1c19040918ecfa7594737f2982118c7358eab4d1e85694eecbe059edc963d4bdc8533b470
+DIST CDFPlayer_11.3.0_LINUX.sh 1556151072 BLAKE2B a5067933400ec20fdf9bc0fb17dc592745beac42cc2a0968dc633ff967f1566831dc7df02bd7f97ea4e46314fa00db5c7b041c266a245b61ac7d189b4ad7fa8d SHA512 62e648e36fd0debff13755671f95e9fae7c1c8ab684b5d0ff2ec53555afa48a4cee5414b3c047024b1354ccb86a843f0ebf4dccd4f390da7aba61d7d5fab56b0
diff --git a/sci-misc/cdfplayer/cdfplayer-11.3.0.ebuild b/sci-misc/cdfplayer/cdfplayer-11.3.0.ebuild
new file mode 100644 (file)
index 0000000..48a91cc
--- /dev/null
@@ -0,0 +1,94 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib versionator
+
+DESCRIPTION="Wolfram Player for the interactive Computable Document Format (CDF)"
+SRC_URI="CDFPlayer_11.3.0_LINUX.sh"
+HOMEPAGE="http://www.wolfram.com/cdf-player/"
+
+LICENSE="WolframCDFPlayer"
+KEYWORDS="-* ~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RESTRICT="strip mirror bindist fetch"
+
+DEPEND=""
+
+# this list comes from lsof output
+# probably there are still some libraries missing
+RDEPEND="
+       x11-libs/libICE
+       x11-libs/libSM
+       x11-libs/libX11
+       x11-libs/libXau
+       x11-libs/libXcursor
+       x11-libs/libXdmcp
+       x11-libs/libXext
+       x11-libs/libXfixes
+       x11-libs/libXi
+       x11-libs/libXmu
+       x11-libs/libXrandr
+       x11-libs/libXrender
+       x11-libs/libXt
+       media-libs/alsa-lib
+       dev-libs/expat
+       media-libs/fontconfig
+       dev-libs/icu
+       x11-libs/libxcb
+       dev-libs/libxml2
+       sys-libs/ncurses:5/5
+       media-libs/freetype
+"
+
+# we need this a few times
+MPN="CDFPlayer"
+MPV=$(get_version_component_range 1-2)
+
+# we might as well list all files in all QA variables...
+QA_PREBUILT="opt/*"
+
+S=${WORKDIR}
+
+src_unpack() {
+       /bin/sh "${DISTDIR}/${A}" --nox11 --confirm --keep -- -auto "-targetdir=${S}/opt/Wolfram/${MPN}/${MPV}" "-execdir=${S}/opt/bin" || die
+}
+
+src_install() {
+       local ARCH
+       if use amd64; then ARCH='-x86-64'; else ARCH=''; fi
+
+       # move all over
+       mv "${S}"/opt "${D}"/opt || die
+
+       # the autogenerated symlinks point into sandbox, redo
+       rm "${D}"/opt/bin/* || die
+       dosym ../Wolfram/${MPN}/${MPV}/Executables/wolframcdfplayer opt/bin/wolframcdfplayer
+       dosym ../Wolfram/${MPN}/${MPV}/Executables/WolframCDFPlayer opt/bin/WolframCDFPlayer
+       rm "${D}"/opt/Wolfram/${MPN}/${MPV}/Executables/wolframscript
+       dosym ../SystemFiles/Kernel/Binaries/Linux${ARCH}/wolframscript /opt/Wolfram/${MPN}/${MPV}/Executables/wolframscript
+
+       # fix some embedded paths and install desktop files
+       insinto /usr/share/applications
+       for filename in $(find "${D}" -name "wolfram-cdf11.desktop") ; do
+               echo Fixing "${filename}"
+               sed -e "s:${S}::g" -e 's:^\t\t::g' -i "${filename}"
+               echo "Categories=Physics;Science;Engineering;2DGraphics;Graphics;" >> "${filename}"
+               doins "${filename}"
+       done
+
+       # install a wrapper
+       echo '#!/bin/sh' >> ${PN}
+       echo "LD_PRELOAD=/usr/$(get_libdir)/libfreetype.so.6:/lib/libz.so.1 /opt/Wolfram/${MPN}/${MPV}/Executables/wolframcdfplayer \$*" \
+                >> ${PN}
+       dobin ${PN}
+}
+
+pkg_nofetch() {
+       einfo "Sadly Wolfram provides no permanent link to the player files."
+       einfo "Please download the Wolfram CFD Player installation file ${SRC_URI} from"
+       einfo "${HOMEPAGE} and place it in ${DISTDIR}"
+}