dev-python/expects: Drop old
authorPacho Ramos <pacho@gentoo.org>
Sat, 10 Mar 2018 14:31:27 +0000 (15:31 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sat, 10 Mar 2018 14:52:31 +0000 (15:52 +0100)
Package-Manager: Portage-2.3.24, Repoman-2.3.6

dev-python/expects/Manifest
dev-python/expects/expects-0.4.2.ebuild [deleted file]

index 5b4a21f3a7093cef85ca2ae524753e47fd4d5876..098f82f5481cd17ad32650e3cfa374146e21267f 100644 (file)
@@ -1,2 +1 @@
-DIST expects-0.4.2.tar.gz 23813 BLAKE2B ab24a5fc457dd9bc67246d7f41a0982a8acdac509b44f181254e4a5150c9de23f3c554bede58e3c6ab4eb889432a4cdb474767b56830a67b3a78373c74ea2fbc SHA512 6701a1a3099073c70d8f729b7ca72e4b9b3eb6d6f9e7d6d2d654a3b684c5ab101c343b4c3556f45d763ab1479dbc3eb3db209c4d9f5d2254cc4111e74a4a3c1a
 DIST expects-0.8.0.tar.gz 27801 BLAKE2B 3371ad3b494a6cfaf463660d013dbd5c26d88e0cd7816be11a39466a831d2a3c19e9459967947651e004dc1bbc6f6e9a61eb0b9f69685482440056061fb9bd95 SHA512 c2379bb6b3b6181a0365a84b0602f2552de40760b7cbadd775705bacfe113ffbe55bcde818c5766f7079867ae38c8c02e318f3c9ffdccdddb58e6cf0559f1e25
diff --git a/dev-python/expects/expects-0.4.2.ebuild b/dev-python/expects/expects-0.4.2.ebuild
deleted file mode 100644 (file)
index 684b630..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_4 )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="Expressive and extensible TDD/BDD assertion library for Python"
-HOMEPAGE="https://github.com/jaimegildesagredo/expects"
-SRC_URI="https://github.com/jaimegildesagredo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc test"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? (
-               >=dev-python/mamba-0.8.2[${PYTHON_USEDEP}]
-               <dev-python/mamba-0.9[${PYTHON_USEDEP}]
-       )
-"
-RDEPEND=""
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       mamba || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-
-       distutils-r1_python_install_all
-}