dev-libs/glib: Add ewarn telling users to restart their session
authorMatt Turner <mattst88@gentoo.org>
Sun, 29 Mar 2020 18:20:25 +0000 (11:20 -0700)
committerMatt Turner <mattst88@gentoo.org>
Sun, 29 Mar 2020 18:21:06 +0000 (11:21 -0700)
Closes: https://bugs.gentoo.org/715186
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-libs/glib/glib-2.64.1.ebuild

index 15d5ed1eac010194fafac8dbfb3bb1b1370521c8..f558eaa92f040c646efe8550c34c2e46b86b2ee7 100644 (file)
@@ -262,6 +262,13 @@ pkg_postinst() {
                ewarn "your final image for performance reasons and re-run it when packages"
                ewarn "installing GIO modules get upgraded or added to the image."
        fi
+
+       for v in ${REPLACING_VERSIONS}; do
+               if ver_test "$v" "-lt" "2.63.6"; then
+                       ewarn "glib no longer installs the gio-launch-desktop binary. You may need"
+                       ewarn "to restart your session for \"Open With\" dialogs to work."
+               fi
+       done
 }
 
 pkg_postrm() {