dev-python/vdf: support pypy3, simplify test dependencies
authorMarek Szuba <marecki@gentoo.org>
Tue, 21 Apr 2020 22:52:31 +0000 (23:52 +0100)
committerMarek Szuba <marecki@gentoo.org>
Tue, 21 Apr 2020 22:57:58 +0000 (23:57 +0100)
pypy3 - builds and tests fine, as claimed by upstream

Test dependencies - Python-3.3 and newer have unittest.mock in the
standard library and this package does not support any versions older
than that, patch the relevant test file to use unittest.mock and stop
pulling in dev-python/mock (which was pulled in incorrectly anyway).

Signed-off-by: Marek Szuba <marecki@gentoo.org>
dev-python/vdf/files/vdf-3.2-mock_from_stdlib.patch [new file with mode: 0644]
dev-python/vdf/vdf-3.2-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/vdf/files/vdf-3.2-mock_from_stdlib.patch b/dev-python/vdf/files/vdf-3.2-mock_from_stdlib.patch
new file mode 100644 (file)
index 0000000..511e5dd
--- /dev/null
@@ -0,0 +1,9 @@
+--- a/tests/test_vdf.py
++++ b/tests/test_vdf.py
+@@ -1,5 +1,5 @@
+ import unittest
+-import mock
++import unittest.mock as mock
+ import sys
+ try:
diff --git a/dev-python/vdf/vdf-3.2-r1.ebuild b/dev-python/vdf/vdf-3.2-r1.ebuild
new file mode 100644 (file)
index 0000000..2c3eaf3
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A module for (de)serialization to and from VDF, Valve's key-value text format"
+HOMEPAGE="https://github.com/ValvePython/vdf"
+SRC_URI="https://codeload.github.com/ValvePython/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-3.2-mock_from_stdlib.patch
+)
+
+distutils_enable_tests pytest