dev-db/redis: bump to 5.0-rc4
authorTomas Mozes <hydrapolic@gmail.com>
Thu, 23 Aug 2018 00:09:41 +0000 (02:09 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Thu, 23 Aug 2018 00:22:22 +0000 (02:22 +0200)
Closes: https://github.com/gentoo/gentoo/pull/9472
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-db/redis/Manifest
dev-db/redis/files/redis-5.0-shared.patch [new file with mode: 0644]
dev-db/redis/files/redis-5.0-sharedlua.patch [new file with mode: 0644]
dev-db/redis/files/redis-sentinel-5.0-config.patch [new file with mode: 0644]
dev-db/redis/redis-5.0_rc4.ebuild [new file with mode: 0644]

index eae411b86c7550c0d404be890adb6b5f7b2fc565..15ebee3a76ea8de835c32bbea0c50ca7882ba58f 100644 (file)
@@ -7,3 +7,4 @@ DIST redis-4.0.6.tar.gz 1723533 BLAKE2B 94c2a9b7eeaa676efaac75cd5c143b0f4b02440b
 DIST redis-4.0.7.tar.gz 1729488 BLAKE2B 7a5337b868e4da4a7387b31bc9d6bd4c86abd701b9ba999f64296ed5188cbba7208ced466973a500730ca03e70a9a85fbab2fb4700fdc977e58defc0126487d1 SHA512 6f317d9e76224b2a2b047dc8f56b126ea85ee5c6112c4c6238cb5cdfa3a83756bff3a82b106b00d1124a93d210a900d836587b8d9563916f19274de0e84c4c6b
 DIST redis-4.0.8.tar.gz 1729973 BLAKE2B 32d82a07beba9ea8f0b08a8fc69da548a1974e5839f052a9803ffb0f52ef920df9b128092e061b5e693581a50efef4a1212c1f6310dc8492eff5ca841ff3b03a SHA512 11c126ddef3bedbceb02ee7a80a61374e081da8087055d77970b0097066a6f1c5e0c4f0d246c9851f8c3beca22f185c184669a9dc4f1c7c229f8cd2c34196ab6
 DIST redis-4.0.9.tar.gz 1737022 BLAKE2B 35a83d146062f5b14c023d7fd9f28d743ba6bec3e0e4bf9ce8e065a706bbd7508ffbcb8b1b4d18f6b6774589b5456540ba8717b9f449fcbd758c0f57dbd505a3 SHA512 a6cf63cb361f0a87da3955ba628190dc04cad342f7a664d18e44416ee67dd86ed6e3a46b9701e994f1417e56b819b3c6fc595f363c10bb4b83d5033919d29598
+DIST redis-5.0_rc4.tar.gz 1937238 BLAKE2B b8f768b83e27476bc038fc554193680f4873eb2405f238e0a6f2053cf68c4a9e6c45546730a263463b805d6811334c1ba056be0230676f19d0562d488a3d4c97 SHA512 75b308bca026fe3b7cff1a92df3990bab5bb7ffe24cdfbc263f4d522ebe7ec8d86a9ed66da1778fe67c08a39b6f0c83cb10c5a332818c6ad04621d01c4aa6add
diff --git a/dev-db/redis/files/redis-5.0-shared.patch b/dev-db/redis/files/redis-5.0-shared.patch
new file mode 100644 (file)
index 0000000..3224507
--- /dev/null
@@ -0,0 +1,32 @@
+diff --git a/src/Makefile b/src/Makefile
+index f5525bd..6f12a20 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -29,14 +29,7 @@ INSTALL_BIN=$(PREFIX)/bin
+ INSTALL=install
+ # Default allocator defaults to Jemalloc if it's not an ARM
+-MALLOC=libc
+-ifneq ($(uname_M),armv6l)
+-ifneq ($(uname_M),armv7l)
+-ifeq ($(uname_S),Linux)
+-      MALLOC=jemalloc
+-endif
+-endif
+-endif
++MALLOC?=jemalloc
+ # To get ARM stack traces if Redis crashes we need a special C flag.
+ ifneq (,$(filter aarch64 armv,$(uname_M)))
+@@ -120,9 +113,8 @@ ifeq ($(MALLOC),tcmalloc_minimal)
+ endif
+ ifeq ($(MALLOC),jemalloc)
+-      DEPENDENCY_TARGETS+= jemalloc
+-      FINAL_CFLAGS+= -DUSE_JEMALLOC -I../deps/jemalloc/include
+-      FINAL_LIBS := ../deps/jemalloc/lib/libjemalloc.a $(FINAL_LIBS)
++      FINAL_CFLAGS+= -DUSE_JEMALLOC -DJEMALLOC_NO_DEMANGLE
++      FINAL_LIBS+= -ljemalloc -ldl
+ endif
+ REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)
diff --git a/dev-db/redis/files/redis-5.0-sharedlua.patch b/dev-db/redis/files/redis-5.0-sharedlua.patch
new file mode 100644 (file)
index 0000000..3b97f91
--- /dev/null
@@ -0,0 +1,61 @@
+diff --git a/deps/lua/src/lua_cjson.c b/deps/lua/src/lua_cjson.c
+index c26c0d7..fa50c41 100644
+--- a/deps/lua/src/lua_cjson.c
++++ b/deps/lua/src/lua_cjson.c
+@@ -46,7 +46,7 @@
+ #include "strbuf.h"
+ #include "fpconv.h"
+-#include "../../../src/solarisfixes.h"
++#include "solarisfixes.h"
+ #ifndef CJSON_MODNAME
+ #define CJSON_MODNAME   "cjson"
+diff --git a/src/Makefile b/src/Makefile
+index 6f12a20..205cd59 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -16,7 +16,7 @@ release_hdr := $(shell sh -c './mkreleasehdr.sh')
+ uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
+ uname_M := $(shell sh -c 'uname -m 2>/dev/null || echo not')
+ OPTIMIZATION?=-O2
+-DEPENDENCY_TARGETS=hiredis linenoise lua
++DEPENDENCY_TARGETS=hiredis linenoise
+ NODEPS:=clean distclean
+ # Default settings
+@@ -58,7 +58,7 @@ endif
+ FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) $(REDIS_CFLAGS)
+ FINAL_LDFLAGS=$(LDFLAGS) $(REDIS_LDFLAGS) $(DEBUG)
+-FINAL_LIBS=-lm
++FINAL_LIBS=@LUA_LIBS@
+ DEBUG=-g -ggdb
+ ifeq ($(uname_S),SunOS)
+@@ -100,7 +100,7 @@ endif
+ endif
+ endif
+ # Include paths to dependencies
+-FINAL_CFLAGS+= -I../deps/hiredis -I../deps/linenoise -I../deps/lua/src
++FINAL_CFLAGS+= -I../deps/hiredis -I../deps/linenoise @LUA_CFLAGS@
+ ifeq ($(MALLOC),tcmalloc)
+       FINAL_CFLAGS+= -DUSE_TCMALLOC
+@@ -137,6 +137,7 @@ endif
+ REDIS_SERVER_NAME=redis-server
+ REDIS_SENTINEL_NAME=redis-sentinel
+ REDIS_SERVER_OBJ=adlist.o quicklist.o ae.o anet.o dict.o server.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o ziplist.o release.o networking.o util.o object.o db.o replication.o rdb.o t_string.o t_list.o t_set.o t_zset.o t_hash.o config.o aof.o pubsub.o multi.o debug.o sort.o intset.o syncio.o cluster.o crc16.o endianconv.o slowlog.o scripting.o bio.o rio.o rand.o memtest.o crc64.o bitops.o sentinel.o notify.o setproctitle.o blocked.o hyperloglog.o latency.o sparkline.o redis-check-rdb.o redis-check-aof.o geo.o lazyfree.o module.o evict.o expire.o geohash.o geohash_helper.o childinfo.o defrag.o siphash.o rax.o t_stream.o listpack.o localtime.o
++REDIS_SERVER_OBJ+=fpconv.o strbuf.o lua_bit.o lua_cjson.o lua_cmsgpack.o lua_struct.o
+ REDIS_CLI_NAME=redis-cli
+ REDIS_CLI_OBJ=anet.o adlist.o dict.o redis-cli.o zmalloc.o release.o anet.o ae.o crc64.o siphash.o crc16.o
+ REDIS_BENCHMARK_NAME=redis-benchmark
+@@ -188,7 +189,7 @@ endif
+ # redis-server
+ $(REDIS_SERVER_NAME): $(REDIS_SERVER_OBJ)
+-      $(REDIS_LD) -o $@ $^ ../deps/hiredis/libhiredis.a ../deps/lua/src/liblua.a $(FINAL_LIBS)
++      $(REDIS_LD) -o $@ $^ ../deps/hiredis/libhiredis.a $(FINAL_LIBS)
+ # redis-sentinel
+ $(REDIS_SENTINEL_NAME): $(REDIS_SERVER_NAME)
diff --git a/dev-db/redis/files/redis-sentinel-5.0-config.patch b/dev-db/redis/files/redis-sentinel-5.0-config.patch
new file mode 100644 (file)
index 0000000..53299f1
--- /dev/null
@@ -0,0 +1,10 @@
+diff --git a/sentinel.conf b/sentinel.conf
+index 3703c73..964ffa3 100644
+--- a/sentinel.conf
++++ b/sentinel.conf
+@@ -222,3 +222,5 @@ sentinel deny-scripts-reconfig yes
+ # case, so writing "config guessme" is the same in the example above.
+ #
+ # SENTINEL SET can also be used in order to perform this configuration at runtime.
++
++logfile "/var/log/redis/sentinel.log"
diff --git a/dev-db/redis/redis-5.0_rc4.ebuild b/dev-db/redis/redis-5.0_rc4.ebuild
new file mode 100644 (file)
index 0000000..1b2b1a5
--- /dev/null
@@ -0,0 +1,144 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils flag-o-matic systemd toolchain-funcs user
+
+MY_PV="${PV/_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="A persistent caching system, key-value and data structures database"
+HOMEPAGE="https://redis.io"
+SRC_URI="https://github.com/antirez/redis/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="+jemalloc tcmalloc luajit test"
+SLOT="0"
+
+# Redis does NOT build with Lua 5.2 or newer at this time.
+# This should link correctly with both unslotted & slotted Lua, without
+# changes.
+RDEPEND="
+       luajit? ( dev-lang/luajit:2 )
+       !luajit? ( || ( dev-lang/lua:5.1 =dev-lang/lua-5.1*:0 ) )
+       tcmalloc? ( dev-util/google-perftools )
+       jemalloc? ( >=dev-libs/jemalloc-3.2 )"
+
+DEPEND="
+       ${RDEPEND}
+       virtual/pkgconfig
+       >=sys-devel/autoconf-2.63
+       test? ( dev-lang/tcl:0= )"
+
+REQUIRED_USE="?? ( tcmalloc jemalloc )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+       enewgroup redis 75
+       enewuser redis 75 -1 /var/lib/redis redis
+}
+
+src_prepare() {
+       eapply \
+               "${FILESDIR}"/${PN}-3.2.3-config.patch \
+               "${FILESDIR}"/${PN}-5.0-shared.patch \
+               "${FILESDIR}"/${PN}-5.0-sharedlua.patch \
+               "${FILESDIR}"/${PN}-sentinel-5.0-config.patch
+       eapply_user
+
+       # Copy lua modules into build dir
+       cp "${S}"/deps/lua/src/{fpconv,lua_bit,lua_cjson,lua_cmsgpack,lua_struct,strbuf}.c "${S}"/src || die
+       cp "${S}"/deps/lua/src/{fpconv,strbuf}.h "${S}"/src || die
+       # Append cflag for lua_cjson
+       # https://github.com/antirez/redis/commit/4fdcd213#diff-3ba529ae517f6b57803af0502f52a40bL61
+       append-cflags "-DENABLE_CJSON_GLOBAL"
+
+       # now we will rewrite present Makefiles
+       local makefiles="" MKF
+       for MKF in $(find -name 'Makefile' | cut -b 3-); do
+               mv "${MKF}" "${MKF}.in"
+               sed -i  -e 's:$(CC):@CC@:g' \
+                       -e 's:$(CFLAGS):@AM_CFLAGS@:g' \
+                       -e 's: $(DEBUG)::g' \
+                       -e 's:$(OBJARCH)::g' \
+                       -e 's:ARCH:TARCH:g' \
+                       -e '/^CCOPT=/s:$: $(LDFLAGS):g' \
+                       "${MKF}.in" \
+               || die "Sed failed for ${MKF}"
+               makefiles+=" ${MKF}"
+       done
+       # autodetection of compiler and settings; generates the modified Makefiles
+       cp "${FILESDIR}"/configure.ac-3.2 configure.ac || die
+
+       # Use the correct pkgconfig name for Lua
+       has_version 'dev-lang/lua:5.1' \
+               && LUAPKGCONFIG=lua5.1 \
+               || LUAPKGCONFIG=lua
+       sed -i  \
+               -e "/^AC_INIT/s|, [0-9].+, |, $PV, |" \
+               -e "s:AC_CONFIG_FILES(\[Makefile\]):AC_CONFIG_FILES([${makefiles}]):g" \
+               -e "/PKG_CHECK_MODULES.*\<LUA\>/s,lua5.1,${LUAPKGCONFIG},g" \
+               configure.ac || die "Sed failed for configure.ac"
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               $(use_with luajit)
+
+       # Linenoise can't be built with -std=c99, see https://bugs.gentoo.org/451164
+       # also, don't define ANSI/c99 for lua twice
+       sed -i -e "s:-std=c99::g" deps/linenoise/Makefile deps/Makefile || die
+}
+
+src_compile() {
+       tc-export CC AR RANLIB
+
+       local myconf=""
+
+       if use tcmalloc; then
+               myconf="${myconf} USE_TCMALLOC=yes"
+       elif use jemalloc; then
+               myconf="${myconf} JEMALLOC_SHARED=yes"
+       else
+               myconf="${myconf} MALLOC=yes"
+       fi
+
+       emake ${myconf} V=1 CC="${CC}" AR="${AR} rcu" RANLIB="${RANLIB}"
+}
+
+src_install() {
+       insinto /etc/
+       doins redis.conf sentinel.conf
+       use prefix || fowners redis:redis /etc/{redis,sentinel}.conf
+       fperms 0644 /etc/{redis,sentinel}.conf
+
+       newconfd "${FILESDIR}/redis.confd-r1" redis
+       newinitd "${FILESDIR}/redis.initd-5" redis
+
+       systemd_newunit "${FILESDIR}/redis.service-2" redis.service
+       systemd_newtmpfilesd "${FILESDIR}/redis.tmpfiles" redis.conf
+
+       newconfd "${FILESDIR}/redis-sentinel.confd" redis-sentinel
+       newinitd "${FILESDIR}/redis-sentinel.initd" redis-sentinel
+
+       insinto /etc/logrotate.d/
+       newins "${FILESDIR}/${PN}.logrotate" ${PN}
+
+       dodoc 00-RELEASENOTES BUGS CONTRIBUTING MANIFESTO README.md
+
+       dobin src/redis-cli
+       dosbin src/redis-benchmark src/redis-server src/redis-check-aof src/redis-check-rdb
+       fperms 0750 /usr/sbin/redis-benchmark
+       dosym redis-server /usr/sbin/redis-sentinel
+
+       if use prefix; then
+               diropts -m0750
+       else
+               diropts -m0750 -o redis -g redis
+       fi
+       keepdir /var/{log,lib}/redis
+}