app-admin/salt: remove old
authorPatrick McLean <patrick.mclean@sony.com>
Wed, 29 Apr 2020 04:21:05 +0000 (21:21 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 29 Apr 2020 04:21:15 +0000 (21:21 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
app-admin/salt/Manifest
app-admin/salt/salt-2019.2.0-r1.ebuild [deleted file]
app-admin/salt/salt-2019.2.2.ebuild [deleted file]

index ce151f7de7f5df0e6457267f71ea6131e97bff8b..bf06df6f8c2bb996c5c49e96c802b3d2666cd682 100644 (file)
@@ -1,4 +1,2 @@
 DIST salt-2018.3.4.tar.gz 14404085 BLAKE2B 932b30b1ba60aefd3a6874a8ebe4cb6c469d82e31f6acdbe8a5641d09e3316796b5403ef803a355cec6255c1aede8bac3b66af179bd1bbaa5418c7076229cef9 SHA512 f17e06fdbf4741f231d9e769be57de4f6079e9283881b4bafa0d23928d7626a1f9c02b9f49c654b29c3e6ee8ed3d3ddf42c21baecef158ad63a97dc87895b21b
-DIST salt-2019.2.0.tar.gz 14952746 BLAKE2B aa3bba4b7d9548a8d333c242fc0265a743f56ff1a259da7c8618d37b3b022e12f09ac594a09f0ceec80fd9d3a6b6b9ec35b33e879b7a124e6612f2ec2a63a01c SHA512 de5a976213d011c230e423a172952effddb87168367958b8657eaaaf8fd2a8bec8471f547b6ff9e896a17064a13d387dbc12e12c605c8a241062e3238bd19eca
-DIST salt-2019.2.2.tar.gz 14420887 BLAKE2B 84e8a0aa72b88a66a1020b695849926669728ee02f8cb51a14853b5e9c2ab692fe65810367e5d53268f7b234c10911f16d063ce665b3761432ab1d9c0aa52d16 SHA512 2bbf9765384f1f6c2336a3f421298c8900cf459e6d1ebc7fb89284014ef8db9f5215a68de2bb06dfa3404983160a0c4c589ffa3dc046611dd5409bd502938677
 DIST salt-2019.2.3.tar.gz 14572686 BLAKE2B 770b815f43ca8651408c1c057377b02c8037e673584c719e0a9b5c56c13c8db2db0e2c8641a17323f2b890d4a69d1508b0090624c7067869d9fa84303c2f8585 SHA512 cd694ca19696a84e3370e39c61da180e508592253713d99dd6dd5342b57c2814fee22e46bade30d7604f5730d9e1a736e59c3a512161f744d3f097f74a2836c5
diff --git a/app-admin/salt/salt-2019.2.0-r1.ebuild b/app-admin/salt/salt-2019.2.0-r1.ebuild
deleted file mode 100644 (file)
index dc4a1c9..0000000
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_6 )
-
-inherit eutils systemd distutils-r1
-
-DESCRIPTION="Salt is a remote execution and configuration manager"
-HOMEPAGE="https://www.saltstack.com/resources/community/
-       https://github.com/saltstack"
-
-if [[ ${PV} == 9999* ]]; then
-       inherit git-r3
-       EGIT_REPO_URI="git://github.com/${PN}stack/${PN}.git"
-       EGIT_BRANCH="develop"
-       SRC_URI=""
-       KEYWORDS=""
-else
-       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-       KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="cherrypy ldap libcloud libvirt gnupg keyring mako mongodb neutron nova"
-IUSE+=" openssl portage profile redis selinux test raet +zeromq vim-syntax"
-
-RDEPEND="sys-apps/pciutils
-       dev-python/jinja[${PYTHON_USEDEP}]
-       dev-python/libnacl[${PYTHON_USEDEP}]
-       >=dev-python/msgpack-0.3[${PYTHON_USEDEP}]
-       dev-python/pyyaml[${PYTHON_USEDEP}]
-       dev-python/markupsafe[${PYTHON_USEDEP}]
-       >=dev-python/requests-1.0.0[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       >=www-servers/tornado-4.2.1[${PYTHON_USEDEP}]
-       <www-servers/tornado-5.0[${PYTHON_USEDEP}]
-       libcloud? ( >=dev-python/libcloud-0.14.0[${PYTHON_USEDEP}] )
-       mako? ( dev-python/mako[${PYTHON_USEDEP}] )
-       ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )
-       libvirt? ( dev-python/libvirt-python[${PYTHON_USEDEP}] )
-       openssl? (
-               dev-libs/openssl:0=[-bindist]
-               dev-python/pyopenssl[${PYTHON_USEDEP}]
-       )
-       raet? (
-               >=dev-python/libnacl-1.0.0[${PYTHON_USEDEP}]
-               >=dev-python/ioflo-1.1.7[${PYTHON_USEDEP}]
-               >=dev-python/raet-0.6.0[${PYTHON_USEDEP}]
-       )
-       zeromq? (
-               >=dev-python/pyzmq-2.2.0[${PYTHON_USEDEP}]
-               dev-python/pycryptodome[${PYTHON_USEDEP}]
-       )
-       cherrypy? ( >=dev-python/cherrypy-3.2.2[${PYTHON_USEDEP}] )
-       mongodb? ( dev-python/pymongo[${PYTHON_USEDEP}] )
-       portage? ( sys-apps/portage[${PYTHON_USEDEP}] )
-       keyring? ( dev-python/keyring[${PYTHON_USEDEP}] )
-       redis? ( dev-python/redis-py[${PYTHON_USEDEP}] )
-       selinux? ( sec-policy/selinux-salt )
-       nova? ( >=dev-python/python-novaclient-2.17.0[${PYTHON_USEDEP}] )
-       neutron? ( >=dev-python/python-neutronclient-2.3.6[${PYTHON_USEDEP}] )
-       gnupg? ( dev-python/python-gnupg[${PYTHON_USEDEP}] )
-       profile? ( dev-python/yappi[${PYTHON_USEDEP}] )
-       vim-syntax? ( app-vim/salt-vim )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               >=dev-python/pytest-salt-2018.12.8[${PYTHON_USEDEP}]
-               dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
-               dev-python/psutil[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-catchlog[${PYTHON_USEDEP}]
-               dev-python/pip[${PYTHON_USEDEP}]
-               dev-python/virtualenv[${PYTHON_USEDEP}]
-               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
-               >=dev-python/boto-2.32.1[${PYTHON_USEDEP}]
-               !x86? ( >=dev-python/boto3-1.2.1[${PYTHON_USEDEP}] )
-               >=dev-python/moto-0.3.6[${PYTHON_USEDEP}]
-               >=dev-python/SaltTesting-2016.5.11[${PYTHON_USEDEP}]
-               >=dev-python/libcloud-0.14.0[${PYTHON_USEDEP}]
-               ${RDEPEND}
-       )"
-
-DOCS=( README.rst AUTHORS )
-
-REQUIRED_USE="|| ( raet zeromq )"
-RESTRICT="!test? ( test ) x86? ( test )"
-
-PATCHES=(
-       "${FILESDIR}/salt-2017.7.0-dont-realpath-tmpdir.patch"
-       "${FILESDIR}/salt-2019.2.0-tests.patch"
-       "${FILESDIR}/salt-2018.3.2-skip-zeromq-test-that-hangs.patch"
-       "${FILESDIR}/salt-2019.2.0-skip-tests-that-oom-machine.patch"
-       "${FILESDIR}/salt-2019.2.0-newer-deps.patch"
-)
-
-python_prepare() {
-       # remove tests with external dependencies that may not be available
-       rm tests/unit/{test_zypp_plugins.py,utils/test_extend.py} || die
-       rm tests/unit/modules/test_{file,boto_{vpc,secgroup,elb}}.py || die
-       rm tests/unit/states/test_boto_vpc.py || die
-       rm tests/unit/modules/test_{kubernetes,vsphere}.py || die
-
-       # allow the use of the renamed msgpack
-       sed -i '/^msgpack/d' requirements/base.txt || die
-}
-
-python_install_all() {
-       local svc
-       USE_SETUPTOOLS=1 distutils-r1_python_install_all
-
-       for svc in minion master syndic api; do
-               newinitd "${FILESDIR}"/${svc}-initd-4 salt-${svc}
-               newconfd "${FILESDIR}"/${svc}-confd-1 salt-${svc}
-               systemd_dounit "${FILESDIR}"/salt-${svc}.service
-       done
-
-       insinto /etc/${PN}
-       doins -r conf/*
-}
-
-python_test() {
-       local tempdir
-       # testsuite likes lots of files
-       ulimit -n 3072 || die
-
-       # ${T} is too long a path for the tests to work
-       tempdir="$(mktemp -du --tmpdir=/tmp salt-XXX)"
-       mkdir "${T}/$(basename "${tempdir}")"
-       mkdir "${BUILD_DIR}"/../{templates,conf/cloud.{providers,profiles,maps}.d} || die
-
-       (
-               cleanup() {
-                       rm -f "${tempdir}"
-                       rmdir "${BUILD_DIR}"/../{templates,conf/cloud.{providers,profiles,maps}.d} || die
-               }
-
-               trap cleanup EXIT
-
-               addwrite "${tempdir}"
-               ln -s "$(realpath --relative-to=/tmp "${T}/$(basename "${tempdir}")")" "${tempdir}"
-
-               USE_SETUPTOOLS=1 SHELL="/bin/bash" \
-                       TMPDIR="${tempdir}" \
-                       ${EPYTHON} tests/runtests.py \
-                       --unit-tests --no-report --verbose
-
-       ) || die "testing failed"
-}
diff --git a/app-admin/salt/salt-2019.2.2.ebuild b/app-admin/salt/salt-2019.2.2.ebuild
deleted file mode 100644 (file)
index c6961f4..0000000
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_6 )
-
-inherit eutils systemd distutils-r1
-
-DESCRIPTION="Salt is a remote execution and configuration manager"
-HOMEPAGE="https://www.saltstack.com/resources/community/
-       https://github.com/saltstack"
-
-if [[ ${PV} == 9999* ]]; then
-       inherit git-r3
-       EGIT_REPO_URI="git://github.com/${PN}stack/${PN}.git"
-       EGIT_BRANCH="develop"
-       SRC_URI=""
-       KEYWORDS=""
-else
-       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-       KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="cherrypy ldap libcloud libvirt gnupg keyring mako mongodb neutron nova"
-IUSE+=" openssl portage profile redis selinux test raet +zeromq vim-syntax"
-
-RDEPEND="sys-apps/pciutils
-       dev-python/jinja[${PYTHON_USEDEP}]
-       dev-python/libnacl[${PYTHON_USEDEP}]
-       >=dev-python/msgpack-0.3[${PYTHON_USEDEP}]
-       dev-python/pyyaml[${PYTHON_USEDEP}]
-       dev-python/markupsafe[${PYTHON_USEDEP}]
-       >=dev-python/requests-1.0.0[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       >=www-servers/tornado-4.2.1[${PYTHON_USEDEP}]
-       <www-servers/tornado-5.0[${PYTHON_USEDEP}]
-       libcloud? ( >=dev-python/libcloud-0.14.0[${PYTHON_USEDEP}] )
-       mako? ( dev-python/mako[${PYTHON_USEDEP}] )
-       ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )
-       libvirt? ( dev-python/libvirt-python[${PYTHON_USEDEP}] )
-       openssl? (
-               dev-libs/openssl:0=[-bindist]
-               dev-python/pyopenssl[${PYTHON_USEDEP}]
-       )
-       raet? (
-               >=dev-python/libnacl-1.0.0[${PYTHON_USEDEP}]
-               >=dev-python/ioflo-1.1.7[${PYTHON_USEDEP}]
-               >=dev-python/raet-0.6.0[${PYTHON_USEDEP}]
-       )
-       zeromq? (
-               >=dev-python/pyzmq-2.2.0[${PYTHON_USEDEP}]
-               dev-python/pycryptodome[${PYTHON_USEDEP}]
-       )
-       cherrypy? ( >=dev-python/cherrypy-3.2.2[${PYTHON_USEDEP}] )
-       mongodb? ( dev-python/pymongo[${PYTHON_USEDEP}] )
-       portage? ( sys-apps/portage[${PYTHON_USEDEP}] )
-       keyring? ( dev-python/keyring[${PYTHON_USEDEP}] )
-       redis? ( dev-python/redis-py[${PYTHON_USEDEP}] )
-       selinux? ( sec-policy/selinux-salt )
-       nova? ( >=dev-python/python-novaclient-2.17.0[${PYTHON_USEDEP}] )
-       neutron? ( >=dev-python/python-neutronclient-2.3.6[${PYTHON_USEDEP}] )
-       gnupg? ( dev-python/python-gnupg[${PYTHON_USEDEP}] )
-       profile? ( dev-python/yappi[${PYTHON_USEDEP}] )
-       vim-syntax? ( app-vim/salt-vim )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               >=dev-python/pytest-salt-2018.12.8[${PYTHON_USEDEP}]
-               >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
-               dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
-               dev-python/psutil[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-catchlog[${PYTHON_USEDEP}]
-               dev-python/pip[${PYTHON_USEDEP}]
-               dev-python/virtualenv[${PYTHON_USEDEP}]
-               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
-               >=dev-python/boto-2.32.1[${PYTHON_USEDEP}]
-               !x86? ( >=dev-python/boto3-1.2.1[${PYTHON_USEDEP}] )
-               >=dev-python/moto-0.3.6[${PYTHON_USEDEP}]
-               >=dev-python/SaltTesting-2016.5.11[${PYTHON_USEDEP}]
-               >=dev-python/libcloud-0.14.0[${PYTHON_USEDEP}]
-               ${RDEPEND}
-       )"
-
-DOCS=( README.rst AUTHORS )
-
-REQUIRED_USE="|| ( raet zeromq )"
-RESTRICT="!test? ( test ) x86? ( test )"
-
-PATCHES=(
-       "${FILESDIR}/salt-2017.7.0-dont-realpath-tmpdir.patch"
-       "${FILESDIR}/salt-2019.2.0-tests.patch"
-       "${FILESDIR}/salt-2019.2.0-skip-tests-that-oom-machine.patch"
-       "${FILESDIR}/salt-2019.2.2-newer-deps.patch"
-       "${FILESDIR}/salt-2019.2.2-workaround-broken-mock-on-py2.patch"
-)
-
-python_prepare() {
-       # remove tests with external dependencies that may not be available
-       rm tests/unit/{test_zypp_plugins.py,utils/test_extend.py} || die
-       rm tests/unit/modules/test_{file,boto_{vpc,secgroup,elb}}.py || die
-       rm tests/unit/states/test_boto_vpc.py || die
-
-       # allow the use of the renamed msgpack
-       sed -i '/^msgpack/d' requirements/base.txt || die
-}
-
-python_install_all() {
-       local svc
-       USE_SETUPTOOLS=1 distutils-r1_python_install_all
-
-       for svc in minion master syndic api; do
-               newinitd "${FILESDIR}"/${svc}-initd-4 salt-${svc}
-               newconfd "${FILESDIR}"/${svc}-confd-1 salt-${svc}
-               systemd_dounit "${FILESDIR}"/salt-${svc}.service
-       done
-
-       insinto /etc/${PN}
-       doins -r conf/*
-}
-
-python_test() {
-       local tempdir
-       # testsuite likes lots of files
-       ulimit -n 3072 || die
-
-       # ${T} is too long a path for the tests to work
-       tempdir="$(mktemp -du --tmpdir=/tmp salt-XXX)"
-       mkdir "${T}/$(basename "${tempdir}")"
-       mkdir "${BUILD_DIR}"/../{templates,conf/cloud.{providers,profiles,maps}.d} || die
-
-       (
-               cleanup() {
-                       rm -f "${tempdir}"
-                       rmdir "${BUILD_DIR}"/../{templates,conf/cloud.{providers,profiles,maps}.d} || die
-               }
-
-               trap cleanup EXIT
-
-               addwrite "${tempdir}"
-               ln -s "$(realpath --relative-to=/tmp "${T}/$(basename "${tempdir}")")" "${tempdir}"
-
-               USE_SETUPTOOLS=1 SHELL="/bin/bash" \
-                       TMPDIR="${tempdir}" \
-                       ${EPYTHON} tests/runtests.py \
-                       --unit-tests --no-report --verbose
-
-       ) || die "testing failed"
-}