dev-python/cryptography: add missing pycparser dep
authorMatthew Thode <prometheanfire@gentoo.org>
Mon, 26 Nov 2018 15:10:44 +0000 (09:10 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Mon, 26 Nov 2018 15:11:01 +0000 (09:11 -0600)
Fixes: https://bugs.gentoo.org/671948
Package-Manager: Portage-2.3.51, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/cryptography/cryptography-2.2.2-r1.ebuild
dev-python/cryptography/cryptography-2.3.1.ebuild
dev-python/cryptography/cryptography-2.3.ebuild

index 449719f769ca764a4c47c71859b6761416152ce7..e4d73ba997e17ef9a471e5556be3ee1dde416010 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -42,6 +42,7 @@ RDEPEND="
        "
 DEPEND="${RDEPEND}
        >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
+       dev-python/pycparser[${PYTHON_USEDEP}]
        test? (
                ~dev-python/cryptography-vectors-${PV}[${PYTHON_USEDEP}]
                dev-python/hypothesis[${PYTHON_USEDEP}]
index 1a58e5692ef8e51ccda14a3a1fa9f88bd3deaed3..9c239e0ef8801dde78bdac433ef1bf40724d16d0 100644 (file)
@@ -41,6 +41,7 @@ RDEPEND="
        "
 DEPEND="${RDEPEND}
        >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
+       dev-python/pycparser[${PYTHON_USEDEP}]
        $(python_gen_cond_dep '>=dev-python/cffi-1.7:=[${PYTHON_USEDEP}]' 'python*')
        $(python_gen_cond_dep '!~dev-python/cffi-1.11.3[${PYTHON_USEDEP}]' 'python*')
        test? (
index ec123a175ee9bd5fc58a55a6f4dc52cf4dcea0bc..f858938c524b60c056b5c536c5175c10b6a7b7eb 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -41,6 +41,7 @@ RDEPEND="
        "
 DEPEND="${RDEPEND}
        >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
+       dev-python/pycparser[${PYTHON_USEDEP}]
        $(python_gen_cond_dep '>=dev-python/cffi-1.7:=[${PYTHON_USEDEP}]' 'python*')
        $(python_gen_cond_dep '!~dev-python/cffi-1.11.3[${PYTHON_USEDEP}]' 'python*')
        test? (