media-sound/lollypop: Version bump 1.2.34
authorJohannes Huber <johu@gentoo.org>
Mon, 13 Apr 2020 11:21:09 +0000 (13:21 +0200)
committerJohannes Huber <johu@gentoo.org>
Mon, 13 Apr 2020 11:21:56 +0000 (13:21 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Johannes Huber <johu@gentoo.org>
media-sound/lollypop/Manifest
media-sound/lollypop/lollypop-1.2.34.ebuild [new file with mode: 0644]

index f5ee4bcc6bcf0c02a8ccc28af2f0fb688a3c8767..60a1c197b2974125d630a4585363f887b8100896 100644 (file)
@@ -1,2 +1,3 @@
 DIST lollypop-1.1.4.16.tar.xz 455312 BLAKE2B 358fae45a4332c10ba59d65d09ae51f28fb7fc026e137289c47951536753796e0b7efa9f3713bccde68e6260f79b1132eb00357be8c53fba04f3c827e97851cf SHA512 08b8ec7c1fbe5f1b8f95f95677012eeb9bd83951ee320470a0da852e0a446818e48ede7de045f6d7b98dff8be139fa69d780dbf03e65904c773f8ec1493f9915
 DIST lollypop-1.2.33.tar.xz 509636 BLAKE2B 850f24e14cd574710f0712389a1db96380eb1058fbb76e0353d9f6aa66978754bd30e4584fd3f50724909796247ec894c8f0c0b1cb1476ed0935596a0edcefe6 SHA512 f5e77e7427f1ef4db05f8ffc1f0f2fd3c412ea22b433a7b0a9de7e0159b0172012478dfb2cd1a39df27c07bcd1dd55fdb14a430d9cf8b04aa77ff7befc92c95b
+DIST lollypop-1.2.34.tar.xz 509768 BLAKE2B 7f1daaa5c4906a947f4ff45d9f961fe129277c3829744321436289cea1958e9aee0a9ece610a7e9a55c06526395a0208fe8a12762e50cc9bdc3a3b0362aca931 SHA512 dc0420984efb859279e6cfb3b8967a30a5b5ff124c990ad73951b6f47cb1a34dde2bb54667b321e3609c3e13233c9efda02caa9920b00e48de123a553d885114
diff --git a/media-sound/lollypop/lollypop-1.2.34.ebuild b/media-sound/lollypop/lollypop-1.2.34.ebuild
new file mode 100644 (file)
index 0000000..06db306
--- /dev/null
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+PYTHON_REQ_USE="sqlite"
+inherit python-single-r1 gnome2-utils meson xdg-utils
+
+DESCRIPTION="Modern music player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Lollypop"
+SRC_URI="https://adishatz.org/${PN}/${P}.tar.xz"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-3"
+SLOT="0"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DEPEND="${PYTHON_DEPS}
+       dev-libs/appstream-glib[introspection]
+       dev-libs/glib:2
+       dev-libs/gobject-introspection[cairo(+)]
+       $(python_gen_cond_dep '
+               dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+               dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+       ')
+       gnome-base/gnome-common
+       x11-libs/gtk+:3
+"
+BDEPEND="${DEPEND}
+       $(python_gen_cond_dep '
+               dev-python/pkgconfig[${PYTHON_MULTI_USEDEP}]
+       ')
+       dev-util/desktop-file-utils
+       dev-util/itstool
+       dev-util/intltool
+"
+RDEPEND="${DEPEND}
+       app-crypt/libsecret[introspection]
+       dev-libs/totem-pl-parser
+       $(python_gen_cond_dep '
+               dev-python/beautifulsoup:4[${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python
+               dev-python/pillow[${PYTHON_MULTI_USEDEP}]
+               >=dev-python/pylast-1.0.0[${PYTHON_MULTI_USEDEP}]
+       ')
+       media-libs/gst-plugins-base:1.0[introspection]
+"
+
+RESTRICT="test"
+
+pkg_preinst() {
+       gnome2_schemas_savelist
+}
+
+src_install() {
+       meson_src_install
+       python_optimize
+}
+
+pkg_postinst() {
+       gnome2_gconf_install
+       gnome2_schemas_update
+       xdg_desktop_database_update
+}
+
+pkg_postrm() {
+       gnome2_gconf_uninstall
+       gnome2_schemas_update
+       xdg_desktop_database_update
+}