dev-python/joblib-0.14.1: Version bump
authorPatrick McLean <patrick.mclean@sony.com>
Wed, 1 Apr 2020 20:18:38 +0000 (13:18 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 1 Apr 2020 21:04:06 +0000 (14:04 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/joblib/Manifest
dev-python/joblib/joblib-0.14.1.ebuild [new file with mode: 0644]

index c6acfacd6fc254023b807189b98237a42ab66b30..af3ac1f1dc3e514bb485af128b67841531e49fed 100644 (file)
@@ -1 +1,2 @@
 DIST joblib-0.12.2.tar.gz 289249 BLAKE2B 247a8bce753ece235877540b829bdc9546b3a6d7610b09592217bf9d47fd038a5e75f649224b76832825e77d76ae46443984de3d83558cdbd4d816d8f610e8b0 SHA512 9bf93c89681f59d17e735c228d3379df5dff67b4365b59ddea1a062f9547c376e5870e4ece83af8e7cda1ae30e2a2893a4a009e03b7fec798d3574e8ab060267
+DIST joblib-0.14.1.tar.gz 338930 BLAKE2B 6b84c43be8b8d32f28a3dbc3e6f4ce15574cf20571805501972d162d4b076c1fe144a9790b8132821f0acd439c8859873038813c7bdd4163d0535eca36a1a8fa SHA512 079eb4321ed95c8f05399abca2a1c46ecb7c28fe9a3a50b6eb106a2bd2f3566fb25bca59022fafbfcee5069f078921421d799eeb29a796f8f98881491cf9be08
diff --git a/dev-python/joblib/joblib-0.14.1.ebuild b/dev-python/joblib/joblib-0.14.1.ebuild
new file mode 100644 (file)
index 0000000..ccc27ee
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tools to provide lightweight pipelining in Python"
+HOMEPAGE="https://joblib.readthedocs.io/en/latest/
+       https://github.com/joblib/joblib"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+       test? (
+               dev-python/threadpoolctl[${PYTHON_USEDEP}]
+       )
+"
+
+distutils_enable_sphinx doc \
+       'dev-python/numpy' \
+       'dev-python/matplotlib' \
+       'dev-python/pillow' \
+       'dev-python/sphinx-gallery' \
+       'dev-python/numpydoc' \
+       'dev-python/pandas' \
+       'dev-python/lz4' \
+       'dev-python/distributed'
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+       sed -e "s:'_static/joblib_logo_examples.png':'doc/_static/joblib_logo_examples.png':" \
+               -i doc/conf.py || die
+
+       # tries to fetch from the internet
+       rm examples/compressors_comparison.py \
+               examples/parallel/distributed_backend_simple.py || die
+
+       distutils-r1_python_prepare_all
+}