dev-python/requests-toolbelt: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sun, 29 Mar 2020 07:10:50 +0000 (09:10 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 29 Mar 2020 07:30:40 +0000 (09:30 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/requests-toolbelt/Manifest
dev-python/requests-toolbelt/requests-toolbelt-0.8.0.ebuild [deleted file]

index 6a6cddf9cc5cd792703517d0bc4f1373b9bab6fc..619cd63f19ca7ecf4256d37fb036056556f88e29 100644 (file)
@@ -1,2 +1 @@
-DIST requests-toolbelt-0.8.0.tar.gz 196129 BLAKE2B 435059ff2879c44a274641c49adae9986c761fcabe567826454d3f055db7e3e5c95905f1d178dcb37e2173bf856a9fb168a856c1301026e8c5d0de6cafb4be51 SHA512 71a4ed8961b742cb1b5b0deec7f9052a2a177d2ed6e4f13ebe22b56b7f1b6b1bad2736f1640c8b41398b082eddc1c1205f0c446602d979d5bf370fb0e10ecc88
 DIST requests-toolbelt-0.9.1.tar.gz 207286 BLAKE2B 6123677a9abafebddf7dffde2150b2426b5132ebe0c330ff891322ecc3d69232a5b15a0c66e3e1fb4832dc04f5a636a939613fba041e499e9fbca9814f548c7e SHA512 12229928df5df71cb57bc65ef453dc0e4a2bbe190c1579811b2c2823673bd81aeba856b00000fa20b253d0f0fa4fff55ea1e750794ca3785f71c376b1df7fd93
diff --git a/dev-python/requests-toolbelt/requests-toolbelt-0.8.0.ebuild b/dev-python/requests-toolbelt/requests-toolbelt-0.8.0.ebuild
deleted file mode 100644 (file)
index 7fc33e2..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="A utility belt for advanced users of python-requests"
-HOMEPAGE="https://toolbelt.readthedocs.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-IUSE="test"
-
-RDEPEND="<dev-python/requests-3.0.0[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/betamax[${PYTHON_USEDEP}]
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-       )"
-
-DOCS=( AUTHORS.rst HISTORY.rst README.rst )
-PATCHES=(
-       "${FILESDIR}/requests-toolbelt-0.8.0-test-tracebacks.patch"
-)
-
-# Known python2.7 test failures do to upstream
-# not testing with newer requests versions
-# bug: https://bugs.gentoo.org/635824
-# https://github.com/requests/toolbelt/issues/213
-RESTRICT=test
-
-python_test() {
-       py.test -v || die "Tests failed with ${EPYTHON}"
-}