Fix dependencies. Set PYTHON_MODNAME and use distutils_pkg_postinst() and distutils_p...
authorMarkos Chandras <hwoarang@gentoo.org>
Fri, 6 Jan 2012 21:28:06 +0000 (21:28 +0000)
committerMarkos Chandras <hwoarang@gentoo.org>
Fri, 6 Jan 2012 21:28:06 +0000 (21:28 +0000)
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64

dev-python/pyconstruct/ChangeLog
dev-python/pyconstruct/pyconstruct-2.06.ebuild

index 0e1d9f8a5a5d4ae36642d74d03c176cea0c668a2..ab36951b74f3fa66e4b5161b969fdf1aa7bbb312 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for dev-python/pyconstruct
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/ChangeLog,v 1.4 2011/12/25 11:11:00 patrick Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/ChangeLog,v 1.5 2012/01/06 21:28:06 hwoarang Exp $
+
+  06 Jan 2012; Markos Chandras <hwoarang@gentoo.org> pyconstruct-2.06.ebuild:
+  Fix dependencies. Set PYTHON_MODNAME and use distutils_pkg_postinst() and
+  distutils_pkg_postrm(). Patch by Arfrever.
 
 *pyconstruct-2.06 (25 Dec 2011)
 
index 39f06b3dcdbe366c3543f9f41cb75f1c64ef99aa..7c8977eca70d72da7d517d54b739178d22c1a22f 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/pyconstruct-2.06.ebuild,v 1.1 2011/12/25 11:11:00 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/pyconstruct-2.06.ebuild,v 1.2 2012/01/06 21:28:06 hwoarang Exp $
 
 EAPI="3"
 PYTHON_DEPEND="2:2.5"
@@ -21,12 +21,14 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="doc"
 
-DEPEND="app-arch/unzip
+DEPEND="dev-python/setuptools
        doc? ( dev-python/sphinx )"
 RDEPEND=""
 
 S="${WORKDIR}/${MY_P}"
 
+PYTHON_MODNAME="construct"
+
 src_compile() {
        distutils_src_compile
 
@@ -44,11 +46,3 @@ src_install() {
                dohtml -r docs/_build/html/* || die "Installation of documentation failed"
        fi
 }
-
-pkg_postinst() {
-       python_mod_optimize construct
-}
-
-pkg_postrm() {
-       python_mod_cleanup construct
-}