media-sound/entagged-tageditor: Bump to EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Sat, 9 Nov 2019 21:45:48 +0000 (22:45 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 9 Nov 2019 21:45:48 +0000 (22:45 +0100)
Closes: https://bugs.gentoo.org/697270
Signed-off-by: Michał Górny <mgorny@gentoo.org>
media-sound/entagged-tageditor/entagged-tageditor-0.35.ebuild
media-sound/entagged-tageditor/files/entagged-tageditor-0.35-buildfixes.patch

index e5316f528a5a4734b2d0aca9885a49e531000a00..1113fa708d1e246c92ac5a0bcfe5c202facbb246 100644 (file)
@@ -1,15 +1,15 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
-inherit eutils java-pkg-2 java-ant-2
+inherit desktop java-pkg-2 java-ant-2
 
 DESCRIPTION="Open-source audiofile tagger"
 HOMEPAGE="http://entagged.sourceforge.net/"
 SRC_URI="mirror://gentoo/${P}.tar.gz"
 
-LICENSE="|| ( GPL-2 LGPL-2.1 )"
+LICENSE="GPL-2+ LGPL-2.1+"
 SLOT="0"
 KEYWORDS="~amd64"
 IUSE=""
@@ -17,23 +17,23 @@ IUSE=""
 S="${WORKDIR}"
 
 RDEPEND=">=virtual/jre-1.5
-       dev-java/squareness-jlf
-       dev-db/hsqldb"
+       dev-java/squareness-jlf:0
+       dev-db/hsqldb:0"
 
 DEPEND=">=virtual/jdk-1.5
-       dev-db/hsqldb"
+       dev-db/hsqldb:0"
 
 EANT_BUILD_XML="entagged/build.xml"
 EANT_BUILD_TARGET="build"
 
-src_unpack() {
-       unpack ${A}
+src_prepare() {
+       java-pkg-2_src_prepare
        mkdir -p test/entagged/junit || die
        mv entagged/entagged/junit test/entagged || die
        rm entagged/*.jar || die
        java-pkg_jarfrom hsqldb hsqldb.jar entagged/hsqldb.jar
        cd entagged || die
-       epatch "${FILESDIR}"/${P}-buildfixes.patch
+       eapply "${FILESDIR}"/${P}-buildfixes.patch
 }
 
 src_install() {
index 7b470e2dbeb5fb3c48ab0640985aa28c78503803..709b16b32a588a6b885d4fec01af6a0d1647374c 100644 (file)
@@ -1,5 +1,5 @@
---- build.xml  2007-03-23 16:25:25.000000000 +0200
-+++ build.xml.fixed    2007-09-01 09:20:44.000000000 +0300
+--- a/build.xml        2007-03-23 16:25:25.000000000 +0200
++++ b/build.xml        2007-09-01 09:20:44.000000000 +0300
 @@ -30,7 +30,7 @@
        <property name="entagged_dir" location="."/>\r
        <property name="entagged_base_dir" location=".."/>\r