dev-python/astroid: disable pytest-runner
authorVirgil Dupras <vdupras@gentoo.org>
Fri, 1 Feb 2019 13:19:49 +0000 (08:19 -0500)
committerVirgil Dupras <vdupras@gentoo.org>
Fri, 1 Feb 2019 13:19:49 +0000 (08:19 -0500)
Makes build fail under network sandbox.

Closes: https://bugs.gentoo.org/677042
Closes: https://bugs.gentoo.org/672628
Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

dev-python/astroid/astroid-2.1.0.ebuild
dev-python/astroid/files/astroid-2.1.0-no-pytest-runner.patch [new file with mode: 0644]

index b23580f1816206916f67fdea862f0c1f925b628c..5f03bf78ac6b1c2f6b1c248ae13d171c998749ea 100644 (file)
@@ -34,6 +34,7 @@ DEPEND="
 
 PATCHES=(
        "${FILESDIR}/${PN}-2.1.0-fix-tests.patch"
+       "${FILESDIR}/${PN}-2.1.0-no-pytest-runner.patch"
 )
 
 python_prepare_all() {
diff --git a/dev-python/astroid/files/astroid-2.1.0-no-pytest-runner.patch b/dev-python/astroid/files/astroid-2.1.0-no-pytest-runner.patch
new file mode 100644 (file)
index 0000000..94eda17
--- /dev/null
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py
+index 2ad90aac..4628a40f 100644
+--- a/setup.py
++++ b/setup.py
+@@ -42,7 +42,6 @@ def install():
+                  install_requires = install_requires,
+                  extras_require=extras_require,
+                  packages=find_packages(exclude=['astroid.tests']) + ['astroid.brain'],
+-                 setup_requires=['pytest-runner'],
+                  test_suite='test',
+                  tests_require=['pytest'],
+                  )