dev-haskell/aeson-compat: new package, a depend of dev-haskell/persistent-template...
authorSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 08:45:16 +0000 (08:45 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 10:21:57 +0000 (10:21 +0000)
Compatibility layer for aeson

Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-haskell/aeson-compat/Manifest [new file with mode: 0644]
dev-haskell/aeson-compat/aeson-compat-0.3.6.ebuild [new file with mode: 0644]
dev-haskell/aeson-compat/metadata.xml [new file with mode: 0644]

diff --git a/dev-haskell/aeson-compat/Manifest b/dev-haskell/aeson-compat/Manifest
new file mode 100644 (file)
index 0000000..2126bd4
--- /dev/null
@@ -0,0 +1 @@
+DIST aeson-compat-0.3.6.tar.gz 8956 SHA256 7aa365d9f44f708f25c939489528836aa10b411e0a3e630c8c2888670874d142 SHA512 2d2bd172a1335886894df73fbb999ce5b8ae5ff710866560278b4bcf27a5ef4a2ff025a0a97cc4f764e85819bf6a9771bdaf7acbd830f1baee5f3133ff5c185d WHIRLPOOL a3f4dec58f7a97619a6e05659c063e6c4b285aa6acc574ac4c699571e73308b90ddaf41a3563737ae5366addb8ea2eed9b7d931bd661ee1f1bf3d4bea0e7fe0d
diff --git a/dev-haskell/aeson-compat/aeson-compat-0.3.6.ebuild b/dev-haskell/aeson-compat/aeson-compat-0.3.6.ebuild
new file mode 100644 (file)
index 0000000..10df549
--- /dev/null
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Compatibility layer for aeson"
+HOMEPAGE="https://github.com/phadej/aeson-compat#readme"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.7.0.6:=[profile?] <dev-haskell/aeson-1.1:=[profile?]
+       >=dev-haskell/attoparsec-0.12:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
+       >=dev-haskell/base-compat-0.6.0:=[profile?] <dev-haskell/base-compat-0.10:=[profile?]
+       >=dev-haskell/exceptions-0.8:=[profile?] <dev-haskell/exceptions-0.9:=[profile?]
+       >=dev-haskell/hashable-1.2:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
+       >=dev-haskell/nats-1:=[profile?] <dev-haskell/nats-1.2:=[profile?]
+       >=dev-haskell/scientific-0.3:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+       >=dev-haskell/semigroups-0.16.2.2:=[profile?] <dev-haskell/semigroups-0.19:=[profile?]
+       >=dev-haskell/tagged-0.7.3:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
+       >=dev-haskell/text-1.2:=[profile?] <dev-haskell/text-1.3:=[profile?]
+       >=dev-haskell/time-locale-compat-0.1.0.1:=[profile?] <dev-haskell/time-locale-compat-0.2:=[profile?]
+       >=dev-haskell/unordered-containers-0.2:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+       >=dev-haskell/vector-0.10:=[profile?] <dev-haskell/vector-0.12:=[profile?]
+       >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.18.1.3
+       test? ( >=dev-haskell/base-orphans-0.4.5 <dev-haskell/base-orphans-0.6
+               >=dev-haskell/quickcheck-2.7.6
+               >=dev-haskell/quickcheck-instances-0.3 <dev-haskell/quickcheck-instances-0.3.13
+               >=dev-haskell/tasty-0.10 <dev-haskell/tasty-0.12
+               >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.10
+               >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.9 )
+"
+
+src_prepare() {
+       default
+
+       cabal_chdeps \
+               'QuickCheck            >=2.7.6 && <2.9.2' 'QuickCheck            >=2.7.6'
+}
diff --git a/dev-haskell/aeson-compat/metadata.xml b/dev-haskell/aeson-compat/metadata.xml
new file mode 100644 (file)
index 0000000..335b9b6
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>haskell@gentoo.org</email>
+               <name>Gentoo Haskell</name>
+       </maintainer>
+       <longdescription>
+               Compatibility layer for @aeson@
+       </longdescription>
+</pkgmetadata>