net-vpn/mullvad-netns: New package
authorPatrick McLean <chutzpah@gentoo.org>
Mon, 6 Apr 2020 02:44:23 +0000 (19:44 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Mon, 6 Apr 2020 02:45:08 +0000 (19:45 -0700)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
net-vpn/mullvad-netns/Manifest [new file with mode: 0644]
net-vpn/mullvad-netns/metadata.xml [new file with mode: 0644]
net-vpn/mullvad-netns/mullvad-netns-0.1.ebuild [new file with mode: 0644]
net-vpn/mullvad-netns/mullvad-netns-9999.ebuild [new file with mode: 0644]

diff --git a/net-vpn/mullvad-netns/Manifest b/net-vpn/mullvad-netns/Manifest
new file mode 100644 (file)
index 0000000..4d209a6
--- /dev/null
@@ -0,0 +1 @@
+DIST mullvad-netns-0.1.tar.gz 12068 BLAKE2B 658f3e050b66028712bc611f42a6b193d482e5d9a9d398d703dbd2e0cdef6a7f94dd614198cf36548d3b1f4eb0f70bc1c9beb34c96e6b4e2e04520fb5544b618 SHA512 de923d3d97fd5689022fea821aa93ee74e3057e50842804da84c8ab6962722ed0000bac61bdbd3c188c6eeda8960345fa6609da5f55e90ee5a49f50bbc7c4838
diff --git a/net-vpn/mullvad-netns/metadata.xml b/net-vpn/mullvad-netns/metadata.xml
new file mode 100644 (file)
index 0000000..126b9ca
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <name>Patrick McLean</name>
+               <email>chutzpah@gentoo.org</email>
+       </maintainer>
+</pkgmetadata>
diff --git a/net-vpn/mullvad-netns/mullvad-netns-0.1.ebuild b/net-vpn/mullvad-netns/mullvad-netns-0.1.ebuild
new file mode 100644 (file)
index 0000000..cefae0c
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} =~ [9]{4,} ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/chutz/mullvad-netns.git"
+else
+       SRC_URI="https://github.com/chutz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Script to run a command within a Mullvad network namespace"
+HOMEPAGE="https://github.com/chutz/mullvad-netns"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="
+       app-misc/jq
+       app-shells/bash
+       net-misc/curl[ipv6,ssl]
+       net-vpn/wireguard-tools
+       sys-apps/baselayout
+       sys-apps/coreutils
+       sys-apps/grep
+       sys-apps/iproute2[ipv6]
+       sys-apps/util-linux
+"
+BDEPEND="
+       sys-apps/coreutils
+       sys-devel/make
+"
diff --git a/net-vpn/mullvad-netns/mullvad-netns-9999.ebuild b/net-vpn/mullvad-netns/mullvad-netns-9999.ebuild
new file mode 100644 (file)
index 0000000..caf1067
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} =~ [9]{4,} ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/chutz/mullvad-netns.git"
+else
+       SRC_URI=""
+       die
+fi
+
+DESCRIPTION="Script to run a command within a Mullvad network namespace"
+HOMEPAGE="https://github.com/chutz/mullvad-netns"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="
+       app-misc/jq
+       app-shells/bash
+       net-misc/curl[ipv6,ssl]
+       net-vpn/wireguard-tools
+       sys-apps/baselayout
+       sys-apps/coreutils
+       sys-apps/grep
+       sys-apps/iproute2[ipv6]
+       sys-apps/util-linux
+"
+BDEPEND="
+       sys-apps/coreutils
+       sys-devel/make
+"