dev-python/setuptools: Bump to 47.1.1
authorMichał Górny <mgorny@gentoo.org>
Fri, 29 May 2020 07:23:06 +0000 (09:23 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 29 May 2020 07:25:00 +0000 (09:25 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/setuptools/Manifest
dev-python/setuptools/setuptools-47.1.1.ebuild [new file with mode: 0644]
profiles/package.mask

index b559fac4d6ad54809ef2c24eefbe914f28baf716..79bb5b30b4c48e06156f9667e9bbeeede98623c4 100644 (file)
@@ -1,3 +1,4 @@
 DIST setuptools-44.0.0.zip 858893 BLAKE2B 02ba2a838487ba9e80d9ca3b8598cecbec4d286f2734be439d2b73f3f7f0ca80e80ea71a0c2322093deb548503c82d6eb32b1585992979b053f14f49baa00baa SHA512 bb48e7763d258e654472bc416d16ec8708eefa95d1eb03cb6e81b623fd636cefc51a0bd67887084ab0214e256e2030a8f655184c3b59ad6937abab6a6178f3a1
 DIST setuptools-44.1.0.zip 858569 BLAKE2B f59f154e121502a731e51294ccd293d60ffccadacf51e23b53bf7ceba38858948b86783238061136c827ac3373ea7ea8e6253d4bb53f3f1dd69284568ec65a68 SHA512 4dfb0f42d334b835758e865a26ecd1e725711fa2b9c38ddc273b8b3849fba04527bc97436d11ba1e98f1a42922aa0f0b9032e32998273c705fac6e10735eacbf
 DIST setuptools-46.4.0.zip 865912 BLAKE2B 452d36132f5648c79c7e1616a93ff6a39ab2f64b2864ee397b4f57e7f72c47d418ff274f5decd35b0591b09800ad2a7cbd71c283550bd0e60a4d85744a57d4ec SHA512 31e58fd1d682089a45d23aa07c3c2c4c952ca016fa4c3416b2cba979d8b57369f80baef98ce857912e506e87d6cb456497a1ce1c75a0cdf1ee25d4e753b58726
+DIST setuptools-47.1.1.zip 870277 BLAKE2B 0ba55f2b51011d4f98a554a959227dba83a79e7369a3cd54450a1d18cb378bf7cfaffc1aa25b0ee11760e917d6f74891f0a63e43478893ca4327e0f5135267dc SHA512 053ffd4c26bf0cf1894754b1ed922be03c6fa2cb54a41e3d28a7d8f7a2fdf2ccebbca4e0bafa16eed476923ef70cf4294ed36df6e77603b2fae0a09b684132c4
diff --git a/dev-python/setuptools/setuptools-47.1.1.ebuild b/dev-python/setuptools/setuptools-47.1.1.ebuild
new file mode 100644 (file)
index 0000000..69172f4
--- /dev/null
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://github.com/pypa/setuptools https://pypi.org/project/setuptools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+       app-arch/unzip
+       test? (
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/pip[${PYTHON_USEDEP}]
+               >=dev-python/pytest-3.7.0[${PYTHON_USEDEP}]
+               dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+               dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+               dev-python/wheel[${PYTHON_USEDEP}]
+       )
+"
+PDEPEND="
+       >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]"
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( {CHANGES,README}.rst docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
+
+python_prepare_all() {
+       # disable tests requiring a network connection
+       rm setuptools/tests/test_packageindex.py || die
+
+       # don't run integration tests
+       rm setuptools/tests/test_integration.py || die
+
+       # xpass-es for me on py3
+       #sed -e '/xfail.*710/s:(:(six.PY2, :' \
+       #       -i setuptools/tests/test_archive_util.py || die
+
+       # avoid pointless dep on flake8
+       sed -i -e 's:--flake8::' pytest.ini || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       distutils_install_for_testing
+       # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+       # It tries to sandbox the test in a tempdir
+       HOME="${PWD}" pytest -vv ${PN} || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+       export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+       distutils-r1_python_install
+}
index 9563311a1f101d8ab079e2c9e76d8b69ecdd5424..a165a68f8e978f63cd822fd7d90922120c0eec4d 100644 (file)
@@ -589,6 +589,7 @@ www-plugins/passff
 # changes.  Let's mask it to reduce the noise, and hopefully try to get
 # python2_7 out of default PYTHON_TARGETS first.
 ~dev-python/setuptools-46.1.3
+>=dev-python/setuptools-47
 
 # Ulrich Müller <ulm@gentoo.org> (2020-01-06)
 # Snapshots from Git and pretest versions, masked for testing.