dev-python/scrypt: Bump to 0.8.15
authorMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 15:42:22 +0000 (17:42 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 15:56:11 +0000 (17:56 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/scrypt/Manifest
dev-python/scrypt/scrypt-0.8.15.ebuild [new file with mode: 0644]

index de111057d8a6ba06f239991cb9f29d27e4bb9d69..cb2c67e90b1e9822dead2dfacfe05bd767e09195 100644 (file)
@@ -1 +1,2 @@
 DIST scrypt-0.8.13.tar.gz 53606 BLAKE2B 924b870d2dd5d8dc6765ab2679e71a819fb08a75cfdb0e7a6cfa9c305f35a376892e78607007013d9dc7d9a6b2bc6420019f8b27fadc7f468b3b2fd685a1c3ff SHA512 a65e24b0a7dbe02e16c0b38b52c66549f36370e267aacf348a107cb980221806ca783cee0caa95ab6af978dd2b0d8efdb6b06798bb43742d4623bd8f6535e9a5
+DIST scrypt-0.8.15.tar.gz 53954 BLAKE2B 9f9bfc6ead25f14b9b3194853cd64a7b2244685d15a7d257e2395b0acf3fb968487fffc5d5eb5a245de1518b0740483d3e6feed841282b40ecec86ce178de46e SHA512 db5f688b341f816935a0fd5a538d8633a1e43c69c7228d9fc127459c9673528f92405170339a5a43eca86eb5a2ea17b951ac16a203993e452e05f2589914a66f
diff --git a/dev-python/scrypt/scrypt-0.8.15.ebuild b/dev-python/scrypt/scrypt-0.8.15.ebuild
new file mode 100644 (file)
index 0000000..fbfdea1
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Bindings for the scrypt key derivation function library"
+HOMEPAGE="https://github.com/holgern/py-scrypt/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="libressl"
+
+RDEPEND="
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest